Package Details: qstlink2-git 1:1.3.0.r261.6c4be10-1

Git Clone URL: https://aur.archlinux.org/qstlink2-git.git (read-only, click to copy)
Package Base: qstlink2-git
Description: A ST-Link V2 (Debugger/Programmer) client graphical user interface
Upstream URL: https://github.com/fpoussin/QStlink2
Licenses: GPL3
Conflicts: qstlink, qstlink2, qstlink2-svn
Provides: qstlink2
Submitter: SpotlightKid
Maintainer: SpotlightKid
Last Packager: SpotlightKid
Votes: 10
Popularity: 0.098019
First Submitted: 2015-02-12 15:37
Last Updated: 2020-05-06 20:00

Dependencies (4)

Required by (0)

Sources (2)

Latest Comments

SpotlightKid commented on 2020-05-06 20:01

@Yinameah: Fixed. Thanks for reporting!

Yinameah commented on 2020-05-06 17:10

I just installed this package. The build wouldn't succeed without an extra dependency : community/hidapi

Not sure if it's build dep only on needed to run, but should be added somewhere I belive.

Best regards and big up to the maintainer

SpotlightKid commented on 2017-03-06 09:19

You're right, it seems that I uploaded a .SRCINFO file with a wrong version number for the previous package release, sorry. I'm not sure how that happened.

I fixed this by setting the package epoch to 1.

korken89 commented on 2017-03-06 08:39

Hi, the version of the package seems of, no matter how may times I update it does not go to 1.3.0, after compile it is 1.2.4 again. Please have a look, a snip from the install:

........
==> Making package: qstlink2-git 1.3.0.r228.8e30cfa-1 (mon mar 6 09:32:33 CET 2017)
........
==> Finished making: qstlink2-git 1.2.4.r244.24a687a-1 (mon mar 6 09:32:48 CET 2017)

SpotlightKid commented on 2016-08-16 04:13

@kyb: fixed

kyb commented on 2016-08-15 22:09

==> ОШИБКА: Переменная 'pkgver' не должна содержать двоеточий, дефисов или пробелов.
==> ERROR: Variable 'pkgver' must not contain ':' '-' 'space'.

I FIXED it with
ver="${ver//-/_}"