Package Details: qtwebkit 2.3.4-7

Git Clone URL: https://aur.archlinux.org/qtwebkit.git (read-only)
Package Base: qtwebkit
Description: An open source web browser engine (Qt port)
Upstream URL: http://trac.webkit.org/wiki/QtWebKit
Licenses: GPL3, LGPL2.1
Conflicts: qt<4.8
Submitter: arojas
Maintainer: fbrennan
Last Packager: FredBezies
Votes: 54
Popularity: 1.107638
First Submitted: 2017-02-09 07:52
Last Updated: 2018-07-07 22:15

Sources (6)

Pinned Comments

FredBezies commented on 2018-02-05 17:10

@alban : so just use qtwebkit-bin package.

By the way, last time I build this package successfully? January 15th, 2018.

fred@fredo-arch ~ % pacman -Qi qtwebkit

name : qtwebkit

Version : 2.3.4-6

Description : An open source web browser engine (Qt port)

Architecture : x86_64

URL : http://trac.webkit.org/wiki/QtWebKit

Licenses : LGPL2.1 GPL3

Groups : None

Provides : None

Depends On : qt4 systemd gst-plugins-base-libs

Optional Deps : None

Required By : google-musicmanager

Optional For : None

Conflicts With : qt<4.8

Replaces : None

Installed Size : 35.26 MiB

Packager : Unknown Packager

Build Date : Mon Jan 15 10:41:57 2018

Install Date : Mon Jan 15 10:47:06 2018

Install Reason : Explicitly installed

Install Script : No

Validated By : None

Latest Comments

« First ‹ Previous ... 9 10 11 12 13 14

Darkhogg commented on 2017-02-20 22:20

This package needs "flex" added to makedepends.

ArchUser01020 commented on 2017-02-20 16:24

package not found using yaourt

Scimmia commented on 2017-02-20 15:31

Please don't bump the pkgrel for changes that don't affect the final package. There's no reason for people to update to -5 if they already have -4.

FredBezies commented on 2017-02-16 09:29

@metak : sorry for late answer. Will look at your issue. I built qtwebkit 2.3.4-4 on my archlinux flawlessly.

Will report asap.

Feb. 20, 2017 : patch added. Can you try again, please?

metak commented on 2017-02-09 19:16

Hello. When building this package it failed with this error:

/QtWebKit -I/usr/src/packages/BUILD/qtwebkit/src/qtwebkit-2.3.4/Source/WTF -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/src/packages/BUILD/qtwebkit/src/qtwebkit-2.3.4/Source/WebKit/qt/declarative -I. -o obj/release/qdeclarativewebview.o /usr/src/packages/BUILD/qtwebkit/src/qtwebkit-2.3.4/Source/WebKit/qt/declarative/qdeclarativewebview.cpp
[ 8582s] In file included from /usr/src/packages/BUILD/qtwebkit/src/qtwebkit-2.3.4/Source/WebKit/qt/declarative/qdeclarativewebview_p.h:29:0,
[ 8582s] from /usr/src/packages/BUILD/qtwebkit/src/qtwebkit-2.3.4/Source/WebKit/qt/declarative/qdeclarativewebview.cpp:21:
[ 8582s] ../../../../include/QtWebKit/qgraphicswebview.h:1:87: fatal error: ../../../../../../../../../../../../Source/WebKit/qt/Api/qgraphicswebview.h: No such file or directory
[ 8582s] #include "../../../../../../../../../../../../Source/WebKit/qt/Api/qgraphicswebview.h"
[ 8582s] ^
[ 8582s] compilation terminated.

Here's also bug report for it in debian along with a patch to fix it.
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=784432

FredBezies commented on 2017-02-09 14:08

Adopting package as I'm using a software depending on it.