Package Details: quake4 1.4.2-5

Git Clone URL: https://aur.archlinux.org/quake4.git (read-only, click to copy)
Package Base: quake4
Description: Quake 4 Engine. You need the retail .pk4 files to play.
Upstream URL: https://web.archive.org/web/20061205073314/http://www.idsoftware.com/games/quake/quake4/
Licenses: custom:"Quake 4", custom:"PunkBuster"
Submitter: None
Maintainer: Slash
Last Packager: Slash
Votes: 55
Popularity: 0.024901
First Submitted: 2005-12-21 00:35 (UTC)
Last Updated: 2021-09-09 01:33 (UTC)

Latest Comments

johnnybash commented on 2021-12-05 18:46 (UTC)

@crazyraven: if you are using pipewire, you have to install lib32-pipewire.

crazyraven commented on 2021-11-11 15:34 (UTC) (edited on 2021-11-11 15:35 (UTC) by crazyraven)

Hi

Quake 4 works fine but no sound.

anyone have same issue as mine?

Thank you

FYI.

-------- Initializing Sound System ---------- sound system initialized.


Luca91 commented on 2021-11-10 21:20 (UTC)

@jmsq Sorry I totally forgot to reply. I've cleaned the yay cache an tried again to install. It worked. Thanks :)

jmsq commented on 2021-10-04 04:22 (UTC)

@Luca91 I just tested making it again and it works just fine; maybe a localized machine issue?

Luca91 commented on 2021-10-02 17:20 (UTC)

This package is now broken for me :( I can't update it anymore, and I can't even install it from scratch. I got a package error just after the "Uncompressing Quake 4 (TM)" step.

Am I the only one experiencing this issue?

Thank you very much

Slash commented on 2021-08-26 23:22 (UTC)

I updated the PKGBUILD to modernize the dependency list for multi-arch.

@johnnybash: See the updated version. I kept i686 compatibility so people using Arch Linux 32 (or other Arch derivatives that support 32bit) could still use it.

johnnybash commented on 2021-08-25 15:56 (UTC)

if its just about removing the i686 stuff, I can help you out.

otherwise makepkg installs lib32-sdl just fine for me?!

Slash commented on 2021-08-24 21:49 (UTC)

It is in the PKGBUILD, it is just defined in an older way. I will update it when I get a chance or I can add co-maintainers.

jmsq commented on 2021-08-06 12:39 (UTC)

PKGBUILD is missing lib32-sdl build dependency.

test0 commented on 2017-09-30 07:55 (UTC)

I had to install lib32-libpulse to get sound to work.

hollunder commented on 2017-08-25 05:35 (UTC) (edited on 2017-08-25 05:43 (UTC) by hollunder)

Never mind, thanks zanny! ---- Any suggestions? Btw., it's 4GB VRAM. Radeon Rx 560. Not surprised it can't load radeonsi as I am using AMDGPU. I didn't install any language other than english because they were not included in the download from GOG. ---- /proc/cpuinfo CPU frequency: 2200 MHz detecting video ram ( set sys_videoRam to force ) .. guess failed, return default low-end VRAM setting ( 64MB VRAM ) Detected 2.20 GHz CPU 16048 MB of System memory 64 MB of Video memory on an optimal video architecture ... boosting AMD chip This system qualifies for Low quality. -------- Initializing renderSystem ---------- using ARB renderSystem renderSystem initialized. --------------------------------------------- Found default language English with VO .... found additional language 'french' without VO .... found additional language 'italian' without VO .... found additional language 'spanish' without VO 696 strings read from strings/english_code.lang 1794 strings read from strings/english_guis.lang 5756 strings read from strings/english_lips.lang 5759 strings read from strings/english_mappack.lang 6235 strings read from strings/english_maps.lang 3 strings read from strings/french_mappack.lang 3 strings read from strings/italian_mappack.lang 3 strings read from strings/spanish_mappack.lang Couldn't open journal files execing default.cfg couldn't exec editor.cfg couldn't exec Quake4Config.cfg couldn't exec autoexec.cfg -------- Initializing Sound System ---------- sound system initialized. --------------------------------------------- --------------- R_InitOpenGL ---------------- Initializing SDL subsystem Loading GL driver 'libGL.so.1' through SDL SDL_ListModes: 1920x1080 1680x1050 1600x900 1280x1024 1280x800 1280x720 1152x864 1024x768 832x624 800x600 720x576 720x480 720x400 640x480 SDL_ListModes are currently ignored for resolution filtering. Set r_useSDLModes to 1 if you want it libGL error: unable to load driver: radeonsi_dri.so libGL error: driver pointer missing libGL error: failed to load driver: radeonsi libGL error: unable to load driver: radeonsi_dri.so libGL error: driver pointer missing libGL error: failed to load driver: radeonsi libGL error: unable to load driver: swrast_dri.so libGL error: failed to load driver: swrast X Error of failed request: BadValue (integer parameter out of range for operation) Major opcode of failed request: 155 (GLX) Minor opcode of failed request: 3 (X_GLXCreateContext) Value in failed request: 0x0 Serial number of failed request: 42 Current serial number in output stream: 43 pure virtual method called terminate called without an active exception signal caught: Aborted si_code -6 Trying to exit gracefully.. pure virtual method called terminate called recursively double fault Aborted, bailing out

Gambier commented on 2016-11-06 18:58 (UTC)

==> ERROR: Failure while downloading http://www.1337-server.net/quake4/quake4-linux-1.4.2.x86.run.gz Server seems to be down.

zan commented on 2016-06-06 03:51 (UTC)

If you are getting the classic "libGL error: unable to load driver" with Quake 4, do what you do with Steam and delete libgcc_s.so.1 and libstdc++.so.6 from the /opt/quake4 directory so SDL uses the native libraries and it should work (it at least does for me).

MrEvilBreakfast commented on 2015-04-16 15:36 (UTC)

Ah thank you!

Slash commented on 2015-04-16 12:17 (UTC)

Change "sys_lang" to "english" in ~/.quake4/q4base/Quake4Config.cfg

MrEvilBreakfast commented on 2015-04-16 05:03 (UTC)

This is awesome and I've got it working just fine... but... The menus and everything are en espanol. I can guess where menu things are okay, but I'd much prefer english. Did I miss something in the build, or...?

Slash commented on 2015-04-01 19:53 (UTC)

Thanks for the heads up, I modernized the PKGBUILD.

obelix commented on 2015-04-01 11:46 (UTC)

makepkg complains about missing package() function and doesn't work at all.

commented on 2013-04-20 12:36 (UTC)

The site for the run file is down, a (slow & official) mirror here: ftp://ftp.idsoftware.com/idstuff/quake4/linux/

swiftgeek commented on 2011-12-12 08:44 (UTC)

Please disable compression of the package in the next release... it's pointless to compress compressed files. PKGEXT='.pkg.tar'

Slash commented on 2010-10-11 22:23 (UTC)

@songangel: I downloaded the binary and the md5sum still matches. I would recommend retrying the download or downloading with wget/curl and see if it helps.

commented on 2010-10-09 22:48 (UTC)

The MD5 doesnt match for the run binary or perhaps the server is down