Package Details: quickgui 1.2.8-1

Git Clone URL: https://aur.archlinux.org/quickgui.git (read-only, click to copy)
Package Base: quickgui
Description: A Flutter frontend for quickget and quickemu
Upstream URL: https://github.com/quickgui/quickgui
Licenses: unknown
Conflicts: quickgui
Provides: quickgui
Submitter: sgnh
Maintainer: sgnh
Last Packager: sgnh
Votes: 8
Popularity: 0.002465
First Submitted: 2021-11-10 13:11 (UTC)
Last Updated: 2022-11-21 21:18 (UTC)

Required by (2)

Sources (1)

Latest Comments

1 2 Next › Last »

Y2K350 commented on 2024-02-18 04:34 (UTC) (edited on 2024-02-18 04:34 (UTC) by Y2K350)

Same error as @hi-phile for me

hi-phile commented on 2023-10-24 20:50 (UTC) (edited on 2023-10-24 22:32 (UTC) by hi-phile)

I recently attempted to build this using yay, and it reported a flutter_localizations error, sorry if this is the wrong place to report this issue:

==> Extracting sources...
  -> Extracting quickgui-1.2.8.tar.xz with bsdtar
==> Sources are ready.
==> Making package: quickgui 1.2.8-1 (Tue 24 Oct 2023 01:31:54 PM PDT)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> WARNING: Using existing $srcdir/ tree
==> Starting build()...
Resolving dependencies... (2.0s)
Note: intl is pinned to version 0.18.1 by flutter_localizations from the flutter SDK.
See https://dart.dev/go/sdk-version-pinning for details.


Because every version of flutter_localizations from sdk depends on intl 0.18.1 and quickgui depends on intl ^0.17.0,
  flutter_localizations from sdk is forbidden.
So, because quickgui depends on flutter_localizations from sdk, version solving failed.


You can try the following suggestion to make the pubspec resolve:
* Try upgrading your constraint on intl: flutter pub add intl:^0.18.1
==> ERROR: A failure occurred in build().
    Aborting...
 -> error making: quickgui-exit status 4
 -> Failed to install the following packages. Manual intervention is required:
quickgui - exit status 4

flutter --version
Flutter 3.13.6 • channel stable • https://github.com/flutter/flutter.git
Framework • revision ead455963c (4 weeks ago) • 2023-09-26 18:28:17 -0700
Engine • revision a794cf2681
Tools • Dart 3.1.3 • DevTools 2.25.0

I tried quickgui-bin from AUR and that didn't report an error and was successfully installed.

sgnh commented on 2022-11-09 10:49 (UTC)

There's a mixup with the versions and URLs on Github. I think 1.2.5 was renamed to 1.2.6 and updated with a new binary release only (1.2.6). So there's no released source code for 1.2.6.

MoonSwan commented on 2022-03-28 16:11 (UTC) (edited on 2022-04-01 20:35 (UTC) by MoonSwan)

@sgnh, I did read the github page but I don't recall seeing anything about permissions issues I'll look again I guess. I was trying to install this application with yay and went through a few clean builds but unless I created that cache directory manually the install just plain failed and then it failed again saying it can't delete the flutter directory either. I did add myself to the flutterusers group so I thought that would fix the permissions issue but no luck. I'll read the github page again and try another build in a while.

Thanks for the quick response. :)

[Edit] Having re-read the github pages I still can't find what you're referring to? Could you please point me in the right direction?

sgnh commented on 2022-03-28 06:32 (UTC)

@MoonSwan if it can't create the cache directory then your permissions are wrong. You need to double-check that you didn't make any mistakes with the permissions and follow the instructions from the flutter package. You should at least be able to run "flutter doctor" before this package can build.

Also, I'm happy to help as much as I can but anyone with problems with how to install flutter might find better help in the flutter community.

MoonSwan commented on 2022-03-27 21:00 (UTC)

Tried building this as others said below by creating the /opt/flutter/bin/cache directory (because it couldn't create it by itself?!). I tried adding my user to the flutter group but that didn't work or help either. Chowning the relevant /opt/flutter directory didn't work either and someone below said it may cause future issues anyway. If I try to build the bin file it also fails a validity check. So, I'm at a loss as to how to install or build this from the AUR. Ideas?

ShalokShalom commented on 2022-02-17 18:09 (UTC)

You could replace Zenity with Qarma, for people on Qt based installations.

sgnh commented on 2021-11-25 23:13 (UTC)

@shayaknyc Yep you're right the package does require manual steps to fully configure flutter.

To get the file permissions right you can add your user to the flutterusers group as mentioned in the terminal and on the flutter page. Changing the permissions directly on /opt/flutter is likely to cause problems with the flutter package in the future.

Alternatively people can use the quickgui-bin package instead if configuring or having the build environment for flutter installed permanently is too much.

sgnh commented on 2021-11-25 23:02 (UTC)

@tiziodcaio Sure it is possible to fully configure flutter while building the package but I don't think it's right to modify the system during the build phase.

tiziodcaio commented on 2021-11-25 09:10 (UTC)

It is possible to add the flutter config --enable-linux-desktop command to the pkgbuild or it doesn't work?