Package Details: rocketchat-desktop 2.15.3-1

Git Clone URL: https://aur.archlinux.org/rocketchat-desktop.git (read-only)
Package Base: rocketchat-desktop
Description: Rocket.Chat Native Cross-Platform Desktop Application via Electron.
Upstream URL: https://github.com/RocketChat/Rocket.Chat.Electron
Keywords: chat client electron rocket rocketchat
Licenses: MIT
Conflicts: rocketchat-client-bin
Submitter: sum01
Maintainer: matthias.lisin
Last Packager: matthias.lisin
Votes: 10
Popularity: 0.201159
First Submitted: 2017-10-23 16:52
Last Updated: 2019-04-30 19:59

Pinned Comments

sum01 commented on 2017-10-25 17:02

If you're wondering about the difference between this and rocketchat-client-bin, this builds from the source code.

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 Next › Last »

SilverRainZ commented on 2018-06-24 09:20

Isn't that python2 is still required as a make dependency?

extra-x86_64_build failed with the following error: https://paste.gnome.org/p6sskn7nc

jamiepate commented on 2018-06-22 17:13

gulp-4.0.0-1-any <br> ... (1/1) checking for file conflicts [#############################################################################] 100% error: failed to commit transaction (conflicting files) gulp: /usr/bin/gulp exists in filesystem Errors occurred, no packages were upgraded.

Do we really need to install the global gulp-cli for this? seems weird to use a system package for a global node module when you could use $(npm bin)/gulp

sum01 commented on 2018-06-11 17:22

Nodejs v10 now seems to work, so anyone who switched to an older version for this can safely upgrade to the newest nodejs when upgrading this package.

Example for Aurman users: aurman -S nodejs rocketchat-desktop

sum01 commented on 2018-05-24 20:22

@thunderstorm9905

It's right in the error message, you need to resolve the dependency.

Install nodejs-lts-carbon or some other compatible nodejs provider. Nodejs version 7 to 9 is compatible.

See https://github.com/RocketChat/Rocket.Chat.Electron/issues/726 for tracking of this issue.

thunderstorm9905 commented on 2018-05-24 20:18

It does not build for me.

==> Missing dependencies: -> nodejs>=7.0.0 ==> ERROR: Could not resolve all dependencies.

==> ERROR: An unknown error has occurred. Exiting...

pelmennoteam commented on 2018-05-22 18:54

Try to build with nodejs-lts-carbon package. I just did it and it's OK.

sum01 commented on 2018-05-17 01:43

@steelstring94 For most people it isn't important. But if you really want some of the reasons...

  • Prevents the possibility of a bait-and-switch situation where the binary isn't actually from the source code, or contains additional malicious code
  • Offers very, very minor speed improvements when compiling for your specific system

Note that both of those reasons aren't really that relevant, as adding malicious code directly to source is still possible, and the speed improvement is really super minor.

There're other reasons, but usually this boils down to personal preference of the user.

steelstring94 commented on 2018-05-17 01:06

@sum01 What would be the advantage to building from source with this package, rather than just installing rocketchat-client-bin?

sum01 commented on 2018-05-01 21:29

@je-vv I don't really know the exact issue, but this issue references it https://github.com/nodejs/node/issues/20281

The only relevant dependency that's changed since the last release was yarn going to v1.6, so maybe that messed something up?

je-vv commented on 2018-04-30 23:47

yarn run v1.6.0 $ gulp build --env=production gulp[14066]: ../src/node_contextify.cc:631:static void node::contextify::ContextifyScript::New(const v8::FunctionCallbackInfo<v8::value>&): Assertion `args[1]->IsString()' failed. 1: node::Abort() [gulp] 2: 0x55b06c2899db [gulp] 3: node::contextify::ContextifyScript::New(v8::FunctionCallbackInfo<v8::value> const&) [gulp] 4: v8::internal::FunctionCallbackArguments::Call(v8::internal::CallHandlerInfo*) [gulp] 5: 0x55b06c49eba7 [gulp] 6: 0x55b06c49f33c [gulp] 7: 0x209b3710427d error Command failed with signal "SIGABRT". info Visit https://yarnpkg.com/en/docs/cli/run for documentation about this command. ==> ERROR: A failure occurred in build(). Aborting...</v8::value></v8::value>