Package Details: rofi-greenclip 4.2-2

Git Clone URL: https://aur.archlinux.org/rofi-greenclip.git (read-only, click to copy)
Package Base: rofi-greenclip
Description: Clipboard manager to use with rofi - Image support and blacklist
Upstream URL: https://github.com/erebe/greenclip
Licenses: GPL
Conflicts: rofi-greenclip-beta
Provides: greenclip
Replaces: rofi-greenclip-beta
Submitter: Erebe
Maintainer: Erebe
Last Packager: Erebe
Votes: 38
Popularity: 0.58
First Submitted: 2018-03-04 13:40 (UTC)
Last Updated: 2021-05-27 14:05 (UTC)

Latest Comments

Erebe commented on 2021-05-03 07:23 (UTC)

You need to clean your cache if the checksum fails. Don't know how to avoid this issue, so if you have a magic solution, feel free to tell me.

Erebe commented on 2020-12-29 20:36 (UTC)

Bumped pkgrel to force build clean, but the checksum is correct.

  1 rofi-greenclip                   (Installed) (Build Files Exist)
==> Packages to cleanBuild?
==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
==> A
:: Deleting (1/1): /home/erebe/.cache/yay/rofi-greenclip
:: Downloaded PKGBUILD (1/1): rofi-greenclip
  1 rofi-greenclip                   (Installed) (Build Files Exist)
==> Diffs to show?
==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
==>
:: (1/1) Parsing SRCINFO: rofi-greenclip
==> Making package: rofi-greenclip 3.4-5 (Tue 29 Dec 2020 09:35:50 PM CET)
==> Retrieving sources...
  -> Downloading greenclip...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   633  100   633    0     0   1850      0 --:--:-- --:--:-- --:--:--  1850
100 2976k  100 2976k    0     0  1300k      0  0:00:02  0:00:02 --:--:-- 1968k
  -> Found greenclip.service
==> Validating source files with sha256sums...
    greenclip ... Passed
    greenclip.service ... Passed

Ergus commented on 2020-12-28 23:37 (UTC)

Same here.

  -> Found greenclip
  -> Found greenclip.service
==> Validating source files with sha256sums...
    greenclip ... FAILED
    greenclip.service ... Passed
==> ERROR: One or more files did not pass the validity check!
error downloading sources: rofi-greenclip

pabloariasal commented on 2020-12-25 16:31 (UTC)

Unfortunately the checksum is still failing

smittie commented on 2020-12-22 10:51 (UTC)

@Brottweiler please consider reading older comments before commenting. You have to cleanBuild as been described by others already.

Brottweiler commented on 2020-12-21 23:12 (UTC)

greenclip sum fails.

Erebe commented on 2020-12-21 20:04 (UTC)

marked all 3 as optional dependencies

loki7990 commented on 2020-09-12 20:44 (UTC)

Rofi should be listed as an optional dependency. As stated on the readme, greenclip can be used with dmenu or fzf. I would suggest making all three of these optional dependencies.

dohq commented on 2020-04-17 06:59 (UTC) (edited on 2020-04-17 07:00 (UTC) by dohq)

@izikeros
==> Packages to cleanBuild?
==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
select rofi-greenclip

izikeros commented on 2020-04-16 05:57 (UTC)

Can you tell me how to delete the cached repo of the rofi-greenclip package? I'm using yay.

ZeroCC commented on 2020-04-12 19:48 (UTC)

@battuta That fixed it - thanks.

battuta commented on 2020-04-12 19:40 (UTC)

@ZeroCC The same happened to me when upgrading with the aurman AUR helper. I had to delete the cached repo of the rofi-greenclip package, and then reinstalling again worked.

ZeroCC commented on 2020-04-12 09:59 (UTC) (edited on 2020-04-12 10:01 (UTC) by ZeroCC)

The latest update gives me

==> Validating source files with sha256sums...
    greenclip ... FAILED
    greenclip.service ... Passed
==> ERROR: One or more files did not pass the validity check!

weilbith commented on 2020-02-17 09:49 (UTC)

I still get the error by the systemd service. Even with the new version including the After=... fix. Any ideas why?

Erebe commented on 2020-01-05 23:06 (UTC)

Done, sorry

famar commented on 2020-01-05 22:17 (UTC)

@Erebe please also fix the SHA for greenclip.service, unless it won't build

Erebe commented on 2020-01-05 22:12 (UTC)

Hello, Sorry for the delay I haven't seen the notifications. Should be fixed I just added "After=display-manager.service" in the service. Let me know if it is not worknig

apetresc commented on 2020-01-05 18:32 (UTC)

I believe the only change that should be required is the fix to the service unit. The upstream package hasn't changed.

sQVe commented on 2020-01-05 16:21 (UTC)

@Erebe Would it be possible to fix the issue that made the package "out-of-date"? It been two months now.

Junker commented on 2019-10-22 08:43 (UTC)

got error on start: greenclip: FatalError {fatalErrorMessage = "X display not available. Please start Xorg before running greenclip"}

fix greenclip.service, add "After=display-manager.service"

like here: https://wiki.archlinux.org/index.php/Greenclip

famar commented on 2019-06-15 16:20 (UTC)

After installing and enabling the service I get the following error:

Jun 15 18:11:05 devil systemd[5054]: greenclip.service: Service RestartSec=100ms expired, scheduling restart.
Jun 15 18:11:05 devil systemd[5054]: greenclip.service: Scheduled restart job, restart counter is at 5.
Jun 15 18:11:05 devil systemd[5054]: Stopped Greenclip agent.
Jun 15 18:11:05 devil systemd[5054]: greenclip.service: Start request repeated too quickly.
Jun 15 18:11:05 devil systemd[5054]: greenclip.service: Failed with result 'start-limit-hit'.
Jun 15 18:11:05 devil systemd[5054]: Failed to start Greenclip agent

Erebe commented on 2019-02-17 17:44 (UTC)

That's good, update your Aur and you will be good. Thanks for the patch

apetresc commented on 2019-02-12 02:10 (UTC)

Oh for sure, I don't think AUR packages are ever supposed/allowed to auto-enable a service :) I just mean to include it in the right place so that it's a systemctl --user enable away.

Sounds good! I'll e-mail it to you momentarily (it's very simple)

Erebe commented on 2019-02-12 01:54 (UTC)

Hello, I can add it in the package if you want but regarding auto-enabling it by default, I will not do it as it is kind of specific of how people manage their system.

Send me the patch by mail or as a PR on github :)

apetresc commented on 2019-02-05 16:43 (UTC)

@Erebe: Would you be willing to accept a patch that adds a systemd user unit for running the greenclip daemon? It's necessary to run the daemon for this package to do anything and its annoying to have to supervise it manually.

polygamma commented on 2018-06-20 18:33 (UTC)

It was indeed an aurman problem and has been fixed with aurman release 2.13.1

samhh commented on 2018-06-20 14:31 (UTC)

Thanks for the investigation, aurman devs looking into it, problem is indeed on their end! :-)

Erebe commented on 2018-06-20 11:17 (UTC)

Well the problem seems to be in aurman. I tried to : + manually build the package with makepkg and install it with pacman -U, it works + manually build the package with makepkg and install it with aurman -U, it works + Install it with yaourt -Sy rofi-greenclip, its works + only aurman -S does not works, and I can't get any more information regarding why it fails

For me it is related to either: + https://github.com/polygamma/aurman/issues/3 + https://github.com/polygamma/aurman/pull/118

I will not spend time to troubleshoot aurman, but in the end if you find out why it fails let me know and I will add/fix it

samhh commented on 2018-06-19 20:34 (UTC) (edited on 2018-06-19 22:35 (UTC) by samhh)

I'm using aurman. I haven't had any trouble with any other packages, and can't seem to see any similar issues on their GitHub repo.

Same issue persists if I uninstall and attempt to reinstall.

Erebe commented on 2018-06-18 14:21 (UTC)

Can you retry a yaourt -Sy rofi-greenclip ? I just tried it, and it is working fine for me

samhh commented on 2018-06-18 10:40 (UTC)

3.0 update is giving me:

classes - install - ERROR - package file of rofi-greenclip not available

Erebe commented on 2018-06-17 13:37 (UTC)

3.0 is now the official stable version. You will get * Image support * Blacklisting applications support * Some perf improvements

WARNING INSTALLING THIS NEW VERSION WILL ERASE YOUR CURRENT CONFIGURATION

as there were some majors reworks, and keeping compatibility with older config / data format was too much work for me.

Erebe commented on 2018-03-12 21:02 (UTC)

If you resync your packages, you will find a rofi-greenclip-beta available.

Erebe commented on 2018-03-11 10:12 (UTC)

I will add a rofi-greenclip-beta package

smnpl commented on 2018-03-10 09:18 (UTC) (edited on 2018-03-10 17:06 (UTC) by smnpl)

If that the blacklisting function comes with it I would very much like having the 3.0 version released! Really need to exclude my password manager. Not sure what the process might be to avoid breaking peoples systems. Maybe offer an alternate rofi-greenclip-2 package which would work with old configurations and conflicts with the rofi-greenclip package? Bring the newest, this is Arch after all :)

Erebe commented on 2018-01-02 15:04 (UTC) (edited on 2018-01-02 15:09 (UTC) by Erebe)

3.0 is still in beta, and I am not sure if I want to release it as it does not bring much more (beside image support) but breaks config files of users.

https://github.com/erebe/greenclip/releases/tag/3.0