Package Details: rpcs3-git 0.0.23.13925.73ed657e0-1

Git Clone URL: https://aur.archlinux.org/rpcs3-git.git (read-only, click to copy)
Package Base: rpcs3-git
Description: A Sony PlayStation 3 emulator
Upstream URL: https://github.com/RPCS3/rpcs3
Licenses: GPL2
Conflicts: rpcs3
Provides: rpcs3
Submitter: alucryd
Maintainer: hcorion
Last Packager: hcorion
Votes: 65
Popularity: 1.46
First Submitted: 2014-08-14 11:04 (UTC)
Last Updated: 2022-07-16 16:41 (UTC)

Dependencies (30)

Required by (0)

Sources (3)

Latest Comments

1 2 3 4 5 6 .. 29 Next › Last »

AtticFinder65536 commented on 2022-06-11 16:00 (UTC)

I needed to explicitly add -DUSE_SYSTEM_WOLFSSL=OFF in the cmake arguments to allow cmake to find the package:

-- Checking for module 'wolfssl>=4.7.0'
--   Package 'wolfssl', required by 'virtual:world', not found
CMake Error at /usr/share/cmake/Modules/FindPkgConfig.cmake:605 (message):
  A required package was not found
Call Stack (most recent call first):
  /usr/share/cmake/Modules/FindPkgConfig.cmake:827 (_pkg_check_modules_internal)
  3rdparty/wolfssl/CMakeLists.txt:3 (pkg_check_modules)

Please consider adding it

Neko-san commented on 2022-05-23 17:36 (UTC)

@patlefort RPCS3 hasn't had building issues for LTO in a while, I'm actually somewhat the cause of this new cmake error

I had reported some bugs that involved LTO but ultimately were "solved" by just enforcing the lack of LTO in the build system. The original issue I had reported was a floating point error but I don't think it was actually fixed because the initial response was a commit PR to prevent LTO instead. This was partially due to the fact that Qt doesn't always like LTO (can cause launch crashes), but now you at least have the full picture as to why no time was really spent on it instead.

patlefort commented on 2022-05-23 06:47 (UTC)

Rpcs3 now error out when LTO is enabled:

CMake Error at CMakeLists.txt:137 (message):
  Rpcs3 doesn't support building with LTO, use -DDISABLE_LTO=TRUE to
  force-disable it

I think options=(!lto) should be used.

fabian-ang commented on 2022-05-15 10:17 (UTC)

Apparently rpcs3 updated their codebase to be compatible with recent flatbuffers versions, thus we can revert the usage of the bundled flatbuffers lib

AtticFinder65536 commented on 2022-04-30 09:44 (UTC)

No need to use bundled ffmpeg or to link against ffmpeg4.4 libraries anymore, https://github.com/RPCS3/rpcs3/commit/fb27ed4deb5a94964d59978de7770b4dcde49d1e fixes it :D

I don't get that error anymore on my system

Ember2528 commented on 2022-04-16 13:41 (UTC)

Alternatively with Arch providing an ffmpeg 4.4 package for now it may be a good idea to link against that

fabian-ang commented on 2022-04-05 15:46 (UTC) (edited on 2022-04-05 15:47 (UTC) by fabian-ang)

As it's said in this issue rpcs3 is incompatible with recent ffmpeg versions. Thus i'd suggest also using the bundled ffmpeg version, as many games don't work with the up to date system ffmpeg package

ferrvittorio commented on 2022-04-01 14:47 (UTC)

Hi,I am getting an error while building The log file is very large, I cannot post it here because it would be really confusing.

error: invalid conversion from ‘const AVCodec’ to ‘AVCodec’ [-fpermissive] 266 | av.codec = avcodec_find_decoder(stream->codecpar->codec_id);

media_utils.cpp:328:39: warning: ‘void av_init_packet(AVPacket*)’ is deprecated [-Wdeprecated-declarations]

[ 76%] Building CXX object rpcs3/Emu/CMakeFiles/rpcs3_emu.dir/__/util/yaml.cpp.o

make[2]: *** [rpcs3/Emu/CMakeFiles/rpcs3_emu.dir/build.make:286: rpcs3/Emu/CMakeFiles/rpcs3_emu.dir/__/util/media_utils.cpp.o] Errore 1

I tried to summarize but I dont know if I was effective at it

agapito commented on 2022-03-22 11:12 (UTC)

-DCMAKE_CXX_FLAGS='-fpermissive'\