Package Details: ruby-rmagick 4.2.2-1

Git Clone URL: (read-only, click to copy)
Package Base: ruby-rmagick
Description: RMagick is an interface between the Ruby programming language and the ImageMagick image processing library
Upstream URL:
Licenses: MIT
Submitter: shtrom
Maintainer: dark-saber
Last Packager: dark-saber
Votes: 26
Popularity: 0.000070
First Submitted: 2009-02-25 04:53 (UTC)
Last Updated: 2021-09-12 13:38 (UTC)

Latest Comments

alexbrinister commented on 2018-10-07 17:26 (UTC)

@ahuillet I just built this package without any errors using libmagick6- Have you tried to build it recently using the newest libmagick6?

ahuillet commented on 2018-06-24 14:34 (UTC)

This doesn't seem to build for me with libmagick6-

checking for presence of MagickWand API (ImageMagick version >= 6.9.0)... no Can't install RMagick 2.16.0. Can't find MagickWand.h. extconf.rb failed Could not create Makefile due to some reason, probably lack of necessary libraries and/or headers. Check the mkmf.log file for more details. You may need configuration options.

dark-saber commented on 2018-02-09 09:39 (UTC)

NeoRaider: Fixed, thanks!

NeoRaider commented on 2018-02-09 08:04 (UTC)

This is missing a dependency on ruby-rdoc:

==> Starting package()...             
Building native extensions. This could take a while...                  
Successfully installed rmagick-2.16.0
ERROR:  While executing gem ... (Gem::DocumentError)
    RDoc is not installed: cannot load such file -- rdoc/rdoc
==> ERROR: A failure occurred in package().

dark-saber commented on 2018-01-04 07:10 (UTC)

I've made some tests and it looks like libmagick6 is enough to make this work, and it doesn't conflict to libmagick v7. Please let me know if you find something is wrong with new dependencies.

dark-saber commented on 2018-01-04 06:57 (UTC)

tuxsavvy: Yes, unfortunately, rmagick still doesn't support imagemagick 7+. Achieving the compatibility with v7 seems to be non-trivial, people have tried, but no one succeeded to this moment ( So the only relevant pull request is this:

There is also a mini_magick gem on GitHub: which is compatible with imagemagick 7+, uses less RAM and it's functionality might be enough for some tasks.

tuxsavvy commented on 2018-01-04 04:33 (UTC)

Does this package still require imagemagick6? According to the repository, supports were added to support imagemagick 6.9+:

RMagick 2.16.0
Support ImageMagick 6.9+ - @ZipoKing

imagemagic6 conflicts with imagemagick (which is already up to 7.0.7.xx)

shtrom commented on 2015-07-13 06:47 (UTC)

Here you go (:

dark-saber commented on 2015-07-13 06:45 (UTC)

@shtrom Yes, I'd like to maintain it.

shtrom commented on 2015-07-13 00:48 (UTC)

And the license IS MIT [0]. I fixed that too. [0]

shtrom commented on 2015-07-13 00:46 (UTC)

Thanks for that Dmitry. That said, I'm not really using this package anymore, so it is likely to go stale again. Care to take up maintainership?

dark-saber commented on 2015-07-11 15:08 (UTC)

Also, it seems that license is MIT.

dark-saber commented on 2015-07-11 15:06 (UTC)

Many things have changed since 2.13: repository has been moved to github, graphicsmagick support has been dropped etc. I've created a PKGBUILD for 2.15.2, which installs rmagick as a gem (like aur/ruby-pdf-reader and many other ruby packages):

dark-saber commented on 2015-07-11 14:34 (UTC)

The package doesn't install, because PKGBUILDs without package() are unsupported now. build() should be replaced with package(), and it would be nice to update version to 2.15.2 too.

anatolik commented on 2015-02-27 16:08 (UTC)

This AUR project is completely fine. I moved on maintaining and using gem binary repository (aka Quarry) I do not use ruby-* packages from AUR anymore, using quarry is way more convenient for me.

nboichat commented on 2015-02-27 08:06 (UTC)

@anatolik: Any specific reason why this package was orphaned? It still works fine here...

anatolik commented on 2014-02-18 18:03 (UTC)

@Sopheny, AUR (and any operations with makepkg) require 'base-devel' package group. See the wiki page [1]. This group already contains patch and pkg-config so it is not needed to specify them as a build dependencies. [1]

Sopheny commented on 2014-02-18 10:13 (UTC)

Ty but I think you forget to add dependencies for the compilation (patch and pkg-config)

anatolik commented on 2013-12-11 23:36 (UTC)

I believe this should be merged into ruby-rmagick

nboichat commented on 2013-09-21 05:50 (UTC)

Pulled together an updated PKBUILD here: hdri.patch comes from someone else: I have no idea what it implies. Simple tests with non-HDR images seems to work fine. peteonrails on github else reported even HDR works fine:

RubenKelevra commented on 2013-09-18 18:42 (UTC)

Same Error here, how to we fix this? ### checking for HDRI disabled version of ImageMagick... no Can't install RMagick 2.13.2. RMagick does not work when ImageMagick is configured for High Dynamic Range Images. Don't use the --enable-hdri option when configuring ImageMagick. ### Thanks in advance

fubik commented on 2013-09-02 07:50 (UTC)

Can't get it installed because it needs to have a HDRI disabled version of ImageMagick and the imagemagick package (provided by the extra repository) is a HDRI enabled version of ImageMagick. How can we fix this ?

fubik commented on 2013-09-02 07:33 (UTC)

What's the difference between ruby-rmagick and ruby-rmagick2 now ? Why didn't you delete this package ?

nboichat commented on 2013-02-12 09:15 (UTC)

PKGBUILD needs trivial version bump to 2.13.2: +pkgver=2.13.2 +pkgrel=1 +md5sums=('732fd61f9c0af4229a0df752ed15ffb1')

bjesus commented on 2013-02-01 23:02 (UTC)

after it fails, do this: cd /usr/lib sudo ln -s sudo ln -s sudo ln -s

kidoz commented on 2012-09-20 19:14 (UTC)

@egeerardyn Done

egeerardyn commented on 2012-09-15 06:51 (UTC)

Please migrate from this package to ruby-rmagick: it is exactly the same and the only package that depends on this version is ruby-gruff (which you also maintain).

shtrom commented on 2010-05-17 23:22 (UTC)

I'm not really using this package, nor Ruby. I'm disowning it, if anybody wants to take it.

kidoz commented on 2010-04-23 18:03 (UTC)

RMagick 2 does not work with grafitssmagitsk, so it is written on the official site: Better to use the gem to create a package.

shtrom commented on 2010-04-07 00:47 (UTC)

Version bump. Cheers.

commented on 2010-04-06 21:57 (UTC)

Howdi, ruby-rmagick fail to compile with the current(2010/4/6) RMagick, upgrading the PKGBUILD to 2.13.1 solves it.