Package Details: scrt-sfx 8.1.4-1

Git Clone URL: https://aur.archlinux.org/scrt-sfx.git (read-only)
Package Base: scrt-sfx
Description: Vandyke SecureCRT & SecureFX SSH Client
Upstream URL: http://www.vandyke.com
Keywords: sftp ssh
Licenses: custom
Provides: scrt, sfx
Submitter: archshot
Maintainer: archshot
Last Packager: archshot
Votes: 2
Popularity: 0.000000
First Submitted: 2017-05-01 15:32
Last Updated: 2017-08-21 13:28

Latest Comments

1 2 Next › Last »

rahulchauhan commented on 2019-08-26 13:18

when i am installing scrt-sfx-8.5.4 i am getting this error pls help makepkg -i ==> Making package: scrt-sfx 8.5.4-0 (Mon Aug 26 18:40:01 2019) ==> Checking runtime dependencies... ==> Checking buildtime dependencies... ==> Retrieving sources... -> Found scrt-sfx-8.5.4.1942.ubuntu18-64.tar.gz ==> Validating source_x86_64 files with md5sums... scrt-sfx-8.5.4.1942.ubuntu18-64.tar.gz ... Skipped ==> Extracting sources... -> Extracting scrt-sfx-8.5.4.1942.ubuntu18-64.tar.gz with bsdtar bsdtar: Failed to set default locale ==> Entering fakeroot environment... ==> Starting package()... install: cannot stat './run_securecrt.sh': No such file or directory ==> ERROR: A failure occurred in package(). Aborting...

belcboo commented on 2019-04-05 20:24

@tbk thank you so much for the PKGBUILD, working perfectly as April/5/2019.

b1tl0rd commented on 2019-03-11 16:02

@tbk thanks for PKGBUILD

tbk commented on 2019-03-01 10:44

Version 8.5.3.1867

PKGBUILD:

# Maintainer: Kabir Sala <aur AT mail DOT ksala DOT eu>
# Inspired by the 'scrt' package by Remy van Elst (https://aur.archlinux.org/packages/scrt/)
#
# How to install:
# 1. Download this package, but don't build it
#    With Pacaur: AURDEST=. pacaur -d scrt-sfx
#    Or just download all the files manually from AUR
# 2. Download
#    scrt-sfx-8.5.3.1867.ubuntu18-64.tar.gz (for 64bit systems)
#    From https://vandyke.com/download/securecrt/download.html
#    (You'll need a free account, SecureCRT/FX will ask for the license at startup)
#    And put in the same folder as the PKGBUILD
# 3. Run makepkg -i and enjoy!

pkgname=scrt-sfx
pkgver=8.5.3
incrver=1867
pkgrel=0
pkgdesc="Vandyke SecureCRT & SecureFX SSH Client"
arch=('x86_64')
url="http://www.vandyke.com"
license=('custom')
depends=('openssl-1.0' 'glibc' 'libpng')
provides=('scrt' 'sfx')
options=('!strip')
source=("run_securecrt.sh" "run_securefx.sh")
md5sums=('f46dbfcf871ed5056742ad2b4d0a6051' 'e64a26ecdc092367dfd5bbd4035e9923')
source_x86_64=("${pkgname}-${pkgver}.${incrver}.ubuntu18-64.tar.gz::file://${pkgname}-${pkgver}.${incrver}.ubuntu18-64.tar.gz")
md5sums_x86_64=('fc945174d9166341ede6b05b64d09eb5')

package() {
    install -Dm 755 ./run_securecrt.sh ${pkgdir}/usr/bin/SecureCRT
    install -Dm 755 ./run_securefx.sh ${pkgdir}/usr/bin/SecureFX

    cd "${srcdir}"/${pkgname}-${pkgver}
    install -Dm 755 ./SecureCRT ${pkgdir}/usr/lib/securecrt/SecureCRT
    install -Dm 644 ./SecureCRT.desktop ${pkgdir}/usr/share/applications/SecureCRT.desktop
    install -Dm 644 ./securecrt_64.png ${pkgdir}/usr/share/vandyke/data/securecrt_64.png

    install -Dm 644 ./SecureCRT_HISTORY.txt ${pkgdir}/usr/share/doc/scrt/SecureCRT_HISTORY.txt
    install -Dm 644 ./SecureCRT_README.txt ${pkgdir}/usr/share/doc/scrt/SecureCRT_README.txt
    install -Dm 644 ./SecureCRT_SecureFX_EULA.txt ${pkgdir}/usr/share/doc/scrt/SecureCRT_EULA.txt 
    cp -r ./SecureCRTHelp ${pkgdir}/usr/share/doc/scrt/

    install -Dm 644 ./changelog.Debian.gz ${pkgdir}/usr/share/doc/scrt/changelog.Debian.gz

    install -Dm 755 ./SecureFX ${pkgdir}/usr/lib/securefx/SecureFX
    install -Dm 644 ./SecureFX.desktop ${pkgdir}/usr/share/applications/SecureFX.desktop
    install -Dm 644 ./securefx_64.png ${pkgdir}/usr/share/vandyke/data/securefx_64.png
    install -Dm 644 ./SecureFX_HISTORY.txt ${pkgdir}/usr/share/doc/sfx/SecureFX_HISTORY.txt
    install -Dm 644 ./SecureFX_README.txt ${pkgdir}/usr/share/doc/sfx/SecureFX_README.txt
    install -Dm 644 ./SecureCRT_SecureFX_EULA.txt ${pkgdir}/usr/share/doc/sfx/SecureFX_EULA.txt 
    cp -r ./SecureFXHelp ${pkgdir}/usr/share/doc/sfx/
}

waranty92 commented on 2017-11-22 19:41

Dear archshot please update package to 8.3 version. Thanks in advance

archshot commented on 2017-08-21 13:29

Thanks @jamesolds, that's exactly how I updated the package. Sorry it took a while, I don't really use it everyday and forget to check for updates often.

jamesolds commented on 2017-08-15 15:07

Not sure if this is right way to contribute but I updated the PKGBUILD for the latest version (8.1.4.1443).

PKGBUILD:

# Maintainer: Kabir Sala <aur AT mail DOT ksala DOT eu>
# Inspired by the 'scrt' package by Remy van Elst (https://aur.archlinux.org/packages/scrt/)
#
# How to install:
# 1. Download this package, but don't build it
# With Pacaur: AURDEST=. pacaur -d scrt-sfx
# Or just download all the files manually from AUR
# 2. Download
# scrt-sfx-8.1.4.1443.ubuntu16.tar.gz
# scrt-sfx-8.1.4.1443.ubuntu16-64.tar.gz
# From https://vandyke.com/download/securecrt/download.html
# (You'll need a free account, SecureCRT/FX will ask for the license at startup)
# And put in the same folder as the PKGBUILD
# 3. Run makepkg -i and enjoy!

pkgname=scrt-sfx
pkgver=8.1.4
incrver=1443
pkgrel=1
pkgdesc="Vandyke SecureCRT & SecureFX SSH Client"
arch=('x86_64' 'i686')
url="http://www.vandyke.com"
license=('custom')
depends=('openssl' 'glibc' 'qt4' 'libpng12' 'openssl-1.0')
depends_i686=('lib32-openssl-1.0')
provides=('scrt' 'sfx')
options=('!strip')
source=("run_securecrt.sh" "run_securefx.sh")
md5sums=('f46dbfcf871ed5056742ad2b4d0a6051' 'e64a26ecdc092367dfd5bbd4035e9923')
source_i686=("${pkgname}-${pkgver}.${incrver}.ubuntu16.tar.gz::file://${pkgname}-${pkgver}.${incrver}.ubuntu16.tar.gz")
source_x86_64=("${pkgname}-${pkgver}.${incrver}.ubuntu16-64.tar.gz::file://${pkgname}-${pkgver}.${incrver}.ubuntu16-64.tar.gz")
md5sums_i686=('64b52eb4cbb4190f2cec8737977bc1dc')
md5sums_x86_64=('0ae3a8ae3df9927cc457b7566af70d62')

package() {
install -Dm 755 ./run_securecrt.sh ${pkgdir}/usr/bin/SecureCRT
install -Dm 755 ./run_securefx.sh ${pkgdir}/usr/bin/SecureFX

cd "${srcdir}"/${pkgname}-${pkgver}
install -Dm 755 ./SecureCRT ${pkgdir}/usr/lib/securecrt/SecureCRT
install -Dm 644 ./SecureCRT.desktop ${pkgdir}/usr/share/applications/SecureCRT.desktop
install -Dm 644 ./securecrt_64.png ${pkgdir}/usr/share/vandyke/data/securecrt_64.png

install -Dm 644 ./SecureCRT_HISTORY.txt ${pkgdir}/usr/share/doc/scrt/SecureCRT_HISTORY.txt
install -Dm 644 ./SecureCRT_README.txt ${pkgdir}/usr/share/doc/scrt/SecureCRT_README.txt
install -Dm 644 ./SecureCRT_SecureFX_EULA.txt ${pkgdir}/usr/share/doc/scrt/SecureCRT_EULA.txt
cp -r ./SecureCRTHelp ${pkgdir}/usr/share/doc/scrt/

install -Dm 644 ./changelog.Debian.gz ${pkgdir}/usr/share/doc/scrt/changelog.Debian.gz

install -Dm 755 ./SecureFX ${pkgdir}/usr/lib/securefx/SecureFX
install -Dm 644 ./SecureFX.desktop ${pkgdir}/usr/share/applications/SecureFX.desktop
install -Dm 644 ./securefx_64.png ${pkgdir}/usr/share/vandyke/data/securefx_64.png
install -Dm 644 ./SecureFX_HISTORY.txt ${pkgdir}/usr/share/doc/sfx/SecureFX_HISTORY.txt
install -Dm 644 ./SecureFX_README.txt ${pkgdir}/usr/share/doc/sfx/SecureFX_README.txt
install -Dm 644 ./SecureCRT_SecureFX_EULA.txt ${pkgdir}/usr/share/doc/sfx/SecureFX_EULA.txt
cp -r ./SecureFXHelp ${pkgdir}/usr/share/doc/sfx/
}

yurividal commented on 2017-08-09 13:52

Finnaly got it to work. I downloaded libssl1.0.0_1.0.1-4ubuntu5.39_amd64.deb from http://security.ubuntu.com/ubuntu/pool/main/o/openssl/libssl1.0.0_1.0.1-4ubuntu5.39_amd64.deb
then i extracted the data archive into my / (2 folders lib and usr).
After extracting these 2, i downloaded the archive for SecureCRT and ir now runs!

archshot commented on 2017-08-08 08:15

@yurividal It's not needed anymore, it got replaced by openssl-1.0/lib32-openssl-1.0.
My fault for not updating the pkgbuild, should be fine now.

yurividal commented on 2017-08-08 01:37

how do i install this?

scrt-sfx: requires libopenssl-1.0-compat