Package Details: sdrangel-git 7.6.2.r11.3c7e7974a-1

Git Clone URL: https://aur.archlinux.org/sdrangel-git.git (read-only, click to copy)
Package Base: sdrangel-git
Description: Qt5/OpenGL SDR and signal analyzer frontend.
Upstream URL: https://github.com/f4exb/sdrangel
Keywords: amateurradio hamradio
Licenses: GPL3
Conflicts: sdrangel
Provides: sdrangel
Submitter: Mikos
Maintainer: xiretza
Last Packager: xiretza
Votes: 10
Popularity: 0.000025
First Submitted: 2015-12-08 10:08 (UTC)
Last Updated: 2022-08-24 17:14 (UTC)

Latest Comments

1 2 3 4 5 6 Next › Last »

catdad_fred commented on 2022-08-26 07:42 (UTC)

For some odd reason I am able to find the dependencies and install. In my case, it's borking on optional depends. I don't need libxtrx or airspyhf for example. I just spotted something, the packages are make depends and are only in [package name]-git form. I will experiment with the PKGBUILD file by adding "-git" to each. My other option is to install each singularly then remove what I don't need.

xiretza commented on 2022-08-25 09:39 (UTC)

You probably need to tell it to use e.g. aptdec-git to satisfy the aptdec dependency - no idea how best to do that with yay though.

catdad_fred commented on 2022-08-25 09:36 (UTC) (edited on 2022-08-25 09:37 (UTC) by catdad_fred)

Where did I goof? "yay sdrangel-git" gives the following error message and won't build.

 -> Could not find all required packages:
    libperseus-sdr (Wanted by: sdrangel-git)
    airspyhf (Wanted by: sdrangel-git)
    libxtrx (Wanted by: sdrangel-git)
    libdab (Wanted by: sdrangel-git)
    sgp4 (Wanted by: sdrangel-git)
    aptdec (Wanted by: sdrangel-git)
    libmirisdr4 (Wanted by: sdrangel-git)

xiretza commented on 2022-08-24 17:14 (UTC)

Thanks, done!

FuzzyCheese commented on 2022-08-24 16:34 (UTC)

I believe the restriction on libmirisdr4 dependency to <2.0.0 can be removed due to upstream changes. "Fixed libmirisdr-4 version after merge of PR #1344" https://github.com/f4exb/sdrangel/commit/48edaecfbcce9a24815af71d8da5ead2c2960a91

xiretza commented on 2022-07-15 14:50 (UTC)

codec2 pushed a backwards-incompatible 1.0.4 tag, which was promptly picked up by Arch. It looks like a new backwards-compatible codec2 version is in the works, it'll probably land in a couple days.

Synthead commented on 2022-07-15 10:28 (UTC)

This doesn't seem to build as of this writing:

/home/max/aur/sdrangel-git/src/sdrangel/plugins/channelrx/demodfreedv/freedvdemodsink.cpp: In member function ‘void FreeDVDemodSink::applyFreeDVMode(FreeDVDemodSettings::FreeDVMode)’:
/home/max/aur/sdrangel-git/src/sdrangel/plugins/channelrx/demodfreedv/freedvdemodsink.cpp:436:13: error: ‘struct freedv_advanced’ has no member named ‘interleave_frames’
  436 |         adv.interleave_frames = 1;
      |             ^~~~~~~~~~~~~~~~~
make[2]: *** [pluginssrv/channelrx/demodfreedv/CMakeFiles/demodfreedvsrv.dir/build.make:118: pluginssrv/channelrx/demodfreedv/CMakeFiles/demodfreedvsrv.dir/freedvdemodsink.cpp.o] Error 1
make[1]: *** [CMakeFiles/Makefile2:12492: pluginssrv/channelrx/demodfreedv/CMakeFiles/demodfreedvsrv.dir/all] Error 2

tgheretford commented on 2022-07-12 18:56 (UTC)

I have 7.4.0-r0.cbacc162b-1 installed. In the last few days the version being offered for upgrade is now 6.20.3.r0.cbacc162b-1. Anyone who does attempt to "upgrade" will result in being unable to compile the program as it expects an older version of codec2 being installed. Something has gone wrong with the versioning which is causing it to download and compile an older version.

xiretza commented on 2022-05-06 12:47 (UTC)

@nizzo: thanks, I've pushed libmirisdr4-v1 and updated the depends accordingly.

xiretza commented on 2022-05-06 08:28 (UTC)

@aquilarubra: you probably need to update your aptdec-git, the latest version is aptdec-git-r188.5140597-1.