Package Details: setroot v2.0.g16b07b3-1

Git Clone URL: https://aur.archlinux.org/setroot.git (read-only)
Package Base: setroot
Description: simple program that sets your (X11) wallpaper. inspired by the *setroots and feh.
Upstream URL: https://github.com/ttzhou/setroot
Licenses: GPLv3
Conflicts: setroot
Provides: setroot
Submitter: ttz
Maintainer: ttz
Last Packager: ttz
Votes: 15
Popularity: 0.000816
First Submitted: 2014-11-13 16:22
Last Updated: 2017-01-24 06:57

Dependencies (6)

Required by (0)

Sources (1)

Latest Comments

ninrod commented on 2017-09-03 23:50

Tried to install tonight, getting this:

==> Finished making: setroot v2.0.gb4a4607-1 (Sun Sep 3 12:03:36 -03 2017)
==> Cleaning up...
:: Installing setroot package(s)...
:: setroot package(s) failed to install.
:: ensure package version does not mismatch between .SRCINFO and PKGBUILD
:: ensure package name has a VCS suffix if this is a devel package
:: imlib2 is now an orphan package

ttz commented on 2017-01-24 06:58

This package now references the latest setroot code from upstream; setroot-git is deprecated.

ttz commented on 2016-10-23 05:10

@KenjiTakahashi

Currently in grad school. It's a rough time. Forgot how to go through the new AUR upload process.

For now, use setroot-git, that's the latest version.

KenjiTakahashi commented on 2016-10-23 04:09

Any plans on updating this? It's been out of date for a couple of months now.

ttz commented on 2016-01-25 21:42

Yes, my mistake, I had modified the Makefile due to another request, forgot to change the PKGBUILD.

Should be good now.

Thanks for reporting (and still using it :P)

jasonwryan commented on 2016-01-25 21:20

You have a typo in the PKGBUILD that borks the build: it should read
make PREFIX="/usr"

Note the slash before usr.

ttz commented on 2015-02-18 14:08

changed arch array to be correct value.

WorMzy commented on 2015-02-18 11:47

The use of "any" in the arch array is incorrect -- "any" means the package doesn't contain any architecture-dependent files, but this package has an ELF file (/usr/bin/setroot). A setroot binary compiled on an x86_64 install will not work on an i686 install.

thiagowfx commented on 2014-12-13 20:44

https://aur.archlinux.org/packages/hsetroot/ adds xorg-server as a dependency. Maybe this is an indicator you should add libX11 also?

ttz commented on 2014-12-10 17:41

Done; on a side note, is it worth adding 'libX11' to depends, or is it obvious enough?

All comments