Package Details: smath 0_98_5935-2

Git Clone URL: https://aur.archlinux.org/smath.git (read-only)
Package Base: smath
Description: A mathematical program with many features and paper-like interface, similar to Mathcad
Upstream URL: http://smath.info
Keywords: mathcad mathematics smath
Licenses: CCPL
Groups: math
Submitter: tomracing
Maintainer: tomracing
Last Packager: tomracing
Votes: 1
Popularity: 0.193400
First Submitted: 2016-01-10 10:32
Last Updated: 2016-05-27 18:29

Latest Comments

tomracing commented on 2016-05-27 18:31

pkg version 2 now has the giflib restriction removed.

silent commented on 2016-05-27 18:23

Please remove <5.1.2 condition for giflib from the PKGBUILD

archmkr commented on 2016-05-25 13:47

Great, I just did the same and its all working.

tomracing commented on 2016-05-24 20:46

giflib 5.1.4-1 just came out.
After doing a normal -Syu and checking things work as normal I updated giflib with another -Syud (the -d stops the dependency check)
For me Smath works with 5.1.4.
If others would like to confirm I will remove the giflib requirement end of the week.

tomracing commented on 2016-04-30 14:49

I've updated to the latest stable 98.5935
Also added the dependency giflib<5.1.2 hope that works for people to keep it at 5.1.1

archmkr commented on 2016-04-28 21:54

Great!

I can confirm that downgrading to giflib-5.1.1-1 it works, thanks!
Maybe you could add a constrain about that in this pckg itself?

tomracing commented on 2016-04-28 21:40

Well I had some time to find out what caused the breakage and I found it!
downgrade giflib to giflib-5.1.1-1
the current version is 5.1.2-1 which breaks smath.

I will start a forum thread to get help on where and how to report the bug.
For now roll back and ignorepkg = giflib if you want smath to work.

archmkr commented on 2016-04-25 11:02

Ok, thanks for reply. Now I have tried to run with the oldest available (libgdiplus-3.8-1) and get the same error.

Reading some other topics related to "GDI+ status: InvalidParameter" I found some suggestions that what could be wrong is some image parameter. If it is the case, I can remember to read about some user who fixed something like this by manually converting images of some software using imagemagick.

tomracing commented on 2016-04-25 06:30

Thanks for helping to try to fix this.
The developer of smath has not responded on his forum yet unfortunately.

Dependencies of mono are listed as:
[code]Dependencies (5)
ca-certificates
libgdiplus>=3.8
python
sh (bash)
zlib[/code]

with the error line
[code]System.ArgumentException: A null reference or invalid value was found [GDI+ status: InvalidParameter] [/code]
we may have to look into libgdiplus.

archmkr commented on 2016-04-24 16:45

Same issue here (geli0n and tomracing).

The only dependency listed here is Mono.. So I have tried to run some newer (0.98) and some older (0.92 ~ 0.97) versions downgrading Mono:
mono-4.0.1.1-2-x86_64 (newest)-> same error
mono-4.0.1.1-1-x86_64 -> same error
mono-3.0.12-1-x86_64 (oldest from ALA/ARM) -> same plus other errors

Now I can imagine that it isn't caused by mono.

All comments