Package Details: soxt 1.3.0-6

Git Clone URL: https://aur.archlinux.org/soxt.git (read-only)
Package Base: soxt
Description: A high-level 3D graphics toolkit on top of OpenGL.
Upstream URL: http://www.coin3d.org/
Licenses: GPL
Submitter: None
Maintainer: None
Last Packager: eworm
Votes: 5
Popularity: 0.025868
First Submitted: 2006-11-16 19:01
Last Updated: 2017-10-02 22:25

Latest Comments

jpeter commented on 2019-04-20 14:40

Installation Error:

configure: error: couldn't compile and link against Coin

Need to be able to run 'coin-config' to figure out how to build and link against the Coin library.

However, coin ist installed.

The proposed fix --with-coin=/usr does not help.

donpicoro commented on 2019-04-16 10:51

[EDIT: NEVERMIND. THIS DOES NOT WORK FOR ME]

As I see this... all the Coin3D software (Coin, SoXt, etc) is migrating towards CMake build system instead of autotools. So now we are in a situation where coin (tip branch in the AUR) uses CMake but SoXt (branch 1.3.0) does not. If you change the SoXt upstream branch you see they already have CMakeList.txt. In the meantime you can just add the following

--with-coin=/usr

to the ./configure line in the PKGBUILD. This did the trick for me

ydallilar commented on 2019-03-15 16:57

Can't install. I got the following error in configure:

configure: WARNING: cannot find 'coin-config' at any of these locations:

-> /opt/google-cloud-sdk/bin/coin-config

-> /usr/bin/coin-config

-> /usr/local/sbin/coin-config

-> /usr/local/bin/coin-config

-> /usr/bin/coin-config

-> /opt/cuda/bin/coin-config

-> /usr/lib/jvm/default/bin/coin-config

-> /usr/bin/site_perl/coin-config

-> /usr/bin/vendor_perl/coin-config

-> /usr/bin/core_perl/coin-config

-> /opt/isis/isis/1.6.2/bin//coin-config

-> /opt/cuda/bin/coin-config

-> /opt/isis/isis/1.6.2/bin//coin-config

-> /opt/cuda/bin/coin-config

-> /usr/bin/coin-config

configure: WARNING:

Need to be able to run 'coin-config' to figure out how to build and link against the Coin library. To rectify this problem, you most likely need to a) install Coin if it has not been installed, b) add the Coin install bin/ directory to your PATH environment variable.

configure: error: couldn't compile and link against Coin

And I have the coin package from aur installed.

lonaowna commented on 2016-05-27 11:23

Can the maintainer please fix the license line? Thanks!

ackthet commented on 2016-02-06 03:43

I'm guessing there was a change to the PKGBUILD layout, but:
==> ERROR: license should be an array

Simply changing to:
license=('GPL')

fixes it.

eworm commented on 2015-01-21 07:08

Renamed the files with a prefix, please install soxt 1.3.0-3.

Stevenwalton commented on 2015-01-21 01:08

Installing soxt gave the following error

error: failed to commit transaction (conflicting files)
soxt: /usr/share/man/man3/components.3.gz exists in filesystem
soxt: /usr/share/man/man3/devices.3.gz exists in filesystem
soxt: /usr/share/man/man3/misc.3.gz exists in filesystem
soxt: /usr/share/man/man3/viewers.3.gz exists in filesystem
Errors occurred, no packages were upgraded.

I checked ownership of these files and they are all owned by coin (a dependency for soxt). Checking what coin was required by I found the only other program was freecad. Upon removal of freecad I was able to install soxt.

It would be nice if this was fixed so that I could run Freecad and Geant4.