Package Details: ssb-patchwork 3.11.6-1

Git Clone URL: (read-only)
Package Base: ssb-patchwork
Description: A decentralized messaging and sharing app built on top of Secure Scuttlebutt (SSB)
Upstream URL:
Keywords: decentralized gossip network patchwork scuttlebutt ssb
Licenses: AGPL3
Submitter: dlandau
Maintainer: dlandau (pypper, christianbundy)
Last Packager: christianbundy
Votes: 15
Popularity: 0.685060
First Submitted: 2017-09-09 19:25
Last Updated: 2019-03-22 17:47

Latest Comments

« First ‹ Previous 1 2 3 4 Next › Last »

GergelyPolonkai commented on 2018-11-06 08:09

As of version 3.11.3-1 I Patchwork fails to start:

Error: Cannot find module '@paulcbetts/spellchecker'
    at Module._resolveFilename (module.js:543:15)
    at Function.Module._resolveFilename (/usr/lib/electron/resources/electron.asar/common/reset-search-paths.js:35:12)
    at Function.Module._load (module.js:473:25)
    at Module.require (module.js:586:17)
    at require (internal/module.js:11:18)
    at Object.<anonymous> (/opt/ssb-patchwork/node_modules/electron-spellchecker/lib/node-spellchecker.js:8:18)
    at Object.<anonymous> (/opt/ssb-patchwork/node_modules/electron-spellchecker/lib/node-spellchecker.js:9:3)
    at Module._compile (module.js:642:30)
    at Object.Module._extensions..js (module.js:653:10)
    at Module.load (module.js:561:32)

I saw this module mentioned in a few SSB posts, but no real solution.

christianbundy commented on 2018-09-27 15:26

Oops, accidentally deleted my comment. Sorry about that.

TL;DR: as long as NPM is up-to-date you should be able to run npm ci. If there are compatibility issues, let me know and I can see about adding a fallback for older versions of NPM. Good luck!

Blaiz0r commented on 2018-09-03 21:07

Line 30 in the PKGBUILD didn't work for me:

npm ci --only=production

I had to separate the c and the i and reverse them.

christianbundy commented on 2018-05-30 18:33

Stephen304: Please read the most recent comments (just below your post).

Patchwork 3.9.0 requires Node.js < 10 as a build dependency (makedepends), but once it's installed you can reinstall nodejs as it isn't required as a runtime dependency.

Stephen304 commented on 2018-05-30 18:27

Is there any specific reason why this depends on nodejs-lts-carbon now? I have atom installed, which depends on nodejs, so I am failing to update to 3.9.0-3 since the nodejs-lts-carbon conflicts with my currently installed nodejs from atom.

:: The following 1 package(s) are getting installed:
   community/nodejs-lts-carbon  /         ->  8.11.2-1

:: The following 1 package(s) are getting updated:
   aur/ssb-patchwork            3.8.10-1  ->  3.9.0-3

:: The following 3 package(s) are getting removed:
   community/apm                1.19.0-6  ->  /
   community/atom               1.27.1-1  ->  /
   community/nodejs             10.3.0-1  ->  /
:: Package nodejs will be removed due to a conflict with nodejs-lts-carbon
:: Dependency nodejs>=10 of package apm is not fulfilled
:: Dependency apm of package atom is not fulfilled

christianbundy commented on 2018-05-07 00:09

Shywim: My "relative confidence" ended up being completely backward, you were right! I've just pushed a new commit to move nodejs-lts-carbon and npm to makedepends, and after about 30 minutes of paranoid testing I can't find any reason not to do this. Thanks for the suggestion!

christianbundy commented on 2018-05-06 15:13

Shywim: I'm relatively confident that nodejs is required at runtime because it ends up hosting an sbot ( server in the background.

I'm working on bringing all of the Patchwork dependencies up-to-date ( to support Node 10, but it will likely take a few more days to wrap up all of the loose ends. Thanks for your patience!

Shywim commented on 2018-05-06 09:30

Is nodejs required for runtime? If not, please use makedepends for nodejs as I need the latest version of node of my machine, and I can't have nodejs and nodejs-lts-carbon side by side.

dlandau commented on 2018-04-29 20:44

Ok, got it to a working state. It's not ideal by a long shot, but at least it functions now.

dlandau commented on 2018-04-29 19:17

Uh, this package is broken by upstream(s) right now.

@Plexcon: That error is this one: Using npm ci instead of npm install gets through that, but then we have the next problem.

On node 10, there's this issue in a dependency

@k3a: see christianbundy's comment. NPM has introduced package-lock.json since then, a file that lists all the exact dependencies and npm ci install exactly those. Using sed to get rid of the electron dependency in package.json is doable, but I'm not sure if doing same to package-lock.json would make any sense as that file is not meant to be human editable.

I tried to update the PKGBUILD to depend on older versions of node and npm from the AUR, which is highly unideal as this forces the removal of the packages from community. This didn't turn out to solve the problem as there's some error message about node-abi and trying to bypass that lead to Patchwork installing, but failing to launch with a message about NODE_MODULE_VERSION (unsurprising, as node-abi was being used for working with that as far as I could tell).

End result is no working package at the moment. I'll try to get it fixed asap, but it might require upstream to do something.