Package Details: stone-soup-yiuf 1.5.5b1-2

Git Clone URL: https://aur.archlinux.org/stone-soup-yiuf.git (read-only)
Package Base: stone-soup-yiuf
Description: A fork of Dungeon Crawl Stone Soup roguelike with old races recovered
Upstream URL: https://github.com/yrmvgh/yiufcrawl
Licenses: GPL, custom, BSD, MIT, Apache, zlib, custom:CC0
Conflicts: crawl, stone-soup-tile
Submitter: dark-saber
Maintainer: dark-saber
Last Packager: dark-saber
Votes: 2
Popularity: 0.000278
First Submitted: 2017-03-02 17:54
Last Updated: 2018-01-14 19:03

Latest Comments

yrmvgh commented on 2017-03-31 10:52

Ah, thank you for the information, I didn't realize how many different-named dcss packages there were floating around.

And thanks for updating the package!

dark-saber commented on 2017-03-25 16:25

egils:
Thank you, I've updated the licenses info. It's still imperfect though:
1. Arch guidelines treat BSD, MIT and zlib/png licenses as custom ones and require to store them in /usr/share/licenses/stone-soup-yiuf, but crawl docs/licenses directory lacks almost all of them.
2. Some tiles are in fact still under unclear licensing (https://github.com/crawl/tiles), although this is not clarified in crawl license.txt. I really had an urge to add 'unknown' on top of license array cake, but I guess I'll stick with 'custom' one for now.

By the way, the same license issues might be addressed to other stone-soup packages too (notably community/stone-soup and aur/stone-soup-git).

dark-saber commented on 2017-03-24 09:08

OK, I'm back from the vacation, and this package is updated finally. Thanks for the info about changed repo url!

As for the 'conflicts' section, I've taken it from the community/stone-soup PKGBUILD, and it exists only for historical reasons in it's current state. AFAIK, there are no packages providing 'crawl' or 'stone-soup-tile' in Arch repos for quite a long time, so this is only a measure against users who still have some antic crawl 0.5.0 installed somehow - I can't guarantee there would be no conflicts with those packages, I can't even see their PKGBUILDS!
Meanwhile, stone-soup-yiuf installs and works fine alongside community/stone-soup and aur/stone-soup-git, although both latter ones are still mutually exclusive.

egils commented on 2017-03-18 17:16

It is not custom-licensed
"License and history information

Crawl is licensed as GPLv2+. See licence.txt for the full text." source: https://github.com/yrmvgh/crawl/#license-and-history-information
see: https://github.com/yrmvgh/crawl/blob/master/crawl-ref/licence.txt

Please update the with a sourcefield saying something like: "GPL2, CC0, BSD, zlib, apache 2"

yrmvgh commented on 2017-03-16 22:50

Changing repo to https://github.com/yrmvgh/yiufcrawl
sometime tonight

yrmvgh commented on 2017-03-15 17:10

As you can see here, I'm quite bad at tagging and versioning, hopefully seeing it in this format can help you make sense of the nonsense!
https://travis-ci.org/yrmvgh/crawl/branches

note: yiuf2 and yiuf3 are merely "backups", not real versions. Backups may be completely and utterly unnecessary with git, but it's reassuring to know before I do a big rebase that there's something working I can fallback to without having to figure out an arcane series of git commands :)

yrmvgh commented on 2017-03-15 14:06

Can you remove the "conflicts" or are they set in stone once the package is created? If I can do anything further to help make conflicts go away, I'm all ears! :)

Also if you have any experience with plutonians they're a really difficult race to judge.

dark-saber commented on 2017-03-11 16:20

yrmvgh:
And thank you for this amazing fork! Yes, yiufcrawl works just fine alongside vanilla DCSS, and the PKGBUILD became much simpler after your recent changes, so thanks for that too!

yrmvgh commented on 2017-03-09 21:49

This is awesome. Thanks for doing this!

Note: I recently changed a bunch of settings to make it possible to install yiufcrawl alongside DCSS without conflicts. Please try it and let me know if I need to change anything!

Pop into ##crawl-forks on Freenode if you want to chat.