Package Details: subtitlecomposer 0.6.6-3

Git Clone URL: https://aur.archlinux.org/subtitlecomposer.git (read-only)
Package Base: subtitlecomposer
Description: A KDE subtitle editor
Upstream URL: https://github.com/maxrd2/subtitlecomposer
Keywords: composer editor kde subtitle
Licenses: GPL
Submitter: Martchus
Maintainer: Martchus (maxrd2)
Last Packager: Martchus
Votes: 18
Popularity: 2.674630
First Submitted: 2015-09-02 23:50
Last Updated: 2018-06-10 19:47

Pinned Comments

Martchus commented on 2016-05-18 21:59

All my packages are managed at GitHub where you can also contribute directly: https://github.com/Martchus/PKGBUILDs
There also exist a binary repository (i686 and x86_64, also contains Git version): https://martchus.no-ip.biz/repo/arch/ownstuff

Latest Comments

1 2 3 Next › Last »

Neros commented on 2018-06-12 23:43

@Martchus Thanks!

Martchus commented on 2018-06-11 14:00

@Neros If you don't need it, just leave pocketsphinx out-commented and build in a clean chroot. This is the cheapest workaround.

maxrd2 commented on 2018-06-11 13:50

@Neros that cmake error is because of invalid sphinbase pkgconfig file. Have submitted pull request upstream: https://github.com/cmusphinx/sphinxbase/pull/55 Before its merged sphinxbase.pc.in should be patched manually.

Neros commented on 2018-06-11 12:39

I can't compile it anymore:

CMake Error at /usr/share/cmake-3.11/Modules/FindPkgConfig.cmake:54 (set):
  Syntax error in cmake code at

    /usr/share/cmake-3.11/Modules/FindPkgConfig.cmake:54

  when parsing string

    ;pocketsphinx;m;sphinxbase;sphinxad;pulse;pulse-simple;pthread;m;blas;lapack;pulse\;pulse-simple\;pthread\;m\;blas\;lapack\

  Invalid character escape '\' (at end of input).
Call Stack (most recent call first):
  /usr/share/cmake-3.11/Modules/FindPkgConfig.cmake:81 (_pkgconfig_set)
  /usr/share/cmake-3.11/Modules/FindPkgConfig.cmake:113 (_pkgconfig_invoke)
  /usr/share/cmake-3.11/Modules/FindPkgConfig.cmake:450 (_pkgconfig_invoke_dyn)
  /usr/share/cmake-3.11/Modules/FindPkgConfig.cmake:585 (_pkg_check_modules_internal)
  cmake/FindPocketSphinx.cmake:11 (pkg_check_modules)
  src/speechplugins/pocketsphinx/CMakeLists.txt:1 (find_package)


-- Configuring incomplete, errors occurred!
See also "/tmp/yaourt-tmp-neros/aur-subtitlecomposer/src/subtitlecomposer-0.6.6/CMakeFiles/CMakeOutput.log".
See also "/tmp/yaourt-tmp-neros/aur-subtitlecomposer/src/subtitlecomposer-0.6.6/CMakeFiles/CMakeError.log".

Martchus commented on 2017-05-24 21:20

I've just rebuild the package in a clean chroot. Not sure why you're getting this error. Could you provide a little bit more of the output (not just the end)? Which makedepends/optdepends do you use?

andre-fernando commented on 2017-05-24 06:45

I am getting a build error:

make[1]: *** [CMakeFiles/Makefile2:2470: src/speechplugins/pocketsphinx/CMakeFiles/pocketsphinxasr.dir/all] Error 2
make: *** [Makefile:130: all] Error 2
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build subtitlecomposer.

any idea how to fix this?

mikronimo commented on 2017-02-08 13:48

@Martchus: i Just tried to update pocketsphinx, but, still, it requires gst0.10... anyway, i'll try what you said, thanks for the answer.

EDIT: I updated subtitlecomposer, and modified the PKGBUILD (at the prompt request about it); compilation and installation are gone well; the issue, for what about me, is solved. Thanks again.

Martchus commented on 2017-02-08 12:11

mikronimo: Did you read the comments about optional dependencies in the PKGBUILD? I propose you just comment the pocketsphinx dependencies out. There is no real benefit having it anyways because pocketsphinx integration isn't ready yet (as far as I know). But wait, hasn't pocketsphinx already been updated to use new gstreamer?

mikronimo commented on 2017-02-08 02:37

I had all working untill the last update; now that gstreamer0.10 became obsolete in manjaro, i removed it, since the new gstreamer1.10 works in his place; subtitle compser has like dependency gstreamer1.10, but pocketsphinx still have the 0.10 version, so i can't update unless i reinstall it: is there a solution without doing that?

Martchus commented on 2016-05-18 21:59

All my packages are managed at GitHub where you can also contribute directly: https://github.com/Martchus/PKGBUILDs
There also exist a binary repository (i686 and x86_64, also contains Git version): https://martchus.no-ip.biz/repo/arch/ownstuff