Package Details: textext 1.10.2-1

Git Clone URL: https://aur.archlinux.org/textext.git (read-only, click to copy)
Package Base: textext
Description: Re-editable LaTeX graphics for Inkscape
Upstream URL: https://textext.github.io/textext
Licenses: BSD-3-Clause
Submitter: joelsc
Maintainer: carlosal1015
Last Packager: carlosal1015
Votes: 79
Popularity: 0.015206
First Submitted: 2008-05-31 20:36 (UTC)
Last Updated: 2024-02-24 21:41 (UTC)

Pinned Comments

carlosal1015 commented on 2023-04-09 16:18 (UTC)

Important note: Is recommended to receive the following key before to install:

$ gpg --recv-keys 7A9964831E98EED5

Also is possible skip the verification, adding the flag for (e.g makepkg, yay) --skippgpcheck, --nopgpfetch, respectively.

Latest Comments

1 2 3 4 5 6 7 Next › Last »

David01 commented on 2024-03-17 08:53 (UTC)

Hi @carlosal1015. Thanks, I'm a bit new here so sorry in advance, but will the following then be appropriate?

$ gpg --recv-keys 7A9964831E98EED5
$ yay -Syu --aur

Thanks

carlosal1015 commented on 2024-03-16 12:47 (UTC)

Hi @David01, import the key as the pinned comment.

David01 commented on 2024-03-16 11:44 (UTC)

Hi, I'm sorry in advance for raising this question but when doing yay -Syu --aur to update, one gets:

==> Making package: textext 1.10.2-1 (2024-03-16T12:27:10 CET)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Updating textext git repo...
==> Validating source files with sha512sums...
    textext ... Skipped
==> Verifying source file signatures with gpg...
    textext git repo ... %s is unable to verify the signature.
git
==> ERROR: One or more PGP signatures could not be verified!
 -> error making: textext-exit status 1

EarlMilktea commented on 2024-02-25 16:22 (UTC)

gpg key (likely to be the same as imported by gpg --recv-keys 7A9964831E98EED5) is already expired.

davidovitch commented on 2023-12-13 14:24 (UTC) (edited on 2023-12-13 14:27 (UTC) by davidovitch)

you are right @carlosal1015, python-inkex is not needed to build the extension.

I run the PKGBUILD in a very standard bash shell (gnome-console).

When I try to generate some LaTeX output I get the same error as @David01 below (see also https://github.com/textext/textext/issues/399#issuecomment-1705523410)

Return Code: -11:
Emergency save activated!
Emergency save completed. Inkscape will close now.
If you can reproduce this crash, please file a bug at https://inkscape.org/report with a detailed description of the steps leading to the crash, so we can fix it.
** Message: 15:11:38.186: Error: 
 0# Inkscape::Application::crash_handler(int) in /usr/bin/../lib/inkscape/libinkscape_base.so.1.3.2.0
 1# 0x00007FA03285C710 in /usr/lib/libc.so.6
 2# 0x00007FA030E00A7B in /usr/bin/../lib/inkscape/../libgtk-3.so.0
 3# 0x00007FA0320D0D14 in /usr/bin/../lib/inkscape/../libgio-2.0.so.0
 4# 0x00007FA0320D4C2D in /usr/bin/../lib/inkscape/../libgio-2.0.so.0
 5# 0x00007FA03213F1BE in /usr/bin/../lib/inkscape/../libgio-2.0.so.0
 6# 0x00007FA0320D0D14 in /usr/bin/../lib/inkscape/../libgio-2.0.so.0
 7# 0x00007FA0320D4C2D in /usr/bin/../lib/inkscape/../libgio-2.0.so.0
 8# 0x00007FA03212C3B3 in /usr/bin/../lib/inkscape/../libgio-2.0.so.0
 9# 0x00007FA0320D0D14 in /usr/bin/../lib/inkscape/../libgio-2.0.so.0
10# 0x00007FA0320D0D4D in /usr/bin/../lib/inkscape/../libgio-2.0.so.0
11# 0x00007FA03310DF69 in /usr/lib/libglib-2.0.so.0
12# 0x00007FA03316C367 in /usr/lib/libglib-2.0.so.0
13# g_main_context_iteration in /usr/lib/libglib-2.0.so.0
14# g_application_run in /usr/bin/../lib/inkscape/../libgio-2.0.so.0
15# main in /usr/bin/inkscape
16# 0x00007FA032845CD0 in /usr/lib/libc.so.6
17# __libc_start_main in /usr/lib/libc.so.6
18# _start in /usr/bin/inkscape

Have not figured out yet what is going on.

iliakats commented on 2023-12-07 12:14 (UTC)

Please don't depend on typst. The package requires either LaTeX or Typst to be installed, but not both.

carlosal1015 commented on 2023-11-18 15:18 (UTC)

Hi @davidovitch, inkscape already provides /usr/share/inkscape/extensions/inkex/.

IMHO, PKGBUILD's python-inkex forgot python-build, python-poetry-core, python-installer as makedependencies and installed over /usr/lib/python3.11/site-packages/inkex/base.py, i.e., non-default path of inkscape.

Which shell is activated in your session? I guess it's not bash, maybe I must change this path.

davidovitch commented on 2023-10-24 13:44 (UTC)

It seems python-inkex (AUR) is now also a build dependency.

Further, on my system I need to have the pwd command in lower case on line 21, like so:

PYTHONPYCACHEPREFIX="${pwd}/.cache/cpython/" python setup.py --inkscape-extensions-path="${pkgdir}/usr/share/inkscape/extensions"

carlosal1015 commented on 2023-09-17 19:14 (UTC)

Hi @David01, I tested on my real machine, preview is great and the extensions is working as well. No idea what is happening. Maybe could you try to reproduce later the issue.