Package Details: tilix 1.5.6-3

Git Clone URL: (read-only)
Package Base: tilix
Description: A tiling terminal emulator for Linux using GTK+ 3
Upstream URL:
Licenses: MPL
Conflicts: terminix
Provides: terminix
Replaces: terminix
Submitter: carlwgeorge
Maintainer: carlwgeorge
Last Packager: carlwgeorge
Votes: 32
Popularity: 19.768415
First Submitted: 2017-03-20 03:59
Last Updated: 2017-04-25 13:17

Dependencies (11)

Required by (2)

Sources (1)

Latest Comments

carlwgeorge commented on 2017-04-28 01:09

@postblue You've got tons of "undefined reference" errors in that gist, are you sure you have all the build dependencies installed?

@heichblatt What exactly is wrong with a pkgrel bump to trigger a rebuild? It's standard practice in Fedora and other distributions. (and anyone else having issues) The build works fine for myself and others. If you are using an AUR helper utility such as yaourt, try to build gtkd and tilix with plain old makepkg and see if that works for you. commented on 2017-04-26 07:44

@heichblatt I've just rebuild gtkd to 3.6.1-1 but I cant build tilix, either. It printed the same error as shown in @postblue's log.

heichblatt commented on 2017-04-25 21:29

I haven't hunted down the culprit myself but as mentioned before, the latest update of gtkd to 3.6.1-1 and the rebuild of tilix triggered by the pkgrel bump (which is explicitly not meant to be used for stuff like that) fixed the problem for me.

postblue commented on 2017-04-25 16:32

With latest gtkd (3.6.1), I cannot build Tilix:

hriad commented on 2017-04-25 13:49

Seems like 1.5.6-3 fixed the build issue. Good job!

anrichvs commented on 2017-04-25 06:41

Can also confirm that rebuilding GTKD and then Tilix fixed the problem. GTKD updated and rebuilt to version 3.6.1-1 and Tilix was then rebuilt as well (version 1.5.6-2)

springer commented on 2017-04-24 19:54

Rebuilding gtkd, then rebuilding tilix fixed it for me too.

arrufat commented on 2017-04-24 15:58

Rebuilding gtkd fixed the problem for me

carlwgeorge commented on 2017-04-24 14:02

I am also getting runtime errors for the package I already built. After some debugging I realized that the liblphobos update from 1.1.1 to 1.2.0 is the problem. After downgrading that package it runs correctly. I imagine if you downgrade that package it will also allow you to build it again.

I'll keep looking into this to see what is needed to get it to correctly build with liblphobos 1.2.0.

hriad commented on 2017-04-24 12:45

Same issue as reported by @heichblatt

All comments