Package Details: tllocalmgr-git v0.7.r3.gbbd8488-7

Git Clone URL: (read-only, click to copy)
Package Base: tllocalmgr-git
Description: A shell and command-line utility to manage TeXLive on Arch Linux
Upstream URL:
Keywords: texlive
Licenses: GPL
Conflicts: texlive-localmanager, texlive-localmanager-git
Provides: texlive-localmanager=v0.7.r3.gbbd8488
Submitter: hv15
Maintainer: hv15
Last Packager: hv15
Votes: 11
Popularity: 0.84
First Submitted: 2020-02-02 21:08
Last Updated: 2021-05-23 13:54

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 Next › Last »

hv15 commented on 2020-06-29 20:33

Hi @TornaxO7, if you used tllocalmgr, then it will have installed the TeX packages as ArchLinux packages (using makepkg/pacman). Have you searched for these in the installed local packages, e.g. pacman -Qs texlive-local-...? You can then uninstall using pacman.

EDIT 1: typos...

hv15 commented on 2020-06-29 20:31

Hi @AlphaJack, sorry for my late response. Upstream hasn't updated some variables to handle texlive 2020, I'll create patch of this in the next 24 hours. Thank you for reporting the issue :)

EDIT: Done, please let me know if there are any problems.

TornaxO7 commented on 2020-06-29 19:47

How can I delete an installed tex-package????

AlphaJack commented on 2020-06-26 17:46

Is it normal to always get this kind of error when updating a CTAN package?

:: texlive-local-caption and texlive-core are in conflict. Remove texlive-core? [y/N] n
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: texlive-local-caption and texlive-core are in conflict (texlive-core>=2019.55507)


:: texlive-local-context-vim and texlive-core are in conflict. Remove texlive-core? [y/N] n
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: texlive-local-context-vim and texlive-core are in conflict (texlive-core>=2019.55652)

Using the latest 2020 texlive-core

2ion commented on 2020-04-11 16:08

BUG: package() in the PKGBUILD will fail if makepkg is executed in a directory the path of which contains a space! This is due to improper variable quoting.

Please consider fixing all instances of this in the PKGBUILD. Patch here:

Ondrian commented on 2020-03-08 15:19

@hv15 Thanks for the tip! I'll have to read up on asp and packaging overall but definitely sounds more robust, than my current approach, haha.

hv15 commented on 2020-03-08 15:12

@Ondrian got it :), glad you were able to to sort it out. I only hope that when texlive-* gets updated, you don't have to go through dependency hell again. It would be nice if tllocalmgr would track Tex dependencies, but I don't think this is even supported through CTAN.

As an alternative, you could use asp to get the relevant texlive- PKGBUILDs and update these instead directly for your own use. I think this would be more robust and hopefully avoid dependency problems.

Ondrian commented on 2020-03-08 14:20

@hv15 I have a standard installation of texlive-most (and dependencies). I decided to update the texlive packages polyglossia and luavlna through tllocalmgr, since there have been some updates since the last update to texlive-most.

Then, I got the error Undefined control sequence. \str_lowercase:n -- apparently, this was because \str_lowercase:n was introduced in the beginning of January and therefore not in the current l3kernel package provided by texlive-most. After installing l3kernel through tllocalmgr this was solved, but many other packages were broken. In the end, I installed about 30 packages through tllocalmgr and finally I have a working latex installation including the up-to-date luavlna.

My point here is, updating a single texlive package can be dangerous, since the version dependencies are not handled at the package level, but (similarly to arch linux), everything in the up-to-date CTAN repository "should be" compatible.

And just to clarify - by the older releases I meant the tex packages provided by the "not so much up-to-date" current version of texlive-most.

hv15 commented on 2020-03-08 14:05

@Ondrian ah, I understand, I think... what do you mean by older releases? Are these the Tex packages you installed?

Ondrian commented on 2020-03-08 13:47

@hv15 That's what I used it for in the beginning - I wanted to update a few packages that recently implemented new functionality. Then I realized some updates depend on others -- e.g. the l3kernel. Now, I have an inconsistent installation with some files from the latest LaTeX2e <2020-02-02> patch level 2 release and some older ones. So the installation is broken, but it's kind of difficult to understand why, since the error messages are quire cryptic. So now I'm manually installing everything I think might be required. I know - great approach :D