Package Details: tmuxinator 0.12.0-1

Git Clone URL: (read-only)
Package Base: tmuxinator
Description: Manage complex tmux sessions easily
Upstream URL:
Licenses: MIT
Submitter: lucacesari
Maintainer: lucacesari
Last Packager: lucacesari
Votes: 61
Popularity: 0.430426
First Submitted: 2013-06-26 07:49
Last Updated: 2018-08-05 09:19

Latest Comments

1 2 3 4 Next › Last »

slav commented on 2018-10-19 19:57

@deathsbreed Thanks for letting know. Yes I ignore it. I just would like to report that it happen after Tmux upgrade to last version.

deathsbreed commented on 2018-10-19 08:47

slav, this happen because of how tmuxinator is written. They have it programmed to recognize deprecation, but only by comparing it to a list of supported version strings instead of trying to see if the version of tmux is later than v1.5. I'd say you should simply ignore it until tmuxinator updates itself. There might also be an option to omit that message, but I am not aware of it.

slav commented on 2018-10-17 20:10


After last update to tmux v2.8 unfortunately come everytime below message before running tmuxinator:

DEPRECATION: You are running tmuxinator with an unsupported version of tmux. Please consider using a supported version: (1.5, 1.6, 1.7, 1.8, 1.9, 2.0, 2.1, 2.2, 2.3, 2.4, 2.5, 2.6, 2.7)

KingSpeedy commented on 2018-02-07 12:38

ruby-rdoc should be added as a dependency.

apaatsio commented on 2018-02-06 21:46

Installation of 0.10.1-2 is failing for me. Am I missing a dependency or something?

Successfully installed tmuxinator-0.10.1
ERROR:  While executing gem ... (Gem::DocumentError)
    RDoc is not installed: cannot load such file -- rdoc/rdoc
==> ERROR: A failure occurred in package().
==> ERROR: Makepkg was unable to build tmuxinator.
==> Restart building tmuxinator ? [y/N]

slav commented on 2018-02-05 21:58

with new version all back to normal with ruby and tmuxinator back to life now thank you!

slav commented on 2018-02-05 21:57

with new version all back to normal with ruby and tmuxinator back to life now thank you!

archerie commented on 2018-02-04 22:39

Also another error when starting tmuxinator

/usr/lib/ruby/2.5.0/rubygems/dependency.rb:310:in to_specs': Could not find 'xdg' (>= 2.2.3, ~> 2.2) among 33 total gem(s) (Gem::MissingSpecError) Checked in 'GEM_PATH=/home/theuser/.gem/ruby/2.5.0:/usr/lib/ruby/gems/2.5.0', executegem env` for more information

archerie commented on 2018-02-04 22:36

Well there's a new version out but with the same error. Maintainer could you please fix this so we don't need to update the pkgbuild manually?

/usr/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in `require': cannot load such file -- ubygems (LoadError)

asermax commented on 2018-02-03 17:32

Some hints to build which worked for me on the current ruby version:

  • On line 19, add an extra line before the rubygems option:

    local _gemdir="$(ruby -rrubygems -e'puts Gem.default_dir')"

  • Add ruby-rdoc to makedepends