Package Details: tmuxinator 1.1.1-1

Git Clone URL: https://aur.archlinux.org/tmuxinator.git (read-only)
Package Base: tmuxinator
Description: Manage complex tmux sessions easily
Upstream URL: https://github.com/aziz/tmuxinator
Licenses: MIT
Submitter: lucacesari
Maintainer: lucacesari
Last Packager: lucacesari
Votes: 64
Popularity: 0.122467
First Submitted: 2013-06-26 07:49
Last Updated: 2019-06-04 19:43

Latest Comments

1 2 3 4 5 Next › Last »

solatis commented on 2019-05-02 05:38

Can someone update this? The current version triggers a warning with tmux 2.9, and 1.0.0 has been released.

noirvent commented on 2019-02-12 08:46

@archerie Had the same problem. Actually reinstalling package ruby-erubis and whatever package tmuxinator is complaining about (for me there was ruby-xdg too) with pacman did the trick

archerie commented on 2019-02-05 13:11

@cgirard What command could I run to rebuild all ruby-* packages?

cgirard commented on 2019-01-14 13:07

@deathsbreed: you should rebuild your ruby-* packages after ruby version update.

deathsbreed commented on 2019-01-14 12:05

After an update of tmuxinator, it started failing saying that it couldn't find the erubis gem, which I did have installed. Turns out the erubis gem was located in /usr/lib/ruby/gems/2.5.0 while my GEM_PATH only included /usr/lib/ruby/gems/2.6.0. I'm not sure how one would solve this, but as a temporary fix you can just add the line export GEM_PATH="$GEM_PATH:/usr/lib/ruby/gems/2.5.0" to your .bashrc or whatever shell rc file you have.

marceljoseph commented on 2018-11-13 23:01

Is it possible to add the completion plugins to ~/.bin as stated in the readme upstream?

asermax commented on 2018-10-21 00:10

@slav if you want to disable the message until the mantainer's update their code, you can go into /usr/lib/ruby/gems/2.5.0/gems/tmuxinator-0.12.0/lib and modify the tmuxinator.rb file to include 2.8 as a valid version.

@deathsbreed you could auto apply that change through a patch on the PKGBUILD, but it's probably more work than it's worth, it's probably gonna get update soon anyways :P

slav commented on 2018-10-19 19:57

@deathsbreed Thanks for letting know. Yes I ignore it. I just would like to report that it happen after Tmux upgrade to last version.

deathsbreed commented on 2018-10-19 08:47

slav, this happen because of how tmuxinator is written. They have it programmed to recognize deprecation, but only by comparing it to a list of supported version strings instead of trying to see if the version of tmux is later than v1.5. I'd say you should simply ignore it until tmuxinator updates itself. There might also be an option to omit that message, but I am not aware of it.

slav commented on 2018-10-17 20:10

Hi,

After last update to tmux v2.8 unfortunately come everytime below message before running tmuxinator:

DEPRECATION: You are running tmuxinator with an unsupported version of tmux. Please consider using a supported version: (1.5, 1.6, 1.7, 1.8, 1.9, 2.0, 2.1, 2.2, 2.3, 2.4, 2.5, 2.6, 2.7)