Package Details: toxic-git 0.7.1.r15.gf858714-1

Git Clone URL: https://aur.archlinux.org/toxic-git.git (read-only, click to copy)
Package Base: toxic-git
Description: CLI Frontend in ncurses for Tox
Upstream URL: https://tox.chat
Licenses: GPL3
Conflicts: toxic
Provides: toxic
Submitter: fhahn
Maintainer: farseerfc (quininer)
Last Packager: farseerfc
Votes: 48
Popularity: 0.000000
First Submitted: 2013-09-01 23:14 (UTC)
Last Updated: 2016-11-29 07:45 (UTC)

Latest Comments

kseistrup commented on 2016-02-13 16:22 (UTC)

Please correct the error in the PKGBUILD file.

HalosGhost commented on 2015-12-11 22:48 (UTC)

Note: ==> ERROR: url should not be an array

nil0x42 commented on 2015-11-26 10:32 (UTC)

missing dependency: 'qrencode' please consider upgrading the package

rumpelsepp commented on 2015-08-22 08:53 (UTC)

toxcore has been included in the official packages: https://www.archlinux.org/packages/community/x86_64/toxcore/

confusedfla commented on 2015-04-13 15:38 (UTC)

urras: sorry for being to so noobish - worked perfectly! Thank you!

urras commented on 2015-04-13 13:33 (UTC)

confusedfla: Make sure you're on the latest version of Toxcore. Please re-install tox-git from the AUR

confusedfla commented on 2015-04-13 05:30 (UTC)

fails to build - I get a lot of unknown type errors. chat_commands.c:259:5: error: unknown type name ‘TOX_ERR_FILE_SEND’ [..] chat.c:390:95: error: unknown type name ‘TOX_FILE_CONTROL’

kseistrup commented on 2015-04-05 10:46 (UTC)

Building fails here with lots of errors in chat.c, e.g.: chat.c:1101:8: error: ‘ToxWindow’ has no member named ‘onMessage’ chat.c:1102:8: error: ‘ToxWindow’ has no member named ‘onConnectionChange’ chat.c:1106:8: error: ‘ToxWindow’ has no member named ‘onStatusChange’ chat.c:1110:8: error: ‘ToxWindow’ has no member named ‘onFileControl’ and so on… Previous version compiled without any problems.

fhahn commented on 2015-04-03 20:35 (UTC)

Thanks @hitori and @Tyr3al, I have update the PKGBUILD.

hitori commented on 2015-03-30 08:57 (UTC)

Patch for the updated PKGBUILD: http://ix.io/hcY

Tyr3al commented on 2015-01-06 15:07 (UTC)

Does not compile... Makefile:2036: recipe for target '../toxencryptsave/libtoxencryptsave_la-toxencryptsave.lo' failed make[2]: *** [../toxencryptsave/libtoxencryptsave_la-toxencryptsave.lo] Error 1 make[2]: Leaving directory '/home/socrat/BUILDS/toxcore-master/build' Makefile:501: recipe for target 'all-recursive' failed make[1]: *** [all-recursive] Error 1 make[1]: Leaving directory '/home/socrat/BUILDS/toxcore-master' Makefile:407: recipe for target 'all' failed make: *** [all] Error 2

fhahn commented on 2014-10-10 10:50 (UTC)

Thanks, I've updated the PKGBUILD

sekret commented on 2014-10-08 11:14 (UTC)

Ok this package needs quite a big update! I don't want to write too much about it, but updated the PKGBUILD. Look at it and feel free to just take it. I'm not sure about which dependency could be used as optional, but freealut definitely can not: $ toxic toxic: error while loading shared libraries: libalut.so.0: cannot open shared object file: No such file or directory Here's the PKGBUILD http://codepad.org/JGcIJqen Namcap's output is clean, so I guess it's good. And the use of tags in pkgver is possible, so please use them.

kafkafuura commented on 2014-09-02 06:09 (UTC)

asciidoc appears to be a dependency when freealut and openal are used. Strangely, it built just fine without asciidoc when freealut was not present on my system. The issue was a call for a2x (not found) when building man pages, iirc.

Aentfs commented on 2014-08-11 16:06 (UTC)

@urras Sorry, but it was, because first, I always build libsodium-git and tox-git before toxic-git. Second, according to Travis on https://github.com/Tox/toxic the last build was not successful at that moment. P.S. I agree that many problems are fixable by recompiling tox-git first, but in this case it wouldn't have helped.

urras commented on 2014-08-09 03:44 (UTC)

It isn't an upstream error. To fix the build error, you just need to rebuild tox-git.

Aentfs commented on 2014-08-01 22:18 (UTC)

This is an upstream error, for some reason they break their code every few weeks. (Had last week a similar problem, was fixed the next day, so try to recompile tomorrow)

Aentfs commented on 2014-08-01 22:16 (UTC)

Yeah, the only problem is, that makedeps are needed at compile time and aren't optional, so nobody can compile it without audio support or changing the PKGBUILD.

td123 commented on 2014-08-01 14:05 (UTC)

freealut needs to be a makedepends AND and optdepends otherwise we get: ../cfg/sound_notifications.mk:19: WARNING -- Toxic will be compiled without sound notifications support ../cfg/sound_notifications.mk:20: WARNING -- You need these libraries for sound notifications support ../cfg/sound_notifications.mk:21: WARNING -- freealut Also this package currently fails to build with: http://pastie.org/pastes/9436787/text

fhahn commented on 2014-07-31 08:21 (UTC)

Thanks, fixed!

sekret commented on 2014-07-30 12:16 (UTC)

Hi, please fix the typo in the license ;)

fhahn commented on 2014-07-28 18:04 (UTC)

Thanks for the feedback, I've updated to PKGBUILD

Aentfs commented on 2014-07-22 11:44 (UTC)

Since a few commits "openal" and "freealut" are optional dependencies for having audio notifications. Would be great to add these two packages to the optdepends array.

commented on 2014-07-21 21:49 (UTC)

I feel like "GLPv3" is not a valid license :P You might want to replace it with "GPL3".

aksr commented on 2014-06-27 06:32 (UTC)

No, thank you for your fast response. :)

fhahn commented on 2014-06-26 22:19 (UTC)

Thanks for the hint, I've updated the PKGBUILD

aksr commented on 2014-06-26 21:31 (UTC)

Hi, please update the PKGBUILD. No more autoreconf, configure etc...

Brottweiler commented on 2014-06-24 11:03 (UTC)

Probably have to update the PKGBUILD because upstream removed autotools.

aitjcize commented on 2014-04-09 13:50 (UTC)

@fhahn, it still wrong: change the package function to exactly package() { cd "${srcdir}/${_gitname}" make DESTDIR=${pkgdir} install } notice that I cd to the ${_gitname} not the build dir the make install command will take care the installation of the toxic and DHTnodes file.

fhahn commented on 2014-04-07 22:22 (UTC)

I've updated the PKGBUILD

aitjcize commented on 2014-04-04 08:42 (UTC)

@fhahn, change the package section to the following code package() { cd "${srcdir}/${_gitname}" make DESTDIR=${pkgdir} install }

fhahn commented on 2014-03-20 19:52 (UTC)

I've updated the PKGBUILD to use ´make install´, but this did not install the DHTnodes file in the correct place. I've installed the DHTnodes file manually for now, sorry for the long delay

Brottweiler commented on 2014-03-14 10:30 (UTC)

@aitjcize Do you mean to replace "install -Dm755 toxic "${pkgdir}/usr/bin/toxic"" with "make install"? The entire line? Until this gets changed in this PBGBUILD, I'd like to do it myself, and I am not fully sure since I am a bit of a noob at this. :)

aitjcize commented on 2014-03-10 18:22 (UTC)

Please use `make install` instead of manually install -D. The DHTnode file isn't installed due to this.

fhahn commented on 2013-08-23 13:33 (UTC)

tox-git does not build correctly at the moment, replace the package() section with: package() { cd $_gitname install -dm755 "$pkgdir/usr/include/tox/" install -m755 -t "$pkgdir/usr/include/tox/" core/*.h cd build/testing install -Dm755 nTox "$pkgdir/usr/bin/nTox" install -Dm755 DHT_test Messenger_test Lossless_UDP_testclient \ Lossless_UDP_testserver "$pkgdir/usr/bin/" install -Dm644 ../core/libtoxcore.a "$pkgdir/usr/lib/libtoxcore.a" install -Dm644 ../../COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING" } to install the tox header files