Package Details: tracks 2.3.0-1

Git Clone URL: https://aur.archlinux.org/tracks.git (read-only)
Package Base: tracks
Description: Web-based application helping to implement the 'Getting things done' methodology
Upstream URL: http://www.getontracks.org/
Licenses: GPL
Submitter: None
Maintainer: Slash
Last Packager: Slash
Votes: 10
Popularity: 0.071586
First Submitted: 2009-07-15 01:52
Last Updated: 2015-12-09 02:11

Required by (0)

Sources (3)

Latest Comments

bassie127 commented on 2016-04-03 10:26

makepkg -s gives error "ERROR: url should not be an array".
Can somebody fix this? Just remove the parentheses seems to be enough.

jackjackk commented on 2016-03-02 14:55

On Arch Linux ARM, I get:

"ruby: relocation error: /tmp/pacaurtmp-jack/tracks/src/TracksApp-tracks-4070f4e/vendor/bundle/ruby/2.2.0/gems/mysql2-0.3.16/lib/mysql2/mysql2.so: symbol mysql_get_client_info, version libmysqlclient_16 not defined in file libmysqlclient.so.18 with link time reference"

what can I do?

Slash commented on 2015-12-09 02:11

It looks like they changed the zip file since the initial release of 2.3.0. I updated the PKGBUILD.

ecognito commented on 2015-12-07 07:28

Just tried to makepkg and got:

Validating source files with sha256sums...
default_db.patch ... Passed
tracks.service ... FAILED
tracks.zip ... FAILED

Also, may want to consider getting:

https://github.com/TracksApp/tracks/archive/v${pkgver}.zip

instead of:

https://github.com/TracksApp/tracks/zipball/v${pkgver}

in the PKGBUILD.

bassie127 commented on 2015-02-14 12:28

Newbie:
makepkg -s gave ERROR: target not found ruby-bundler
Must this be changed to 'ruby2.1-bundler'?

Slash commented on 2013-12-03 23:45

Thanks, I updated the PKGBUILD

ganryu commented on 2013-12-03 20:31

Might want to add libxml2, libxslt, libmariadbclient to the dependencies as they're required for compile.

Thankyou for maintaining this as it saves me and others a lot of trouble.

Slash commented on 2013-08-06 22:08

I bundled the exact versions of the gems required for Tracks as part of this package, defaulted to Mongrel as the web server and SQLite as the database so you should be able to build this package, start the service, and have a working version of Tracks.

Necopinus commented on 2012-04-28 06:04

I don't have the time to update this package right now, and in any event have migrated to using EMACS' org-mode. So if someone else would like to take this over that'd probably be for the best.

Necopinus commented on 2011-12-11 16:59

Taking this package over, as I actually use it and prefer installing from PKGBUILDs.

That said, there are some dependency issues - a lot of the gems that Tracks needs are out-of-date in AUR, and I frankly don't have the time/energy to maintain all of the necessary builds. For now you should get a message at the end of installation detailing the additional gems you'll need to build. If anyone else wants to maintain the supporting PKGBUILDs, let me know and I'll add your work as deps. Otherwise I'll port all the dependencies over to packages in the official repositories once Tracks is ported to Ruby 1.9+.

All comments