Package Details: trillian 6.0.0.1-1

Git Clone URL: https://aur.archlinux.org/trillian.git (read-only)
Package Base: trillian
Description: A commercial, multi-protocol and cross-platform IM client
Upstream URL: https://www.trillian.im
Keywords: im
Licenses: proprietary
Submitter: mariusn
Maintainer: xyon
Last Packager: xyon
Votes: 12
Popularity: 1.387630
First Submitted: 2013-10-09 08:12
Last Updated: 2017-07-18 13:14

Latest Comments

DefaultSpatula commented on 2017-05-26 23:01

Version 1.0.2.l-1 of the openssl-1.0 package resolves the compatibility issues for me.

Using HanFox's PKGBUILD below (thanks!), replace the openssl dependency with openssl-1.0. You shouldn't need libopenssl-1.0-compat anymore. The other dependencies seem correct based on the .deb file and it worked for me without doing anything extra.

HanFox commented on 2017-05-23 07:13

I won't be updating this package because it still looks like trash (sadly) and I just don't need Trillian anymore.

EDIT: I updated the PKGBUILD to reflect what defaultspatula says above:
https://pastebin.com/hfuhWS4P

Someone who uses Trillian should really take over this package though ;)

---

OLD POST BELOW FOR BREVITY:
In response to nullvoid though the "better" way to get around the error is to get libopenssl-1.0-compat from the AUR and launch trillian with:

LD_PRELOAD=/usr/lib/openssl-1.0-compat/libssl.so.1.0.0:/usr/lib/openssl-1.0-compat/libcrypto.so.1.0.0 trillian

Here's a quick PKGBUILD to deal with the above (not sure if the deps are 100% correct): https://pastebin.com/hfuhWS4P

You'll still need to either edit the trillian.desktop or make a new one in your ~/.local folder with the aforementioned way to launch it.

nullvoid commented on 2017-05-09 12:55

For those of who are getting an error regarding "libcrypto.so" and "libssl.so.1.0.0", I have a temporary solution for you.

* Download an old version of libssl for Debian: http://security.ubuntu.com/ubuntu/pool/main/o/openssl/libssl1.0.0_1.0.1-4ubuntu5.39_amd64.deb
* Extract: ar vx libssl1.0.0_1.0.1-4ubuntu5.39_amd64.deb
* Extract data: tar -xvf data.tar.gz
* Copy the lib files into the trillian directory: sudo cp ./lib/x86_64-linux-gnu/lib* /usr/share/trillian

Fixed it for me. Would really like an alternative though.

realmain commented on 2017-05-09 03:15

New Trillian version is out: https://www.trillian.im/get/linux/6.0/linux.html

https://www.trillian.im/changelog/linux/6.0/

realmain commented on 2017-05-02 18:03

Received this e-mail from Trillian:

"We plan on pushing out a Linux build either this week or next week - sorry for the delay.

-Kevin"

It should be using libzip.so.5 too.

Kisuke-CZE commented on 2017-03-21 16:32

Does not work after updating libzip.
But this quick fix works:

ln -s /usr/lib/libzip.so.5.0.0 /usr/lib/libzip.so.4

nullvoid commented on 2016-06-04 00:15

Hi guys. Just wanted to confirm that with the latest update, this is now working for me. Thanks for the hard work, Han.

HanFox commented on 2016-05-23 14:48

Oh, you're right. It's because I'd downgraded gtk3 to 3.18 due to theme issues and gtkmm3 threw an error because it wasn't in sync with gtk3. My bad. I'll update the PKGBUILD then.

Kisuke-CZE commented on 2016-05-23 14:16

That is odd. On my archlinux installation it is working just fine.
Previous version was crashing on libcrypto and libssl errors.

version 2.0.0.7 reports same errors in console as previous:
trillian: /usr/lib/libcrypto.so.1.0.0: no version information available (required by trillian)
trillian: /usr/lib/libssl.so.1.0.0: no version information available (required by trillian)

But it is not crashing. It runs just fine after this report.

HanFox commented on 2016-05-20 20:04

@Kisuke-CZE v2.0.0.7 fails with the same errors as earlier versions have.

All comments