Package Details: ulauncher 5.15.7-1

Git Clone URL: https://aur.archlinux.org/ulauncher.git (read-only, click to copy)
Package Base: ulauncher
Description: Application launcher for Linux
Upstream URL: https://ulauncher.io
Keywords: application launcher stable
Licenses: GPL3
Submitter: ulauncher
Maintainer: ulauncher (friday)
Last Packager: friday
Votes: 70
Popularity: 0.028376
First Submitted: 2017-03-03 09:36 (UTC)
Last Updated: 2024-04-02 20:39 (UTC)

Pinned Comments

friday commented on 2023-10-02 18:19 (UTC) (edited on 2023-10-21 16:18 (UTC) by friday)

When you update Python, you need to rebuild all python AUR packages, including Ulauncher.

See https://github.com/Ulauncher/Ulauncher/discussions/1280 for more info

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 Next › Last »

willemw commented on 2019-04-24 18:40 (UTC)

Note: don't have to use "| xargs ...". Can use "find ... -exec sed ..." and "find ... -delete" instead.

pempek commented on 2018-12-07 11:29 (UTC) (edited on 2018-12-08 02:34 (UTC) by pempek)

Hi, I just installed Ulauncher, but got error when trying to use some of the extensions.

Sample errors:
- Unexpected API error. KeyError: com.github.brpaz.ulauncher-currency
- Unexpected API error. KeyError: com.github.beajeanm.ulauncher-windows-switcher

When I run ulauncher -v, this is what I got:

/usr/lib/python2.7/site-packages/ulauncher/util/desktop/notification.py:1: PyGIWarning: Notify was imported without specifying a version first. Use gi.require_version('Notify', '0.7') before import to ensure that the right version gets loaded.
from gi.repository import Notify
/usr/lib/python2.7/site-packages/ulauncher/ui/windows /PreferencesUlauncherDialog.py:6: PyGIWarning: WebKit2 was imported without specifying a version first. Use gi.require_version('WebKit2', '4.0') before import to ensure that the right version gets loaded.
from gi.repository import Gio, Gtk, WebKit2, GLib

teetest commented on 2018-09-11 11:42 (UTC)

extensions work fine in python2-websocket-client=0.52 https://github.com/Ulauncher/Ulauncher/issues/270 this feature is nice!

ulauncher commented on 2018-09-11 05:57 (UTC)

Hi @wallace11. Please try python2-websocket-client=0.52. Some people reported that 0.51 is also not stable

wallace11 commented on 2018-09-09 06:51 (UTC) (edited on 2018-09-10 05:41 (UTC) by wallace11)

Any news on the issues with last update? python2-notify python2-websocket-client=0.51 installed and still cannot load extensions no matter what.

Edit: Latest Manjaro update (2018-09-10) fixed this problem. I don't know which package it was, though.

teetest commented on 2018-09-05 11:10 (UTC) (edited on 2018-09-05 11:11 (UTC) by teetest)

@ulauncher Thank you.

https://pastebin.com/0wkGE9BK

ulauncher commented on 2018-09-05 07:26 (UTC)

Could you please confirm that you have restarted ulauncher and pacman -Qi python2-websocket-client shows v0.51 or higher?

BTW, I just noticed that the latest version is 0.52.

teetest commented on 2018-09-04 23:04 (UTC)

@ulauncher I run ulauncher in terminal. It shows:

com.github.chenjsa.kingsoft-dict | 2018-09-05 07:02:31,510 | ERROR | websocket: error() | error from callback <bound 0x7f730438a650="" <ulauncher.api.client.client.client="" at="" client.on_open="" method="" object="" of="">>: on_open() takes exactly 2 arguments (1 given)</bound>

com.github.user0308.ulauncher-plugin-jump | 2018-09-05 07:02:31,574 | ERROR | websocket: error() | error from callback <bound 0x7f39f20f6190="" <ulauncher.api.client.client.client="" at="" client.on_message="" method="" object="" of="">>: on_message() takes exactly 3 arguments (2 given)</bound>

com.github.rolfkoenders.ulauncher-myip | 2018-09-05 07:02:39,803 | ERROR | websocket: error() | error from callback <bound 0x7fa18ac44350="" <ulauncher.api.client.client.client="" at="" client.on_message="" method="" object="" of="">>: on_message() takes exactly 3 arguments (2 given)</bound>

ulauncher commented on 2018-09-04 19:37 (UTC)

@teetest what do you see in the logs?