Package Details: ultrastar-creator git.latest-6

Git Clone URL: https://aur.archlinux.org/ultrastar-creator.git (read-only, click to copy)
Package Base: ultrastar-creator
Description: Qt program used to generate USDX songs from scratch
Upstream URL: https://github.com/UltraStar-Deluxe/UltraStar-Creator
Licenses: GPL2
Submitter: maxlefou
Maintainer: maxlefou
Last Packager: maxlefou
Votes: 0
Popularity: 0.000000
First Submitted: 2017-09-01 10:44
Last Updated: 2021-06-01 10:00

Latest Comments

maxlefou commented on 2021-06-01 09:09

@berocs awesome thanks. Update in a few.

berocs commented on 2021-06-01 04:16

It's missing a cld2 dependency. Apply the following patch to the repo with git apply:

diff --git a/.SRCINFO b/.SRCINFO
index af3f582..70cebfc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -10,6 +10,7 @@ pkgbase = ultrastar-creator
    depends = git
    depends = libbass
    depends = taglib
+   depends = cld2-git
    source = git://github.com/UltraStar-Deluxe/UltraStar-Creator.git
    source = ultrastar-creator.desktop
    source = ultrastar-creator
diff --git a/PKGBUILD b/PKGBUILD
index 1edf926..39fa110 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ url=https://github.com/UltraStar-Deluxe/UltraStar-Creator
 license=('GPL2')
 arch=('x86_64')

-depends=('qt5-base' 'qt5-tools' 'git' 'libbass' 'taglib')
+depends=('qt5-base' 'qt5-tools' 'git' 'libbass' 'taglib' 'cld2-git')

 source=('git://github.com/UltraStar-Deluxe/UltraStar-Creator.git'
         'ultrastar-creator.desktop'

tobisaur commented on 2021-01-10 14:13

If anyone is having trouble with the application hanging upon loading a song, make sure it has access to ALSA in one way or another (for me installing pulseaudio-alsa was what fixed it).

maxlefou commented on 2019-10-09 11:05

@barbeque Fixed. Thanks for the report.

barbeque commented on 2019-10-08 17:44

This package also depends on "taglib". I had to install that one manually to get this to run.

tomx3 commented on 2018-10-08 18:46

Please remove "i686" from "arch". Sourcecode includes only libs for 64Bit systems and is not compileable on i686.

maxlefou commented on 2017-09-12 10:19

I think I found the problem: forgotten dependencies. I updated the package. Please try again and tell any other error that might prevent compiling. Thanks for the report.

maxlefou commented on 2017-09-12 07:59

Please be more specific. I can't fix any problem if you don't tell me what exactly is wrong.
Any errors? Logs?

enetheru commented on 2017-09-12 07:30

I cant get this to play. :|