Package Details: virtualbox-ext-oracle 5.1.18-1

Git Clone URL: (read-only)
Package Base: virtualbox-ext-oracle
Description: Oracle VM VirtualBox Extension Pack
Upstream URL:
Keywords: virtualbox
Licenses: custom:PUEL
Submitter: seblu
Maintainer: seblu
Last Packager: seblu
Votes: 1135
Popularity: 13.265371
First Submitted: 2010-12-24 16:48
Last Updated: 2017-03-19 10:50

Dependencies (2)

Required by (1)

Sources (1)

Latest Comments

jamesan commented on 2017-04-21 11:31

tl;dr: package installs/upgrades complete with errors and the extension pack is not successfully added to VirtualBox. Either manually install the extension pack using the CLI VBoxManage command or the VirtualBox GUI after the erroneous install/upgrade or replace the package's post_install() function with prior to install/upgrade:
post_install () {
VBoxManage extpack install --accept-license=$(sha256sum /usr/share/licenses/virtualbox-ext-oracle/PUEL | head --bytes=64) "/usr/share/virtualbox/extensions/Oracle_VM_VirtualBox_Extension_Pack-${1%%-*}.vbox-extpack" >/dev/null


The `VBoxManage extpack install` command fails when run within a script (non-interactively). When run interactively, it requires user acceptance of its license and outputs how to run it non-interactively -- namely, by adding the argument, --accept-license=$HASH, where $HASH is derived to equal the SHA256 hash value of the text file version of the extension pack license (the extracted ./ExtPack-license.txt in the extpack archive file, also installed by this package to /usr/share/licenses/virtualbox-ext-oracle/PUEL). I can confirm this derivation holds true for at least version 5.1.20.

Without changes, upgrading or installation fails at the post_install() VBoxManage command with pacman outputting an "error: command failed to execute correctly" message and the extension pack is not added to VirtualBox. With the above change, the package installs without exception and VirtualBox recognises the new extension pack.

drankinatty commented on 2017-03-21 02:14

As was generally the case, it was the end-user doing something stupid. I had an old version of the guest-additions installed that conflicted with the auto-build of the new modules. 5.1.18 works just fine. Sorry for the noise.

ranger commented on 2017-03-18 11:37

is your host and your guest arch linux? you need virtualbox-ext-oracle for your host only.

Det commented on 2017-03-18 07:00

You say "Build fails for both 5.1.18 and 5.1.16."?

drankinatty commented on 2017-03-18 03:54

Note: when bumping the version to 5.1.18, building/installing the extension pack package worked fine, but when attempting to build the kernel modules for an Arch guest with the 4.10 kernel, I ran into a build failure. Reported upstream:

ranger commented on 2016-11-22 16:31

I had the same problem but upgrading to the latest version of virtualbox-ext-oracle solved the problem.

yan12125 commented on 2016-11-22 15:52

Hello seblu, I know there's already an out-of-date flag, while things are somewhat different this time. With virtualbox 5.1.10, virtual machines refuse to start with older extension packs:

$ vboxmanage startvm win7
Waiting for VM "win7" to power on...
VBoxManage: error: The device helper structure version has changed.
VBoxManage: error: If you have upgraded VirtualBox recently, please make sure you have terminated all VMs and upgraded any extension packs. If this error persists, try re-installing VirtualBox. (VERR_PDM_DEVHLPR3_VERSION_MISMATCH)
VBoxManage: error: Details: code NS_ERROR_FAILURE (0x80004005), component ConsoleWrap, interface IConsole

virtualbox has just entered [community] 90 minutes ago, so I just more people will be affected by this issue.

For others come here, perlsite's comment below (on 2016-07-01 18:32) is helpful. Just change pkgver=5.1.10 and md5sum to ac90d8356746754eadc3f28ef77174f0

WFV commented on 2016-10-30 21:40

I'm getting these errors when updating this package:
error: 'jre8-openjdk-headless-8.u112-1': description file is missing
error: 'jre8-openjdk-headless-8.u112-1': file list is missing
Yet the jre8-openjdk-headless-8 directory does exist in /var/lib/pacman/local and isn't empty, and pacman -Qi shows it is version .u112-1. Happens using pacaur and yaourt, pacaur gives a little more info in the error. What can I do to remedy it?
EDIT: my mistake, had to set default java enviro to 8 today after -Syyu, all is well.

brain_death commented on 2016-10-20 18:35

For the latest version, use:


eaglex commented on 2016-09-16 16:19

For the latest version, use:


All comments