Package Details: webcord-git 4.2.0.r845.66c71e5-2

Git Clone URL: (read-only, click to copy)
Package Base: webcord-git
Description: A Discord and Fosscord client made with the Electron (master branch).
Upstream URL:
Keywords: arm discord electron electron-discord-webapp fosscord
Licenses: MIT
Conflicts: webcord
Provides: webcord
Submitter: SpacingBat3
Maintainer: SpacingBat3
Last Packager: SpacingBat3
Votes: 7
Popularity: 0.002886
First Submitted: 2021-06-07 20:24 (UTC)
Last Updated: 2023-04-09 13:04 (UTC)

Latest Comments

Freso commented on 2023-09-04 15:27 (UTC)

FWIW, when I try to makepkg this PKGBUILD it somehow tries to depend on electron26 which is currently only available via electron26-bin in the AUR. Editing /usr/bin/webcord to remove the "26" works for the time being until electron26 gets added to Arch’s packages. (It’s also complaining about npm 10 being available, but at least that doesn’t seem to prevent the package from building or installing.)

italoghost commented on 2023-04-08 17:51 (UTC)


I am getting the following error:

/home/ghost/.cache/paru/clone/webcord-git/PKGBUILD: line 263: ^24.0.0-1: SyntaxError: expected (error token is "^24.0.0-1")

The package is expecting electron ^24.0.0-1, but even after installing the AUR package "electron24-bin" it doesn't recognize it.

I wonder if it is happening because of the ".0-1", as my package is still considered in beta: "24.0.0.beta.3-2".

Rubos commented on 2023-04-05 12:09 (UTC)

The package asks me to install the typescript package, but with typescript 5.x it gives the following error:

(1/6) Installing dependencies...
(2/6) Cleaning up workspace...
(3/6) Compiling TypeScript to Javascript...
error TS5101: Option 'importsNotUsedAsValues' is deprecated and will stop functioning in TypeScript 5.5. Specify compilerOption '"ignoreDeprecations": "5.0"' to silence this error.
  Use 'verbatimModuleSyntax' instead.

Found 1 error.

Failed to compile TypeScript sources to JavaScript
 -> Fehler beim Erstellen: webcord-git-exit status 1
 -> Failed to install the following packages. Manual intervention is required:
webcord-git - exit status 1

Sir-Photch commented on 2022-12-06 16:07 (UTC) (edited on 2022-12-06 16:08 (UTC) by Sir-Photch)

this does not build since it apparently depends on electron22, which is not part of the packagegs dependencies:

resolving dependencies...
warning: cannot resolve "electron22", a dependency of "webcord-git"
:: The following package cannot be upgraded due to unresolvable dependencies:

:: Do you want to skip the above package for this upgrade? [y/N]
error: failed to prepare transaction (could not satisfy dependencies)
:: unable to satisfy dependency 'electron22' required by webcord-git

Seems like this is available on the AUR. Mind adding this as a dependency?

SpacingBat3 commented on 2021-11-29 16:13 (UTC) (edited on 2021-12-12 17:03 (UTC) by SpacingBat3)

@Raansu The last update should make this package much more stable, as it will now respect the proper dependency versions, rather than using the latest one (which was the common cause of the problems with building my application on Arch). Right now, I believe that in most cases it should fail in the same time it does on GitHub repository.

SpacingBat3 commented on 2021-11-21 21:12 (UTC)

@Raansu, this package should compile for aarch64 as well. However, the current implementation needs to be improved as pointed in GitHub issue tracker.

Raansu commented on 2021-10-27 07:34 (UTC)

Is there anyway to get this to compile on a aarch64 machine? There doesn't appear to be a aarch64 electron package in Arch Linux ARM and I was hoping to compile this for a PinePhone