Package Details: webtorrent-desktop 0.24.0-1

Git Clone URL: https://aur.archlinux.org/webtorrent-desktop.git (read-only, click to copy)
Package Base: webtorrent-desktop
Description: Streaming torrent client.
Upstream URL: https://webtorrent.io/desktop
Licenses: MIT
Conflicts: webtorrent-desktop-bin, webtorrent-desktop-git
Submitter: 314eter
Maintainer: 314eter
Last Packager: 314eter
Votes: 24
Popularity: 0.000092
First Submitted: 2016-04-07 00:02 (UTC)
Last Updated: 2020-08-29 10:30 (UTC)

Latest Comments

gdamjan commented on 2021-04-26 21:54 (UTC)

the application starts, but with a black screen. Openinig the dev console, shows that

Uncaught ReferenceError: require is not defined
    at main.html:11

about the line <script>require('../build/renderer/main.js')</script>

bartus commented on 2019-09-17 22:09 (UTC)

git should be added to makedepends alongside npm.

omano commented on 2019-09-17 00:18 (UTC)

Yep new version works after install, please update this AUR package for everyone else to benefit from the update :)

serdarsaglam commented on 2019-09-16 08:04 (UTC) (edited on 2019-09-16 08:04 (UTC) by serdarsaglam)

Hi New version available v0.21, running smoothly

omano commented on 2019-09-03 11:16 (UTC) (edited on 2019-09-03 11:23 (UTC) by omano)

https://webtor.io/ or else vlc-bittorent plugin works very good for simple torrents ;)

You also have the Flatpak version of webtorrent but it has also its issues (like not being able to use VLC as external player, or not being able to open torrent from outside your home folder..)

qark commented on 2019-09-02 23:13 (UTC)

@fabianski, qBittorrent with sequential download is good enough for me.

malcolm commented on 2019-09-02 23:07 (UTC)

any good alternative for webtorrent?

314eter commented on 2019-09-02 22:49 (UTC)

I don't use WebTorrent anymore, but downgrading pango doesn't work for me. If someone wants to update the package, I can disown it.

omano commented on 2019-08-31 14:10 (UTC) (edited on 2019-08-31 14:13 (UTC) by omano)

Thanks for the finding. Would that be something needed to be reported to WebTorrent devs? EDIT: and it already was reported https://github.com/webtorrent/webtorrent-desktop/issues/1644 but closed. OK.

Boskote commented on 2019-08-29 06:05 (UTC)

Downgrading pango to version 1.43 is a workaround for the error with segfault at launch (I only tested it with webtorrent-desktop-bin, but I assume it is the same here). Version 1.44 ended support for bitmap fonts as part of the transition to the HarfBuzz font loader, more info here: https://wiki.archlinux.org/index.php/Fonts#Bitmap

Tio commented on 2019-08-14 13:57 (UTC)

Same here. Does not start...

omano commented on 2019-08-14 13:27 (UTC) (edited on 2019-08-14 14:23 (UTC) by omano)

I eventually uninstalled it, and installed the FlatHub version, it worked instantly. Would prefere to install this AUR package instead but for now it works great with the flatpak/FlatHub version.

flatpak install flathub io.webtorrent.WebTorrent

cheers. Hope for a fix, in the meantime, enjoy

EDIT: by the way, the "segmentation fault" issue on launch appeared on this manjaro update for me https://forum.manjaro.org/t/stable-update-2019-08-13-kernels-xfce-4-14-kde-libreoffice-6-3-discord-mesa/98600 maybe it can be helpful to troubleshoot the issue.

serdarsaglam commented on 2019-08-07 21:22 (UTC)

It doesn't work, I uninstalled it again, but it still doesn't work.

malcolm commented on 2019-08-03 15:12 (UTC)

Even with root not working, nothing is open.

diegovincent commented on 2019-06-13 22:31 (UTC)

Same as @curiosity. If I try to run it without sudo from the console, nothing gets output to stdout.

314eter commented on 2019-06-05 22:08 (UTC)

@curiosity It works for me. Do you get an error message?

curiosity commented on 2019-06-04 14:38 (UTC)

won't run from menu, won't run from command line as user, will only run as root/sudo.

qark commented on 2019-05-05 16:36 (UTC)

This fixes work with electron 4: https://github.com/webtorrent/webtorrent-desktop/issues/1564#issuecomment-489404377

314eter commented on 2019-04-12 22:31 (UTC)

It works with electron2

qark commented on 2019-04-12 20:28 (UTC)

Doesn't work with current (4.1.1) electron. Probably switch to https://github.com/webtorrent/webtorrent-desktop/tree/greenkeeper/electron-4.1.1 branch might fix that.

Kutabe commented on 2018-06-28 00:07 (UTC)

add npm to make depends

KayleePop commented on 2018-04-21 19:56 (UTC)

Consider using this patch to fix tray functionality on arch. https://pastebin.com/nUUuCUXu

A debian specific check is done in the js code to check that libappindicator1 is installed which always fails on non-debian systems. This patch simply bypasses the check.

If libnotify isn't installed, then the webtorrent window will close without killing the process, but it's already a dependency of the electron package, so it's not an issue.

alex4o commented on 2017-08-13 10:50 (UTC)

gets stuck on: > node ./download-chromedriver.js

commented on 2017-04-10 22:04 (UTC)

hi im having issues with this pkg on gnome please remove the Path= lines from webtorrent-desktop.desktop, and change the second line of the webtorrent-desktop script to: exec electron /usr/lib/webtorrent-desktop "$@" thx

nicman23 commented on 2017-03-31 20:39 (UTC)

please update the PKGBUILD to this https://pastebin.com/7kJs58TU it downloads elctron from repos and has the 18 version

gdamjan commented on 2016-10-05 21:06 (UTC)

oh my, it also downloads electron armv7, electron is now in community, maybe this package can depend and use it?

02m commented on 2016-09-02 10:07 (UTC)

Installation gets stuck with the last output of: ==> Starting build()... npm WARN deprecated lodash@1.2.1: lodash@<3.0.0 is no longer maintained. Upgrade to lodash@^4.0.0. npm WARN deprecated minimatch@2.0.10: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue [ .....] / extract:webtorrent: sill doParallel extract 753

gdamjan commented on 2016-05-20 16:19 (UTC)

why does it download both electron-v1.0.2-linux-x64.zip and electron-v1.0.2-linux-ia32.zip ?

joaomedeiros95 commented on 2016-05-16 11:44 (UTC) (edited on 2016-05-16 11:45 (UTC) by joaomedeiros95)

v0.4.0 released, please update

314eter commented on 2016-05-09 14:57 (UTC)

I added the dependencies, thanks for noticing.

syntobu commented on 2016-05-09 13:53 (UTC)

depends should also include gconf

syntobu commented on 2016-05-09 13:52 (UTC)

makedepends should include git and zip, building will fail without them.

314eter commented on 2016-04-27 11:59 (UTC)

Should be fixed now.

mareke commented on 2016-04-27 06:17 (UTC)

Manually building (also git version) gives error too.

duttondj commented on 2016-04-07 19:54 (UTC)

Won't work using a helper like yaourt, must do makepkg manually.