Package Details: wfuzz 3.1.0-1

Git Clone URL: https://aur.archlinux.org/wfuzz.git (read-only, click to copy)
Package Base: wfuzz
Description: Utility to bruteforce web applications to find their not linked resources
Upstream URL: https://github.com/xmendez/wfuzz
Licenses: GPL
Submitter: onny
Maintainer: dkasak
Last Packager: dkasak
Votes: 15
Popularity: 0.000062
First Submitted: 2011-08-14 09:39 (UTC)
Last Updated: 2020-11-13 12:34 (UTC)

Latest Comments

1 2 Next › Last »

johnnyciocca commented on 2023-12-09 01:19 (UTC) (edited on 2023-12-09 01:26 (UTC) by johnnyciocca)

@alexbraga said to

1- Clone the wfuzz-git repository from the AUR and enter the folder

2- Create a backup of setup.py

but... there's no src folder there?

alexbraga commented on 2023-12-05 03:24 (UTC)

For those facing the error, I wrote the following step-by-step originally for wfuzz-git package, but I believe it should work here as well. Keep in mind the modifications in file paths where applied:

Warning: 'classifiers' should be a list, got type 'tuple'
error in wfuzz setup command: 'install_requires' must be a string or list of strings containing valid project/version requirement specifiers; Expected end or semicolon (after version specifier)
    pyparsing>=2.4*;python_version>="3.5"
             ~~~~~^
==> ERROR: A failure occurred in build().
    Aborting...
 -> error making: wfuzz-git-exit status 4

Here's a fix:

1- Clone the wfuzz-git repository from the AUR and enter the folder:

git clone https://aur.archlinux.org/wfuzz-git.git
cd wfuzz-git

2- Create a backup of setup.py:

cp src/wfuzz/setup.py src/wfuzz/setup.py.orig

3- Modify the setup.py file:

Open the setup.py file in a text editor, find the line 'pyparsing>=2.4*;python_version>="3.5"' and remove the asterisk after 2.4:

'pyparsing>=2.4;python_version>="3.5"'

4- Create the patch file

Navigate to the src/wfuzz directory and generate the patch file:

cd src/wfuzz
diff -u setup.py.orig setup.py > fix_install_requires.patch

5- Go back to the wfuzz-git directory and open the PKGBUILD file for editing:

cd ../..
nano PKGBUILD

6- Add the prepare() function in PKGBUILD right after build():

prepare() {
  cd "$_name"
  sed -i "s|__SETUP_PATH__|$(pwd)/setup.py|" "$srcdir/wfuzz/fix_install_requires.patch"
  patch -p0 < "$srcdir/wfuzz/fix_install_requires.patch"
}

7- Save the changes and exit the text editor.

8- Continue with the installation:

makepkg -si

GI_Jack commented on 2023-05-14 19:22 (UTC)

==> Starting package()...
Warning: 'classifiers' should be a list, got type 'tuple'
error in wfuzz setup command: 'install_requires' must be a string or list of strings containing valid project/version requirement specifiers; Expected end or semicolon (after version specifier)
    pyparsing>=2.4*;python_version>="3.5"
             ~~~~~^

dkasak commented on 2020-04-27 10:35 (UTC)

@PedroHLC, added. Thanks!

PedroHLC commented on 2020-04-26 14:34 (UTC)

Missing python-sphinx as makedepends

dkasak commented on 2020-04-22 11:51 (UTC)

Updated to 2.4.5 and also packages HTML docs, man page and wordlists. I had to relax the pycurl version requirement which I think was accidentally made too strict, but if you encounter any bugs, please yell at me.

cgirard commented on 2019-06-03 08:29 (UTC)

I switched it to Python 3 and corrected the deps.

olivierlm commented on 2019-06-01 16:40 (UTC)

Sorry, I'm not using this anymore, feel free to update !

dkasak commented on 2019-06-01 12:33 (UTC)

Consider switching to Python 3 (especially when 2.4 gets released).

The wfuzz website now says:

Wfuzz supports Python 3. The use of Python 3 is preferred (and faster) over Python 2.

cgirard commented on 2019-05-22 08:18 (UTC)

There is a missing makedepends: python2-setuptools