Package Details: wine-git 4.11.r138.g6e97461580-1

Git Clone URL: https://aur.archlinux.org/wine-git.git (read-only)
Package Base: wine-git
Description: A compatibility layer for running Windows programs (git version)
Upstream URL: https://www.winehq.org/
Keywords: windows wine
Licenses: LGPL
Conflicts: bin32-wine, wine, wine-wow64
Provides: bin32-wine=4.11.r138.g6e97461580, wine=4.11.r138.g6e97461580, wine-wow64=4.11.r138.g6e97461580
Replaces: bin32-wine
Submitter: None
Maintainer: dbermond
Last Packager: dbermond
Votes: 84
Popularity: 0.792695
First Submitted: 2007-07-18 16:01
Last Updated: 2019-06-27 21:57

Dependencies (160)

Required by (230)

Sources (3)

Latest Comments

« First ‹ Previous ... 3 4 5 6 7 8 9 10 11 12 Next › Last »

Anonymous comment on 2012-01-01 14:41

I dunno if anyone else is facing this problem but i get: "wine: failed to initialize: dlopen interface not detected by configure following" following msg after compile and install. all upgraded arch linux x86_64. And the package provided by repo is broken for mouse as it has xinput2 enabled which is broken for many games that i use so i need compile this again without xinput2

korrode commented on 2011-12-27 12:54

if [[ $CARCH == i686 ]]; then
# Strip lib32 etc. on i686
depends=(${depends[@]/*32-*/})
makedepends=(${makedepends[@]/*32-*/})
makedepends=(${makedepends[@]/*-multilib*/})
optdepends=(${optdepends[@]/*32-*/})
else
provides=("wine=$pkgver" "bin32-wine=$pkgver" "wine-wow64=$pkgver")
conflicts=("wine" 'bin32-wine' 'wine-wow64')
replaces=("wine" 'bin32-wine')
fi

---------------------------------------------

Is not the problem obvious?
There's only provides/conflicts/replaces if $CARCH isn't i686.

sxe commented on 2011-11-12 10:26

Can anyone confirm this? I have no i686 installation to test it. On 64bit everything works like expected.

Anonymous comment on 2011-11-09 20:35

Having dependency problems. On i686 it looks like "provides", "conflicts" and "replaces" are *not* set. I discovered this when I tried to install and wine-git did not complain about my existing wine installation at first (I ended up removing it manually). pacman -Qi does not list any "provides", "conflicts" or "replaces". This is a problem if I want to install Arch's wine-gecko!

rwd2 commented on 2011-10-13 09:45

namcap lists some dependency issues: missing dependencies for libgphoto2 and gettext, and several included dependencies that are optional

sxe commented on 2011-10-11 18:52

thx, fixed

xphoniexx commented on 2011-10-11 03:30

Howdy,
Wine is listed as an unnecessary makedepends of itself in the PKGBUILD file.
'makedepends=(wine autoconf ncurses bison perl fontforge flex prelink'

sxe commented on 2011-10-06 09:39

Hi feilen,
do you have any problems with CoreAudio while compiling? I prefer keeping the wine-git PKGBUILD as close as possible to the original wine PKGBUILD.

feilen commented on 2011-10-06 06:52

Couldn't you add --without-coreaudio to the configure options? CoreAudio is for Macs.

sxe commented on 2011-09-06 07:03

done