Package Details: wiredtiger 3.1.1.20190808-1

Git Clone URL: https://aur.archlinux.org/wiredtiger.git (read-only)
Package Base: wiredtiger
Description: High performance, scalable, production quality, NoSQL, Open Source extensible platform for data management
Upstream URL: http://source.wiredtiger.com/
Licenses: GPL
Submitter: felixonmars
Maintainer: chrbayer (jamespharvey20)
Last Packager: jamespharvey20
Votes: 6
Popularity: 0.26
First Submitted: 2019-01-18 22:09
Last Updated: 2019-08-10 02:45

Pinned Comments

jamespharvey20 commented on 2019-08-21 22:53

As of 4.2.0, this is no longer required by aur/mongodb.

Upstream broke mongodb from using wiredtiger as a separate library. Apparently they don't test having them be separate during development or testing.

Upstream advised to not have them be separate packages at least for now, with it being unknown if they will get around to fixing them to be able to be separate again, or will just remove the option entirely. https://jira.mongodb.org/browse/SERVER-42813

Because that leaves this package only required by aur/mongodb-3.4, I think it's best to leave the package at this version and no longer update it, unless 4.2.x is fixed so they can be separate again, or something stops working with mongodb-3.4.

Latest Comments

« First ‹ Previous 1 2 3 4 Next › Last »

felixonmars commented on 2019-01-31 10:03

@francoism90 I used to pick the exact commit from corresponding mongodb release. Otherwise the integration tests of mongodb fail from time to time, indicating there are actually small compatibility issues.

fupduck commented on 2019-01-31 09:46

Could you please add "gperftools" to the dependencies? Without gperftools the build failed with "configure: error: --enable-tcmalloc requires gperftools/tcmalloc.h"

francoism90 commented on 2019-01-31 08:29

@chrbayer Did you change makepkg.conf changes? Try in a clean chroot.

francoism90 commented on 2019-01-31 08:21

@rich_o You can simple downgrade, it will ask to confirm this action when installing this package. Don't know why it included the date as version because it was not needed, this part has now been removed. I didn't want to bump with epoch either.

You may have to rebuilt mongodb as this include some changes, although this should not be needed in most cases.

rich_o commented on 2019-01-30 15:55

The pacman universe considers the new version 3.1.0-1 as smaller than the old version 3.1.0.20181203-1, see https://www.archlinux.org/pacman/vercmp.8.html. So I can't update to the new version without de- and reinstalling. As wiredtiger is a dependency of mongo, I don't really want to go that way.

chrbayer commented on 2019-01-30 12:35

Using the latest version, I still get an error:

depbase=echo src/utilities/util_cpyright.o | sed 's|[^/]*$|.deps/&|;s|\.o$||';\

cc -DHAVE_CONFIG_H -I. -I./api/leveldb -I./src/include -D_FORTIFY_SOURCE=2 -std=c11 -D_GNU_SOURCE -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong -fno-plt -MT src/utilities/util_cpyright.o -MD -MP -MF $depbase.Tpo -c -o src/utilities/util_cpyright.o src/utilities/util_cpyright.c &&\

mv -f $depbase.Tpo $depbase.Po

File "wtperf_config.py", line 24

print '@par ' + v[0] + ' (' + v[3] + ', default=' + d + ')'

^

SyntaxError: invalid syntax

which leads to

make[2]: [Makefile:3651: docs/index.html] Error 1

make[2]: Waiting for unfinished jobs....

make[2]: Leaving directory '/home/chrbayer/packages/wiredtiger/src/wiredtiger-3.1.0'

make[1]: [Makefile:2686: all-recursive] Error 1

make[1]: Leaving directory '/home/chrbayer/packages/wiredtiger/src/wiredtiger-3.1.0'

make: [Makefile:1380: all] Error 2

==> ERROR: A failure occurred in build().

Aborting...

francoism90 commented on 2019-01-30 09:47

@chrbayer I have updated the PKG, could you please try again? It builds without issues for me.

francoism90 commented on 2019-01-30 09:46

I have changed the configure flags:

./configure --prefix=/usr \
    --enable-crc32-hardware \
    --enable-leveldb \
    --enable-python \
    --enable-snappy \
    --enable-lz4 \
    --enable-tcmalloc \
    --enable-zlib \
    --enable-zstd \
    --with-python-prefix=${pkgdir}/usr/lib/python3.7/site-packages

Be aware when rebuilding this package.

chrbayer commented on 2019-01-29 10:36

Even with the changed default python version, the first build with makepkg failed, the second try works... So reverted the default version and tried again with python3 and without changing the .py files. This builds with the second try, too. So python is not the problem at all...

chrbayer commented on 2019-01-29 10:26

Still does not build... I had to adapt the line, but I verified that the python commands have been changed to python2, but not all python command seems to have such a header. For a test I changed the link python3 -> python to python2 -> python and with that hack the package builds.

I guess there are some patches necessary here :-)