Package Details: wxformbuilder 3.10.1-2

Git Clone URL: https://aur.archlinux.org/wxformbuilder.git (read-only, click to copy)
Package Base: wxformbuilder
Description: RAD tool for wxWidgets GUI design
Upstream URL: https://github.com/wxFormBuilder/wxFormBuilder
Keywords: gui rad wxgtk wxwidgets
Licenses: GPL2
Conflicts: wxformbuilder, wxformbuilder-git, wxformbuilder-svn
Provides: wxformbuilder
Submitter: antoniomx
Maintainer: antoniomx (redtide, jgmdev)
Last Packager: redtide
Votes: 4
Popularity: 0.014769
First Submitted: 2019-04-27 21:27 (UTC)
Last Updated: 2022-08-13 10:23 (UTC)

Latest Comments

1 2 Next › Last »

branalba commented on 2022-08-26 17:51 (UTC)

Works for me as well, thank you

pbneves commented on 2022-08-25 08:14 (UTC)

It worked for me, now. Thanks

redtide commented on 2022-08-13 10:29 (UTC)

Sorry for the delay, I hope it's OK now, please let me know.

vnen commented on 2022-07-30 14:19 (UTC)

Not sure why this is built with Meson (which is giving issues with the wxWidgets 3.2 release) when the upstream only uses CMake officially. See https://github.com/wxFormBuilder/wxFormBuilder/issues/746

pbneves commented on 2022-07-25 08:34 (UTC) (edited on 2022-07-25 08:34 (UTC) by pbneves)

I have wxwidgets 3.2.0 properly installed, and I can't install wxformbuilder with the same error that branalba posted, but it can be built following the instruction of the wxformbuilder site, so I believe that is a package problem, and not a system-wide problem.

branalba commented on 2022-07-18 19:46 (UTC)

Ever since a change to the wx packages last week wxFormBuilder won't launch. Reinstalling it results in this build failure:

==> Starting build()...
The Meson build system
Version: 0.63.0
Source dir: /home/branalba/.cache/yay/wxformbuilder/src/wxFormBuilder-3.10.1
Build dir: /home/branalba/.cache/yay/wxformbuilder/src/wxFormBuilder-3.10.1/_build
Build type: native build
Project name: wxformbuilder
Project version: undefined
C++ compiler for the host machine: c++ (gcc 12.1.0 "c++ (GCC) 12.1.0")
C++ linker for the host machine: c++ ld.bfd 2.38
Host machine cpu family: x86_64
Host machine cpu: x86_64
Compiler for C++ supports arguments -Wall: YES 
Compiler for C++ supports arguments -Wextra: YES 
Compiler for C++ supports arguments -Winit-self: YES 
Compiler for C++ supports arguments -Wimplicit-fallthrough: YES 
Compiler for C++ supports arguments -Wpedantic: YES 
Compiler for C++ supports arguments -Wdelete-non-virtual-dtor: YES 
Compiler for C++ supports arguments -Wlogical-op: YES 
Compiler for C++ supports arguments -Wduplicated-cond: YES 
Compiler for C++ supports arguments -Wduplicated-branches: YES 
Compiler for C++ supports arguments -Wno-overloaded-virtual: YES 
Compiler for C++ supports arguments -Wtautological-compare: YES 
Compiler for C++ supports arguments -Wextra-semi: YES 
Compiler for C++ supports arguments -Wno-inconsistent-missing-override: NO 
Compiler for C++ supports arguments -Wno-ignored-qualifiers: YES 
Compiler for C++ supports arguments -Wno-unused-parameter: YES 
Compiler for C++ supports arguments -Wno-cast-function-type: YES 
meson.build:21: WARNING: Consider using the built-in warning_level option instead of using "-Wall".
meson.build:21: WARNING: Consider using the built-in warning_level option instead of using "-Wextra".
wx-config found: NO need ['>=3.0.3']
Run-time dependency WxWidgets found: NO (tried config-tool)

meson.build:30:0: ERROR: Dependency "wxwidgets" not found, tried config-tool

A full log can be found at /home/branalba/.cache/yay/wxformbuilder/src/wxFormBuilder-3.10.1/_build/meson-logs/meson-log.txt
==> ERROR: A failure occurred in build().
    Aborting...
 -> error making: wxformbuilder

wx-config is on my PATH, I can run wx-config --version without problems and it gives 3.2.0.

From what @bkb says this seems to be part of a larger problem, just wanted to add what I experienced

bkb commented on 2022-07-17 11:14 (UTC)

All these wx things are basically broken. Some needs a newer version, some needs the old one. A long chain of dependency made it impossible to even switch from old to new or new to old, without uninstalling nearly the OS

dee42 commented on 2021-06-02 07:30 (UTC)

I needed to change the source URL to git+https://github.com... for this package to work.

GRAPHENE commented on 2021-02-28 13:37 (UTC)

Building failure

nickoe commented on 2020-07-12 23:48 (UTC) (edited on 2020-07-12 23:48 (UTC) by nickoe)

@antoniomx I get the same issue as bubla mentioned about the missing gendesk dependency.