Package Details: wxlua 3.0.0.9-2

Git Clone URL: https://aur.archlinux.org/wxlua.git (read-only, click to copy)
Package Base: wxlua
Description: Lua bindings for wxWidgets (Lua 5.3+ compatible fork)
Upstream URL: https://github.com/pkulchenko/wxlua
Licenses: custom:wxWindows
Submitter: farvardin
Maintainer: caleb
Last Packager: caleb
Votes: 24
Popularity: 0.000000
First Submitted: 2009-02-12 21:21
Last Updated: 2020-09-10 08:10

Pinned Comments

caleb commented on 2020-02-27 16:18

PSA: I've started hosting this as a prebuilt package in my repository for those that want to install it using pacman without messing around with building from the AUR.

caleb commented on 2020-02-11 09:24

If anyone needs Lua 5.2 or 5.1 support let me know and I think we could set this up to build packages for multiple Lua versions. Also if the 2.8 branch (upstream is pretty much abandonware) is really needed we could fork this repo at 11af6c0 and make a wxlua28 package out of it, but I couldn't see what the need would be.

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 Next › Last »

PyroDevil commented on 2014-03-04 15:37

I created a working PKGBUILD.
It now uses lua 5.2.

https://gist.github.com/anonymous/9348708

cl0ne commented on 2014-03-03 11:09

Dependency 'lua51' has to be replaced with 'lua'

hollunder commented on 2014-01-24 16:52

wxlua fails to build for: https://gist.github.com/anonymous/8601243
I still have a working wxlua 2.8.12.2-2 installed, so maybe it was the latest change that broke the build.

hollunder commented on 2014-01-22 21:02

The changelog also suggests that it should build with lua 5.2: http://wxlua.sourceforge.net/docs/changelog.txt

hollunder commented on 2014-01-22 20:59

Hmm... some messages on the mailinglist suggest that it should work: http://article.gmane.org/gmane.comp.lib.wxwidgets.wxlua.user/3530
Maybe the devs are not aware of the compile issue we face on Arch.

speps commented on 2014-01-22 12:18

@hollunder wxlua seems to be still not ready for wxgtk 3.0.0 (build failures). It depends on lua51 while most of the libraries are not already ported to 5.2, zerobrane studio depends on lua51 too.

hollunder commented on 2014-01-21 21:42

Can you modify this to build against wxgtk 3? This would fix some issues in ZBS and enable some features. Why does it depend on the old lua51 instead of lua (5.2)?

speps commented on 2014-01-20 23:15

Updated to 2.8.12.3-1
Now wxlua builds against wxgtk2.8 - @CalinLeafshade, thanks for reporting

CalinLeafshade commented on 2014-01-20 18:54

Will no longer build with wxgtk3.

Anonymous comment on 2013-07-29 18:30

I confirm that building fails with other than -j1. Please update.
Btw: thanks for maintaining this :)

For the time being you can edit PKGBUILD:

./configure --prefix=/usr
make -j1