Package Details: wxmedit 3.2-1

Git Clone URL: https://aur.archlinux.org/wxmedit.git (read-only, click to copy)
Package Base: wxmedit
Description: Cross-platform Text/Hex Editor, a fork of MadEdit with bug fixes and improvements
Upstream URL: https://wxmedit.github.io/
Licenses: GPL
Submitter: codestation
Maintainer: petronny
Last Packager: petronny
Votes: 14
Popularity: 0.003348
First Submitted: 2014-01-08 04:14 (UTC)
Last Updated: 2023-07-10 06:28 (UTC)

Latest Comments

1 2 3 Next › Last »

rcrath commented on 2021-04-12 23:46 (UTC)

oops, it is in community repo, not aur.

rcrath commented on 2021-04-12 23:45 (UTC)

used appimage install. there are three versions. the VinnyVynce one is the one that works for e in appimagge. Installed it via bauh, in the aur.

rcrath commented on 2021-03-05 03:29 (UTC)

tried applying the outstanding pull request from git but still wont build.

rcrath commented on 2021-02-11 04:27 (UTC)

gives error on wxgtk, won't build

rcrath commented on 2020-05-10 04:33 (UTC)

launch gives error: $ wxmedit wxmedit: error while loading shared libraries: libicui18n.so.65: cannot open shared object file: No such file or directory

Installing ICU 65 fixes it, but says it should work with ICU>4.3

slut commented on 2019-04-16 08:06 (UTC)

not currently building

khau commented on 2018-04-27 22:51 (UTC)

Failing to link with the latest libicu* (seeking v60 instead of v61).

wxmedit: error while loading shared libraries: libicui18n.so.60: cannot open shared object file: No such file or directory

kappa8086 commented on 2018-04-19 01:49 (UTC)

With new installed archlinux (4-18), makepkg produces errors when compiling, eg. ['UnicodeString' does not name a type; did you mean ‘Encoding’?] and some with "BreakIterator" declaration.

What to be done with ICU or something else?

potatoe commented on 2017-02-09 16:42 (UTC)

I don't think this package needs to depend on the 2.8 version of wxgtk any more, it builds and seems to work fine with the wxgtk 3.0.2-6 package from extra (after changing the PKGBUILD's deps and the ./configure options). The compilation problem from 2014 in the comments here seems to have been fixed in recent versions of the app (with an ifdef: https://github.com/hltj/wxMEdit/blob/3.1/src/wxmedit/wxmedit.cpp#L53 ), and the app's README explicitly mentions support for "wxWidgets 2.8/3.0".

petronny commented on 2016-05-15 16:27 (UTC)

* https://www.archlinux.org/todo/hooks-part-1/ "Each rebuild requires the install file updated to remove these commands." * https://wiki.archlinux.org/index.php/DeveloperWiki:Pacman_Hooks "Implemented update-desktop-database update-mime-database update-appstream-index install-info glib-compile-schemas gtk-update-icon-cache, xdg-icon-resource gconfpkg gio-querymodules gdk-pixbuf-query-loaders gtk-query-immodules-2.0 gtk-query-immodules-3.0"