Package Details: xdg-su 1.2.3-2

Git Clone URL: https://aur.archlinux.org/xdg-su.git (read-only, click to copy)
Package Base: xdg-su
Description: Run a program as root with the most environment appropriate available graphical authentication agent
Upstream URL: https://github.com/tarakbumba/xdg-su
Licenses: MIT
Submitter: tarakbumba
Maintainer: Ayceman
Last Packager: Ayceman
Votes: 117
Popularity: 0.72
First Submitted: 2011-03-08 19:59
Last Updated: 2020-06-21 21:25

Latest Comments

« First ‹ Previous 1 2 3 Next › Last »

tarakbumba commented on 2012-04-04 11:46

Uh!Oh! I shouldn't work with sleepy eyes. Sorry for that. I' ll update PKGBUILD tonight. Also, i will do a version bump to xdg-su; should remove scripts/xdg-su as sebcactus mentioned but have forgotten. Please, be patient

zeev commented on 2012-04-04 10:27

Same here.
xdg-su/PKGBUILD: line 16: cd: /home/nemo/xdg-su/src/xdg-su-1.2: No such file or directory

OrdinaryMagician commented on 2012-04-04 10:15

In build() and package(), the line where you change to the extracted archive directory should be changed from 'cd "${srcdir}/${pkgname}-${pkgver}"' to 'cd "${srcdir}/${pkgname}"'
I noticed it this morning when I downloaded the latest update.

tarakbumba commented on 2012-03-13 00:46

Thank you for feedback. I'm kind a busy nowadays but try to fix in a week. Btw, xdg-su script have been placed to use immediately, for lazies. :)

tarakbumba commented on 2012-03-13 00:45

Thank you for feedback. I'm kind a busy nowadays but try to fix in a week.

sebcactus commented on 2012-03-12 12:14

The validation error comes from the missing docbook-xsl dependency, adding it in the makedepends should fix it

sebcactus commented on 2012-03-12 11:30

So in short :)
Bug fix:
- add 'docbook-xsl' in the makedepends
- remove the scripts/xdg-su file in tar package (this should be created by the make process)
- add scripts in the "all" target of scripts/Makefile.in (all: scripts)

Feature wish:
- add urxvt in the supported TERMINAL in scripts/xdg-su.in :)

Thanks you!
Seb

sebcactus commented on 2012-03-12 11:26

The validation error comes from the missing docbook-xsl dependency, adding it in the makedepends should fix it

sebcactus commented on 2012-03-12 11:18

Forgot to mention that the problem is also in the git package

sebcactus commented on 2012-03-12 11:16

I think the ./configure and "make" line in Build() are not doing anything because the scripts/xdg-su file is already there.
If I remove the scripts/xdg-su, the building process does not work:
- first the all target of the Makefile is empty
- if by adding "scripts" in the all target, I get a validation issue with scripts/desc/xdg-su.xml

Would be nice to fix this :)
Also if you could add urxvt in the supported TERMINAL, it would be nice :)
Thanks!