Package Details: xf86-video-ati-git 1:19.1.0.r4.g38453924-1

Git Clone URL: https://aur.archlinux.org/xf86-video-ati-git.git (read-only, click to copy)
Package Base: xf86-video-ati-git
Description: X.org ati video driver
Upstream URL: https://xorg.freedesktop.org/
Keywords: amd ati driver git video xorg xserver
Licenses: custom
Conflicts: xf86-video-ati, xorg-server
Provides: xf86-video-ati
Submitter: vbmithr
Maintainer: yurikoles
Last Packager: yurikoles
Votes: 180
Popularity: 0.000000
First Submitted: 2008-02-25 18:44 (UTC)
Last Updated: 2020-07-06 13:31 (UTC)

Latest Comments

mkkot commented on 2018-07-22 10:55 (UTC)

I sent new PKGBUILD to package maintainers. It is also available here: https://pastebin.com/HRtj1M86

B4SH-B00STER commented on 2017-04-05 10:53 (UTC)

disowning package nvidia seems to be better :)

yurikoles commented on 2017-02-17 20:56 (UTC)

Why its conflicts with xorg-server?

B4SH-B00STER commented on 2016-11-23 12:33 (UTC) (edited on 2016-11-23 12:38 (UTC) by B4SH-B00STER)

build in clean chroot http://pastebin.com/raw/9RgePUH7

keminar commented on 2016-11-22 14:16 (UTC)

==> Starting build()... autoreconf: Entering directory `.' autoreconf: configure.ac: not using Gettext autoreconf: running: aclocal main::scan_file() called too early to check prototype at /usr/local/bin/aclocal line 618. configure.ac:40: error: must install xorg-macros 1.8 or later before running autoconf/autogen configure.ac:40: the top level autom4te: /usr/bin/m4 failed with exit status: 1 aclocal: /usr/bin/autom4te failed with exit status: 1 autoreconf: aclocal failed with exit status: 1 ==> ERROR: A failure occurred in build().

B4SH-B00STER commented on 2016-11-17 17:27 (UTC)

updated enjoy :)

EndlessEden commented on 2016-05-03 21:38 (UTC)

looks abandoned. its been tagged and i brought up the issue a few times. the maintainer deletes my comments and ignore it.

ciupenhauer commented on 2016-04-13 21:29 (UTC)

Is anyone still maintaining this?

cpatrick08 commented on 2015-09-07 21:46 (UTC)

wont build if xorg-server-git is installed

MRLemux commented on 2015-02-10 16:29 (UTC)

Updated it, should now work again.

MRLemux commented on 2014-11-01 11:34 (UTC)

This should depend on xorg-server-git as the radeon driver is made with the X git tree in mind.

Dasonk commented on 2014-10-06 00:01 (UTC)

You should add git as a make dependency

tomkwok commented on 2014-09-27 04:42 (UTC)

Updated. I'm sorry for the delay.

confusedfla commented on 2014-09-24 10:55 (UTC)

@tomkwok: Do you have time/interest in maintaining this package? This package doesn't work without the fix provided by @kerberizer and with > 200 votes people are/will encounter this ;-)

kerberizer commented on 2014-08-08 02:10 (UTC)

The following seems to work with the new Xorg 1.16... -depends=('libdrm>=2.4.41' 'systemd' 'ati-dri' 'glamor-egl') -makedepends=('xorg-server-devel' 'X-ABI-VIDEODRV_VERSION=15') -conflicts=('xorg-server<1.15.0' 'X-ABI-VIDEODRV_VERSION<15' 'X-ABI-VIDEODRV_VERSION>=16' 'xf86-video-ati') +depends=('libdrm>=2.4.41' 'systemd' 'ati-dri') +makedepends=('xorg-server-devel' 'X-ABI-VIDEODRV_VERSION=18') +conflicts=('xorg-server<1.16.0' 'X-ABI-VIDEODRV_VERSION<18' 'X-ABI-VIDEODRV_VERSION>=19' 'xf86-video-ati')

kerberizer commented on 2014-07-11 09:55 (UTC)

May I suggest adding the following pkgver function to the PKGBUILD... pkgver() { cd "${srcdir}/xf86-video-ati" echo $(git describe --long | sed -r 's/^xf86-video-ati-//;s/([^-]*-g)/r\1/;s/-/./g') } The package version would then be something like "7.4.0.r2.gc4ae0e2-1", which would help to keep better track on what exactly code the package was built from.

commented on 2014-03-02 12:11 (UTC)

I have updated the package to @zman0900's pkgbuild, I no longer use this package and don't have the time to maintain it, so I'm disowning.

zman0900 commented on 2014-03-02 11:09 (UTC)

Flagged out of date sine the --enable-dri flag isn't valid anymore. Here's an updated pkgbuild: https://gist.github.com/zman0900/9304936 I updated it to match what is in the repos and use the built in way of handling git.

younishd commented on 2014-02-07 20:08 (UTC)

@tapir, Same here. Did you fix it somehow? https://bbs.archlinux.org/viewtopic.php?id=176426 (related?)

tapir commented on 2014-01-01 16:55 (UTC)

X11 hangs on start without any errors on log file: http://paste2.org/a5sAHvzK xf86-video-ati works OK.

Nowaker commented on 2013-09-24 16:00 (UTC)

I marked it but Dr.Egg is right, glamor is enabled by default so there is no need for any changes. Mark as up-to-date please.

commented on 2013-09-22 18:43 (UTC)

Hello, I am considering becoming maintainer for this package. I've not maintained any video drivers before. I am wondering why this package was flagged and what needs to be done? Thanks,

rwhite226 commented on 2013-09-19 16:40 (UTC)

Glamor is now enabled by default in master branch http://cgit.freedesktop.org/xorg/driver/xf86-video-ati/commit/?id=282587cd0709850e7bacb1d8307065d95dc2c97d so there is no need to enable it.

Nowaker commented on 2013-09-18 13:06 (UTC)

xf86-video-ati in [extra] already enables glamor. I believe this package should do this as well. https://projects.archlinux.org/svntogit/packages.git/tree/trunk/PKGBUILD?h=packages/xf86-video-ati

RcrdBrt commented on 2012-11-11 09:30 (UTC)

updated!

commented on 2012-11-10 20:40 (UTC)

It seems that scrnsaverproto is also needed for this to build. Without it, I got "fatal error: x11/extensions/saver.h: no such file or directory" during compilation.

RcrdBrt commented on 2012-10-17 14:22 (UTC)

updated with the resourceproto make dep thanks to agapito

agapito commented on 2012-10-17 13:54 (UTC)

I couldn't compile without "resourceproto" package.

derJupp commented on 2012-10-15 19:40 (UTC)

After update with pacman ati-dri 9.0-1 the xf86-video-ati-git driver not works ! I cant get new install Errors: In file included from /usr/include/xorg/globals.h:8:0, from /usr/include/xorg/opaque.h:34, from /usr/include/xorg/xf86_OSproc.h:127, from ati.h:32, from ati.c:65: /usr/include/xorg/extinit.h:107:38: fatal error: X11/extensions/XResproto.h: No such file or directory compilation terminated. Now i get the catalyst-test driver for my Radeon HD 7770 , sorry for my bad englisch

commented on 2012-10-11 06:33 (UTC)

after an update with the official driver my RV250 RADEON encounters bugs. With this package it's ok. Thanks for it ;) Après une mise à jour avec le driver officiel, ma carte RV250 RADEON a fait bugguer l'affichage. Avec ce driver c'est nickel ;) Merci

RcrdBrt commented on 2012-09-26 15:41 (UTC)

updated the PKGBUILD with clark correction thanks clark3934

commented on 2012-09-25 01:41 (UTC)

ovonuk: This is because the PKGBUILD does't cd into the directory containing the git repo. Add cd "${_gitname}" after line 31, so it looks like: if [[ -d "${srcdir}/${_gitname}" ]] ; then cd "${_gitname}" git pull origin msg "The local files are updated..." else git clone "${_gitroot}" cd "${_gitname}" fi

commented on 2012-09-17 17:58 (UTC)

Hello, I am getting the following error: Klone nach 'xf86-video-ati'... remote: Counting objects: 18269, done. remote: Compressing objects: 100% (6245/6245), done. remote: Total 18269 (delta 14478), reused 15104 (delta 12020) Empfange Objekte: 100% (18269/18269), 4.90 MiB | 383 KiB/s, done. Löse Unterschiede auf: 100% (14478/14478), done. fatal: Not a git repository (or any parent up to mount point /tmp) Stopping at filesystem boundary (GIT_DISCOVERY_ACROSS_FILESYSTEM not set).

RcrdBrt commented on 2012-09-07 09:15 (UTC)

haagch you're right! I did a mistake in the script since this is the upstream version I thought it's necessary to test it with a new xorg version and I did a typo.. sorry, updated the PKGBUILD

haagch commented on 2012-09-07 09:03 (UTC)

conflicts=('xorg-server>1.11.0' oO

donpicoro commented on 2012-04-19 00:29 (UTC)

Nevermind, my bad.

donpicoro commented on 2012-04-19 00:10 (UTC)

Hello, I am getting the following error: Cloning into 'xf86-video-ati'... fatal: http://anongit.freedesktop.org/xorg/driver/xf86-video-ati/info/refs not found: did you run git update-server-info on the server? Is it a problem with the package itself or should I do something about it? Thanks in advance.

kfgz commented on 2011-08-13 09:58 (UTC)

OK. Fixed.

commented on 2011-08-11 18:34 (UTC)

radeon.h:76:23: fatal error: GL/glxint.h: No such file or directory You really have to add glproto as dependency.

kfgz commented on 2011-08-08 18:08 (UTC)

Why should I do it? xf86-video-ati in [extra] doesn't have glproto as dependency.

burntsushi commented on 2011-08-08 02:47 (UTC)

Please add 'glproto' as a dependency.

commented on 2010-10-10 23:20 (UTC)

[Bug 30451] http://www.mail-archive.com/xorg-driver-ati@lists.x.org/msg15952.html If you get error: "ATI driver: module ABI major version (8) doesn't match the server's version (9)", you need to rebuild that driver; If you get error: ‘struct _ScrnInfoRec’ has no member named ‘pixmapPrivate’ see for patch http://www.mail-archive.com/xorg-driver-ati@lists.x.org/msg15965.html

commented on 2010-10-07 20:58 (UTC)

Actually, it doesn't compile without this patch (https://bugs.freedesktop.org/show_bug.cgi?id=30451).

jiuren commented on 2010-09-29 10:57 (UTC)

it works fine with xorg-server 1.8.1 for me too. btw, i use the whole tool chain of git version including ati-dri-git/mesa-git and so on.

commented on 2010-09-23 02:47 (UTC)

For what its worth this works fine for me without xorg-server-devel

Perry3D commented on 2010-09-08 19:47 (UTC)

Why is this package limited to the testing repo? Is there no configuration to build it against extra and testing?

commented on 2010-09-08 19:24 (UTC)

Yes, I did install the stuff from [testing], coz I already had ran into mouse/keyboard issues (man, I'm hating this). If not for the stupid KDE 4.5.1, I wouldn't be here wasting 2 hours figuring out gallium dependencies :(

flamelab commented on 2010-09-08 19:07 (UTC)

Not only that, if you install just some packages from [testing], you may have a problem. You should fully upgrade into [testing]. xf86-video-ati-git can be built with the current [extra] xorg-server, just an edit in PKGBUILD. But I propose you to use the testing graphics' packages.

commented on 2010-09-08 18:58 (UTC)

I understand, you want us to install xorg-server-devel from the testing repo, ok.

flamelab commented on 2010-09-08 18:54 (UTC)

Please read my comments below.

commented on 2010-09-08 17:04 (UTC)

makedepends=('xorg-server-devel' ... etc As far as I see this package is now called 'xorg-server-dev' on AUR. Should this be fixed?

intgr commented on 2010-08-30 21:54 (UTC)

D'oh, I think I was missing xorg-server-devel (not sure how I managed to run makepkg without it before; did you update the PKGBUILD?). In any case, it works now.

flamelab commented on 2010-08-30 21:40 (UTC)

Upstream problem, wait for a fix.

intgr commented on 2010-08-30 21:39 (UTC)

./configure fails with: [...] checking whether to build shared libraries... yes checking whether to build static libraries... no checking whether gcc -std=gnu99 and cc understand -c and -o together... yes ./configure: line 11733: syntax error near unexpected token `RANDR,' ./configure: line 11733: `XORG_DRIVER_CHECK_EXT(RANDR, randrproto)'

flamelab commented on 2010-08-26 17:07 (UTC)

It's in testing. Using xf86-video-ati without testing, isn't proposed. If you do want to test it without the [testing] repo, replace xorg-server-devel with xorg-server in the PKGBUILD

rp9 commented on 2010-08-26 16:30 (UTC)

xorg-server-devel isn't in AUR anymore?

flamelab commented on 2010-08-25 11:16 (UTC)

... And also made a few fixes in the PKGBUILD.

flamelab commented on 2010-08-25 11:03 (UTC)

PKGBUILD updated with updated makedeps/deps

flamelab commented on 2010-08-24 21:18 (UTC)

Thank you for the comment, I'm planning to update it as soon as possible.

commented on 2010-08-24 20:36 (UTC)

This package now has a build dependency on xorg-server-devel which provides /usr/share/aclocal/xorg-server.m4

commented on 2010-07-11 09:09 (UTC)

@ rahman If you're using autoconf 2.66 from testing, try to downgrade to the one in [core] (version 2.65).

commented on 2010-07-11 08:00 (UTC)

I get this When I do a "makepkg"; ==> Starting configure... autoreconf: Entering directory `.' autoreconf: configure.ac: not using Gettext autoreconf: running: aclocal configure.ac:24: warning: AC_INIT: not a literal: https://bugs.freedesktop.org/enter_bug.cgi?product=xorg autoreconf: configure.ac: tracing configure.ac:24: warning: AC_INIT: not a literal: https://bugs.freedesktop.org/enter_bug.cgi?product=xorg autoreconf: running: libtoolize --copy libtoolize: putting auxiliary files in AC_CONFIG_AUX_DIR, `.'. libtoolize: copying file `./ltmain.sh' libtoolize: Consider adding `AC_CONFIG_MACRO_DIR([m4])' to configure.ac and libtoolize: rerunning libtoolize, to keep the correct libtool macros in-tree. libtoolize: Consider adding `-I m4' to ACLOCAL_AMFLAGS in Makefile.am. configure.ac:24: warning: AC_INIT: not a literal: https://bugs.freedesktop.org/enter_bug.cgi?product=xorg autoreconf: running: /usr/bin/autoconf configure.ac:24: warning: AC_INIT: not a literal: https://bugs.freedesktop.org/enter_bug.cgi?product=xorg configure:12366: error: possibly undefined macro: AS_MESSAGE_LOG_FDdnl If this token and others are legitimate, please use m4_pattern_allow. See the Autoconf documentation. autoreconf: /usr/bin/autoconf failed with exit status: 1

JokerBoy commented on 2010-07-04 07:50 (UTC)

depends=('xorg-server>=1.8.0' 'libdrm>=2.4.20' 'libpciaccess' 'ati-dri>=7.8.1' 'pixman>=0.18.0') conflicts=('xf86-video-ati') is better.

commented on 2010-07-03 18:34 (UTC)

$ pacman -Sgl base-devel base-devel autoconf base-devel automake ... Packages in base-devel should NOT be added as makedeps, base-devel has been created for this reason. If you want to build something on arch, first you have to install base-devel.

commented on 2010-07-03 18:32 (UTC)

$ pacman -Sgl base-devel base-devel autoconf base-devel automake ... Packages in base-devel should NOT be added as makedeps, base-devel as been created for this reason. If you want to build something on arch, first you have to install base-devel.

xangelux commented on 2010-07-01 17:25 (UTC)

Add dependencies autoconf and automake

flamelab commented on 2010-06-22 22:11 (UTC)

-> Updated deps/makedeps after xorg-server 1.8/mesa 7.8 passed to extra

flamelab commented on 2010-04-05 20:13 (UTC)

6.13 is out, 6.14 is baking.