Package Details: xmonad-git v0.13.r5.g2e63127-2

Git Clone URL: https://aur.archlinux.org/xmonad-git.git (read-only)
Package Base: xmonad-git
Description: Lightweight X11 tiled window manager written in Haskell
Upstream URL: http://xmonad.org/
Licenses: BSD
Conflicts: xmonad
Provides: xmonad
Submitter: Mr.Elendig
Maintainer: None
Last Packager: Mr.Elendig
Votes: 2
Popularity: 0.007623
First Submitted: 2015-09-12 18:58
Last Updated: 2017-06-21 10:16

Latest Comments

Mr.Elendig commented on 2017-03-30 08:05

Check LDFLAGS in your makepkg.conf, the one shipped by arch does not have -pie.

misc commented on 2017-03-29 16:16

Getting
/usr/bin/ld: -r and -pie may not be used together
since two or three weeks.

Probably an Arch bug or GHC shortcoming, though.

de-vries commented on 2017-02-19 16:15

Shouldn't git be a makedepend? Currently building in a clean chroot fails because git is not automatically installed.

Thanks for providing the PKGBUILD, btw :)

anpieber commented on 2017-02-17 08:16

I get the following error: :: xmonad-git: installing haskell-x11 (1.8-1) breaks dependency 'haskell-x11<1.8'

Mr.Elendig commented on 2016-12-31 11:47

I'm not going to bother, it is trivial to just update the PKGBUILD for haskell-x11(-xft), and hopefully there is a new xmonad release soon™ so that haskell-x11 in the repos can get bumped anyway. But feel free to make haskell-x11-git if you like. Would require users to rebuild haskell-x11-xft too btw.

mazinght commented on 2016-12-28 13:08

Thanks! I think having the dependency wrong for a few days for the sake of spending time with family is completely understandable :)
Should we make a haskell-x11-git package, perhaps, to avoid this situation?

Mr.Elendig commented on 2016-12-28 11:59

Nothing I can do about haskell-x11 being too old in [community]. You can bump it yourself if you are not using anything that depends on <= 1.6. Was going to update the dep in the PKGBUILD earlier but then I got invaded by family. Stupid holidays.

mazinght commented on 2016-12-27 12:37

I am getting
Encountered missing dependencies: X11 == 1.7.*

Also, after getting this error, I have to manually remove xmonad.desktop to be able to try (and fail) to install this package again.

haskell-x11 has been flagged out of date a few days ago.