Package Details: xnviewmp 0.96.4-1

Git Clone URL: https://aur.archlinux.org/xnviewmp.git (read-only, click to copy)
Package Base: xnviewmp
Description: An efficient multimedia viewer, browser and converter.
Upstream URL: http://www.xnview.com/en/xnviewmp/
Keywords: graphics
Licenses: custom
Submitter: oliwer
Maintainer: Corax
Last Packager: Corax
Votes: 269
Popularity: 0.84
First Submitted: 2008-07-25 19:01
Last Updated: 2020-07-01 21:36

Pinned Comments

Corax commented on 2017-01-21 15:34

I have created a new package: xnviewmp-system-libs. This is exactly the same build, except that the bundled Qt/icu libs are removed. Please try it if you want to use XnView without the bundled libs, and discuss any issue related to this configuration here: https://aur.archlinux.org/packages/xnviewmp-system-libs/. Do keep in mind that this is an experimental package though, and things may break when I try to fix other things...

Corax commented on 2017-01-20 21:49

If makepkg fails because the checksum is incorrect, please flag the package out-of-date and I will update the PKGBUILD.

Upstream does not version the released archives and does not announce new releases either, so the checksum is bound to become wrong every time there is a new release, and there's nothing I can do about that.

Latest Comments

« First ‹ Previous ... 8 9 10 11 12 13 14 15 16 17 18 ... Next › Last »

tastyminerals commented on 2015-10-10 19:30

first segmentation fault, then after I replaced the binary using the link from @baldr I get: xnviewmp: error while loading shared libraries: libQt5MultimediaWidgets.so.5: cannot open shared object file: No such file or directory

vinibali commented on 2015-10-09 18:58

please add the libxslt as dependency.

allencch commented on 2015-10-03 13:16

@baldr, Thank you. That works.

baldr1 commented on 2015-10-02 18:30

please consider this link:
http://newsgroup.xnview.com/viewtopic.php?f=82&t=32190&sid=ef8200677c42d5040fafa32a6064e2a3

baldr1 commented on 2015-10-02 18:28

please consider this link:
http://newsgroup.xnview.com/viewtopic.php?f=82&t=31108&sid=ef8200677c42d5040fafa32a6064e2a3

jooch commented on 2015-09-29 14:08

Same problem on x86-64:

XNVIEW restoreGeometry before : 640 480
/usr/bin/xnviewmp: regel 5: 7318 Segmentatiefout (geheugendump gemaakt) "$dirname"/XnView "$@"

Running the binary directly gives the following error:

./XnView
This application failed to start because it could not find or load the Qt platform plugin "xcb".

AFAIK i have all the xcb plugins installed, guess it must be a wrong setup somewhere?

jooch commented on 2015-09-29 13:40

Same problem on x86-64:

XNVIEW restoreGeometry before : 640 480
/usr/bin/xnviewmp: regel 5: 7318 Segmentatiefout (geheugendump gemaakt) "$dirname"/XnView "$@"

Forvord commented on 2015-09-29 07:36

Arch I686:
/usr/bin/xnviewmp: line 5: 14517 Segmentation fault

allencch commented on 2015-09-29 01:20

I don't have "xcb" error. But
Fontconfig error: line 51779151: syntax error
Fontconfig error: Cannot load default config file
XNVIEW restoreGeometry before : 640 480
/usr/bin/xnviewmp: line 5: 16776 Segmentation fault (core dumped) "$dirname"/XnView "$@"

cdown commented on 2015-09-24 00:16

Disowning: I don't use this software much any more (I only brought it to AUR4), and it seems the dependencies are getting pretty complicated without much documentation.