Package Details: xonsh-git 0.6.7.r12.g9b48934b-1

Git Clone URL: https://aur.archlinux.org/xonsh-git.git (read-only)
Package Base: xonsh-git
Description: A Python-ish, BASHwards-compatible shell
Upstream URL: http://github.com/scopatz/xonsh
Keywords: python shell system
Licenses: FreeBSD
Conflicts: xonsh
Submitter: None
Maintainer: dundee
Last Packager: dundee
Votes: 4
Popularity: 0.002282
First Submitted: 2015-07-30 17:26
Last Updated: 2018-06-22 09:49

Dependencies (4)

  • python
  • python-ply
  • python-setuptools (make)
  • python-prompt_toolkit (optional) – support for SHELL_TYPE=prompt_toolkit

Required by (0)

Sources (1)

Latest Comments

dundee commented on 2019-02-20 11:00

Granitosaurus: Looks like your problem only (maybe with pycache?). Try to reinstall python-prompt_toolkit.

Does this work for you?

python -c "import prompt_toolkit"

Granitosaurus commented on 2019-02-20 05:07

This constantly breaks with prompt_toolkit:

ImportError: cannot import name 'to_cli_filter' from 'prompt_toolkit.filters' (/usr/lib/python3.7/site-packages/prompt_toolkit/filters/init.py) Xonsh encountered an issue during launch

sh-5.0$ yay -Q python-prompt_toolkit python-prompt_toolkit 2.0.8-1

Am I misisng something?

dundee commented on 2017-09-05 10:37

midgard: Fixed, thanks!

midgard commented on 2017-09-04 10:40

Hi dundee, in PKGBUILD you should quote variables that may contain spaces, in particular "$pkgdir" on line 26. In the non-git package as well.

dundee commented on 2015-11-08 20:25

Fixed by patch and reported upstream - https://github.com/scopatz/xonsh/pull/480

Thanks!

kseistrup commented on 2015-11-07 12:38

This package doesn't build well after the arrival of the Jupyter kernel patch.

Anonymous comment on 2015-08-30 13:46

I've recently moved to Gentoo full-time, so I'm disowning all my packages. Farewell!

Anonymous comment on 2015-07-30 17:33

Git version