Package Details: xst-git 20160407.74c6832-1

Git Clone URL: https://aur.archlinux.org/xst-git.git (read-only)
Package Base: xst-git
Description: st fork
Upstream URL: https://github.com/neeasade/xst
Licenses: MIT
Conflicts: st, xst
Provides: xst
Submitter: neeasade
Maintainer: neeasade
Last Packager: neeasade
Votes: 7
Popularity: 0.935960
First Submitted: 2016-04-29 05:01
Last Updated: 2016-05-02 01:16

Dependencies (4)

Required by (0)

Sources (1)

Latest Comments

Girafferson commented on 2017-04-16 06:42

Even if I delete the st and st-256color files it still won't let me install this..

buttcake commented on 2017-04-10 14:53

>unsable
Sorry for unintelligible, I was reffering to the curses frontend for gpg-agent.

parchd commented on 2017-04-10 09:39

I guess that is why we should never use --force...

If this package tries to install files that already exist, something is wrong somewhere. Manually removing files shouldn't be necessary. If what ncurses provides is correct, this package shouldn't do anything to them - it already depends on ncurses, afterall. If ncurses provides a different version, the question gets more complicated.

buttcake commented on 2017-04-10 09:26

Make a backup of those files first. I --force installed xst-git, ncurses gpg-agent stopped working and after I switched to st, st-git it was unsable.

neeasade commented on 2016-07-08 22:35

yepp, just remove those files(they will be reinstalled with this package). this was due to a recent change in the Makefile, which now respects $DESTDIR with respect to terminfo files. sorry about that.

ref: https://github.com/neeasade/xst/pull/1

blueyed commented on 2016-07-08 21:39

Get a conflict with "ncurses" when trying to install it:

> error: failed to commit transaction (conflicting files)
> xst-git: /usr/share/terminfo/s/st exists in filesystem
> xst-git: /usr/share/terminfo/s/st-256color exists in filesystem

neeasade commented on 2016-04-29 05:01

This project name changed. The package is now xst-git.