Package Details: yay 9.2.0-1

Git Clone URL: https://aur.archlinux.org/yay.git (read-only)
Package Base: yay
Description: Yet another yogurt. Pacman wrapper and AUR helper written in go.
Upstream URL: https://github.com/Jguer/yay
Keywords: arm AUR go helper pacman wrapper x86
Licenses: GPL
Submitter: jguer
Maintainer: jguer
Last Packager: jguer
Votes: 621
Popularity: 81.510467
First Submitted: 2016-10-05 17:20
Last Updated: 2019-04-06 13:09

Required by (6)

Sources (1)

Pinned Comments

jguer commented on 2019-04-16 14:08

I cannot delete the spam comments appearing regularly in this page, which has also led me to disable notifications from here. I remind that the best way to receive support or report a problem is through the Upstream URL.

Latest Comments

1 2 3 4 5 6 ... Next › Last »

jguer commented on 2019-04-16 14:08

I cannot delete the spam comments appearing regularly in this page, which has also led me to disable notifications from here. I remind that the best way to receive support or report a problem is through the Upstream URL.

Chrissss commented on 2019-04-16 13:35

Can someone delete the last two comments? Looks like spam...

johnnybash commented on 2019-02-20 05:58

@adomol yay -Sc deletes everything you wont need anymore.

adomol commented on 2019-02-18 19:10

Hello... what is the proper way to clear the Yay cache?

Thanks.

Morganamilo commented on 2019-01-13 18:40

My guess is on https://github.com/Jguer/yay/issues/812

yay --bottomup --save should correct it.

jguer commented on 2019-01-13 18:35

==> Packages to NOT upgrade: (eg: 1 2 3, 1-3, ^4 or repo name)

Don't see anything wrong there

Thermi commented on 2019-01-13 17:37

Hi, I think the numbers in the "Packages to upgrade" menu aren't right. See the following.

:: 2 Packages to upgrade.
2  aur/python-cli_helpers  1.0.2-1 -> 1.1.0-1
1  aur/qemu-user-static    3.1-2   -> 3.1.0-1
==> Packages to not upgrade: (eg: 1 2 3, 1-3, ^4 or repo name)
==> 1
:: Checking for conflicts...
:: Checking for inner conflicts...
[Aur: 1]  python-cli_helpers-1.1.0-1

  1 python-cli_helpers               (Installed) (Build Files Exist)
==> Packages to cleanBuild?
==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
==> 

Nyutag commented on 2019-01-05 17:00

@hringriin. I was having the same issue. Also freshly installed ArchLinux 32bit.

Solved by using another repo from https://git.archlinux32.org/archlinux32/packages/raw/branch/master/core/pacman-mirrorlist/mirrorlist and pacman -Syyu

I get the last go package and successfully install yay.

hringriin commented on 2019-01-03 23:03

>$ makepkg
[...]
go build -v -ldflags '-s -w -X main.version=9.0.1' -o yay -mod=vendor
flag provided but not defined: -mod
make: *** [Makefile:51: build] Error 2

This is the output of makepkg on A freshly installed Arch Linux 32 bit.

I could see, that my version of the go package is 2:1.10.3-1.1 whereas the latest go version is 2:1.11.4-1, but, as of yet only for 64 bit architectures.

Is this due to my older version of go or am I missing something else?

Morganamilo commented on 2018-12-28 17:01

By default sudo will cache your password for 5 minutes.