Package Details: yay-bin 11.2.0-1

Git Clone URL: https://aur.archlinux.org/yay-bin.git (read-only, click to copy)
Package Base: yay-bin
Description: Yet another yogurt. Pacman wrapper and AUR helper written in go. Pre-compiled.
Upstream URL: https://github.com/Jguer/yay
Keywords: AUR go helper pacman wrapper
Licenses: GPL3
Conflicts: yay
Provides: yay
Submitter: jguer
Maintainer: jguer
Last Packager: jguer
Votes: 215
Popularity: 2.31
First Submitted: 2016-12-03 15:06 (UTC)
Last Updated: 2022-06-17 08:28 (UTC)

Required by (24)

Sources (4)

Pinned Comments

jguer commented on 2021-05-20 11:48 (UTC) (edited on 2021-06-04 16:36 (UTC) by jguer)

With pacman 6 arriving a rebuild of yay will be necessary, if you upgrade pacman without upgrading yay at the same time, yay will not run after.

It will take a bit to release the yay-bin binaries compiled with pacman 6 support

Once they're released (and if you installed pacman 6 before)

# pacman -S --needed git base-devel
$ git clone https://aur.archlinux.org/yay-bin.git
# pacman -R yay-bin
$ cd yay-bin
$ makepkg -si

Latest Comments

bbaster commented on 2022-06-20 16:24 (UTC)

Anyone else getting this error while trying to upgrade this package?

-> error fetching yay-bin: fatal: not a git repository (or any of the parent directories): .git 
         context: exit status 128

tech commented on 2021-12-06 21:54 (UTC)

It seems redundent to strip a binary that is already stripped in upstream. Unless this goes against the AUR submition guidelines for binary packages, why not remove this from the build? This patch works for me.

diff --git a/PKGBUILD b/PKGBUILD
index 06df7aa..7281848 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,6 +14,7 @@ optdepends=(
 )
 provides=('yay')
 conflicts=('yay' 'libalpm.so<13')
+options=('!strip')

 source_x86_64=("https://github.com/Jguer/yay/releases/download/v${pkgver}/${pkgname/-bin/}_${pkgver}_x86_64.tar.gz")
 source_aarch64=("https://github.com/Jguer/yay/releases/download/v${pkgver}/${pkgname/-bin/}_${pkgver}_aarch64.tar.gz")

Alterego commented on 2021-06-04 12:22 (UTC)

Oh yes i forgot to do that, thanks

kuluse commented on 2021-06-04 07:55 (UTC)

Alterego, I just reinstalled yay-bin following the pinned comment and there is no conflict anymore. Maybe you have another error

bulletmark commented on 2021-06-03 23:36 (UTC) (edited on 2021-06-03 23:41 (UTC) by bulletmark)

I've been using yay-bin on my Arch and Arch ARM boxes for ages. All of these have updated to pacman 6 and I have updated yay-bin to work on the Arch boxes but it fails to install on my Arch ARM boxes because of error yay-bin and pacman are in conflict (libalpm.so<13-64). On my Arch boxes, pacman 6 provides libalpm.so=13-64 but on Arch ARM pacman 6 provides libalpm.so=13-32. Changing the PKGBUILD to conflicts=('yay' 'libalpm.so<13') fixes this.

Alterego commented on 2021-06-03 23:29 (UTC)

Still conflicting after latest release

hexhu commented on 2021-06-01 03:15 (UTC)

pacman 6.0.0-2 conflicts with yay-bin

==> Installing package yay-bin with pacman -U...
loading packages...
resolving dependencies...
looking for conflicting packages...
:: yay-bin and pacman are in conflict (libalpm.so). Remove pacman? [y/N] n
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: yay-bin and pacman are in conflict (libalpm.so>12-64)
==> WARNING: Failed to install built package(s).

jguer commented on 2021-05-20 11:48 (UTC) (edited on 2021-06-04 16:36 (UTC) by jguer)

With pacman 6 arriving a rebuild of yay will be necessary, if you upgrade pacman without upgrading yay at the same time, yay will not run after.

It will take a bit to release the yay-bin binaries compiled with pacman 6 support

Once they're released (and if you installed pacman 6 before)

# pacman -S --needed git base-devel
$ git clone https://aur.archlinux.org/yay-bin.git
# pacman -R yay-bin
$ cd yay-bin
$ makepkg -si

jpegxguy commented on 2021-01-11 21:36 (UTC)

If v10.1.2 supports pacman > 6, why the < 6 check in the depends array?

jguer commented on 2020-12-15 08:41 (UTC)

@maverick1 yay is built with versioned bindings meaning it requires a recompile when libalpm is updated. Right now building yay with -tags six will use the pacman6 bindings. This yay-bin was compiled without -tags six so will only be compatible with pacman5, once pacman6 is released I'll update yay-bin to build using -tags six by default

maverick1 commented on 2020-12-15 05:35 (UTC)

I am wondering why pacman<6 is being added now. It should have been added for previous builds but not this one according to the changelog.

SleeplessSloth commented on 2020-12-14 23:59 (UTC)

Why does v10.1.2 require pacman<6 when in the changelog it clearly says support for >6 was added instead? Shouldn't it be just depends=('pacman'...)?

jguer commented on 2020-02-29 16:56 (UTC)

v9.4.5 binary version is delayed until multiarchitecture builds get fixed

rEnr3n commented on 2020-01-19 08:09 (UTC)

@tee Users are expected to have base-devel installed when using aur. https://wiki.archlinux.org/index.php/Arch_User_Repository#Getting_started

tee commented on 2020-01-19 07:35 (UTC)

==> Validating source_x86_64 files with sha1sums...
    yay_9.4.4_x86_64.tar.gz ... Passed
==> Removing existing $srcdir/ directory...
==> Extracting sources...
  -> Extracting yay_9.4.4_x86_64.tar.gz with bsdtar
==> Sources are ready.
==> ERROR: Cannot find the fakeroot binary.
Error making: yay-bin

Also depends on fakeroot

tee commented on 2020-01-19 07:31 (UTC) (edited on 2020-01-19 07:31 (UTC) by tee)

$ ./yay -S yay-bin
:: Checking for conflicts...
:: Checking for inner conflicts...
[Aur: 1]  yay-bin-9.4.4-1

:: Downloaded PKGBUILD (1/1): yay-bin
  1 yay-bin                                  (Build Files Exist)
==> Diffs to show?
==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
==> 
:: Parsing SRCINFO (1/1): yay-bin
==> ERROR: Cannot find the strip binary required for object file stripping.
Error downloading sources: yay-bin

yay-bin depends on binutils which provides strip

jguer commented on 2019-10-24 02:05 (UTC)

ARM packages have been readded now that pacman 5.2 has reached core in archlinux arm

jguer commented on 2019-10-23 08:16 (UTC)

Yes, I just saw this and this is something that may require manual action. yay 9.3.3 is preventing you from installing it because it breaks current deps, I'll be looking at the easiest upgrade path.

Archlinux ARM still doesn't have pacman 5.2 in its repositories, once it's added I'll add arm back to the PKGBUILD

bjo commented on 2019-10-23 08:13 (UTC)

No support for armv7h any more?

cwrau commented on 2019-10-23 08:11 (UTC)

Removing the dependency helped, kinda

Now I could install yay-bin, but without the dependency to pacman>5.2 I couldn't run yay again, I had to manually pacman -S pacman

cwrau commented on 2019-10-23 07:59 (UTC)

I cannot update this package, it errors with the following message:

λ yay -S yay-bin
:: Checking for conflicts...
:: Checking for inner conflicts...
[Repo: 1]  pacman-5.2.0-2
[Aur: 1]  yay-bin-9.4.0-1

  1 yay-bin                                  (Installed) (Build Files Exist)
==> Packages to cleanBuild?
==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
==> 
:: PKGBUILD up to date, Skipping (1/1): yay-bin
  1 yay-bin                                  (Installed) (Build Files Exist)
==> Diffs to show?
==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
==> 
:: Parsing SRCINFO (1/1): yay-bin
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing pacman (5.2.0-2) breaks dependency 'pacman<=5.1.3' required by yay-bin
Error installing repo packages

jguer commented on 2019-06-21 12:16 (UTC)

That's true, should be all good now

bjo commented on 2019-06-21 10:02 (UTC)

You'll have to update the PKGBUILD because the sha1sum doesn't fit any more

jguer commented on 2019-06-21 09:49 (UTC)

I've renamed the directory inside of the tarball manually so it should be fixed, I won't be updating the PKGBUILD but the build process to fix this

LChris314 commented on 2019-06-20 14:23 (UTC) (edited on 2019-06-20 14:24 (UTC) by LChris314)

On an armv7h machine it fails to build with the following error:

install: cannot stat '/home/alarm/.cache/yay/yay-bin/src/yay_9.2.1_armv7h/yay': No such file or directory

This is because yay_x.y.z_armv7h.tar.gz extracts to a directory named yay_x.y.z_armv7l. A quick fix made to the PKGBUILD would suffice, though renaming the directory inside the tarball might be more consistent.