Package Details: yay-bin 9.4.7-1

Git Clone URL: https://aur.archlinux.org/yay-bin.git (read-only, click to copy)
Package Base: yay-bin
Description: Yet another yogurt. Pacman wrapper and AUR helper written in go. Pre-compiled.
Upstream URL: https://github.com/Jguer/yay
Keywords: AUR go helper pacman wrapper
Licenses: GPL
Conflicts: yay
Provides: yay
Submitter: jguer
Maintainer: jguer
Last Packager: jguer
Votes: 123
Popularity: 12.22
First Submitted: 2016-12-03 15:06
Last Updated: 2020-05-01 15:42

Required by (7)

Sources (3)

Pinned Comments

jguer commented on 2019-10-23 08:31

Having issues updating yay and pacman at the same time?

yay -S yay-bin

sudo pacman -Syu

https://github.com/Jguer/yay/issues/1084

Latest Comments

1 2 Next › Last »

jguer commented on 2020-02-29 16:56

v9.4.5 binary version is delayed until multiarchitecture builds get fixed

rEnr3n commented on 2020-01-19 08:09

@tee Users are expected to have base-devel installed when using aur. https://wiki.archlinux.org/index.php/Arch_User_Repository#Getting_started

tee commented on 2020-01-19 07:35

==> Validating source_x86_64 files with sha1sums...
    yay_9.4.4_x86_64.tar.gz ... Passed
==> Removing existing $srcdir/ directory...
==> Extracting sources...
  -> Extracting yay_9.4.4_x86_64.tar.gz with bsdtar
==> Sources are ready.
==> ERROR: Cannot find the fakeroot binary.
Error making: yay-bin

Also depends on fakeroot

tee commented on 2020-01-19 07:31

$ ./yay -S yay-bin
:: Checking for conflicts...
:: Checking for inner conflicts...
[Aur: 1]  yay-bin-9.4.4-1

:: Downloaded PKGBUILD (1/1): yay-bin
  1 yay-bin                                  (Build Files Exist)
==> Diffs to show?
==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
==> 
:: Parsing SRCINFO (1/1): yay-bin
==> ERROR: Cannot find the strip binary required for object file stripping.
Error downloading sources: yay-bin

yay-bin depends on binutils which provides strip

jguer commented on 2019-10-24 02:05

ARM packages have been readded now that pacman 5.2 has reached core in archlinux arm

jguer commented on 2019-10-23 08:31

Having issues updating yay and pacman at the same time?

yay -S yay-bin

sudo pacman -Syu

https://github.com/Jguer/yay/issues/1084

jguer commented on 2019-10-23 08:16

Yes, I just saw this and this is something that may require manual action. yay 9.3.3 is preventing you from installing it because it breaks current deps, I'll be looking at the easiest upgrade path.

Archlinux ARM still doesn't have pacman 5.2 in its repositories, once it's added I'll add arm back to the PKGBUILD

bjo commented on 2019-10-23 08:13

No support for armv7h any more?

cwrau commented on 2019-10-23 08:11

Removing the dependency helped, kinda

Now I could install yay-bin, but without the dependency to pacman>5.2 I couldn't run yay again, I had to manually pacman -S pacman

cwrau commented on 2019-10-23 07:59

I cannot update this package, it errors with the following message:

λ yay -S yay-bin
:: Checking for conflicts...
:: Checking for inner conflicts...
[Repo: 1]  pacman-5.2.0-2
[Aur: 1]  yay-bin-9.4.0-1

  1 yay-bin                                  (Installed) (Build Files Exist)
==> Packages to cleanBuild?
==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
==> 
:: PKGBUILD up to date, Skipping (1/1): yay-bin
  1 yay-bin                                  (Installed) (Build Files Exist)
==> Diffs to show?
==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
==> 
:: Parsing SRCINFO (1/1): yay-bin
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing pacman (5.2.0-2) breaks dependency 'pacman<=5.1.3' required by yay-bin
Error installing repo packages