Package Details: yay 9.0.1-3

Git Clone URL: https://aur.archlinux.org/yay.git (read-only)
Package Base: yay
Description: Yet another yogurt. Pacman wrapper and AUR helper written in go.
Upstream URL: https://github.com/Jguer/yay
Keywords: AUR go helper pacman wrapper
Licenses: GPL
Submitter: jguer
Maintainer: jguer
Last Packager: jguer
Votes: 464
Popularity: 77.559611
First Submitted: 2016-10-05 17:20
Last Updated: 2018-12-07 14:06

Required by (5)

Sources (1)

Latest Comments

1 2 3 4 5 6 ... Next › Last »

Morganamilo commented on 2019-01-13 18:40

My guess is on https://github.com/Jguer/yay/issues/812

yay --bottomup --save should correct it.

jguer commented on 2019-01-13 18:35

==> Packages to NOT upgrade: (eg: 1 2 3, 1-3, ^4 or repo name)

Don't see anything wrong there

Thermi commented on 2019-01-13 17:37

Hi, I think the numbers in the "Packages to upgrade" menu aren't right. See the following.

:: 2 Packages to upgrade.
2  aur/python-cli_helpers  1.0.2-1 -> 1.1.0-1
1  aur/qemu-user-static    3.1-2   -> 3.1.0-1
==> Packages to not upgrade: (eg: 1 2 3, 1-3, ^4 or repo name)
==> 1
:: Checking for conflicts...
:: Checking for inner conflicts...
[Aur: 1]  python-cli_helpers-1.1.0-1

  1 python-cli_helpers               (Installed) (Build Files Exist)
==> Packages to cleanBuild?
==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
==> 

Nyutag commented on 2019-01-05 17:00

@hringriin. I was having the same issue. Also freshly installed ArchLinux 32bit.

Solved by using another repo from https://git.archlinux32.org/archlinux32/packages/raw/branch/master/core/pacman-mirrorlist/mirrorlist and pacman -Syyu

I get the last go package and successfully install yay.

hringriin commented on 2019-01-03 23:03

>$ makepkg
[...]
go build -v -ldflags '-s -w -X main.version=9.0.1' -o yay -mod=vendor
flag provided but not defined: -mod
make: *** [Makefile:51: build] Error 2

This is the output of makepkg on A freshly installed Arch Linux 32 bit.

I could see, that my version of the go package is 2:1.10.3-1.1 whereas the latest go version is 2:1.11.4-1, but, as of yet only for 64 bit architectures.

Is this due to my older version of go or am I missing something else?

Morganamilo commented on 2018-12-28 17:01

By default sudo will cache your password for 5 minutes.

WFV commented on 2018-12-28 16:26

Thanks for yay. Is it normal when running % yay -Sua for some packages to simply install but others ask for sudo password? (I've never used any wrappers for doing bulk aur package updates, nor system updates.)

schimicata commented on 2018-12-25 00:16

@twnaing I had the same error. I could fix it upgrading my installed package of "go".

eschwartz commented on 2018-12-24 18:44

@adizero you're not supposed to source this yourself. This installs a completion spec, but users who wish to use completions are supposed to install the bash-completion package as that both sets up the automatic lazy loading of completion specs, and contains the shared helper functions relied on by many command completions.

adizero commented on 2018-12-21 08:24

Shouldn't the bash-completion package be listed as an optional dependency? Without it an attempt to use the completion (after pressing <TAB>) fails. E.g.: $ source /usr/share/bash-completion/completions/yay $ yay bash: _get_comp_words_by_ref: command not found