Package Base Details: kodi-standalone-service

Git Clone URL: https://aur.archlinux.org/kodi-standalone-service.git (read-only, click to copy)
Submitter: graysky
Maintainer: graysky
Last Packager: graysky
Votes: 61
Popularity: 0.003999
First Submitted: 2014-11-05 20:25
Last Updated: 2020-02-02 19:47

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 10 ... Next › Last »

graysky commented on 2017-03-04 14:19

Bump to v1.90-1
Changelog: Run on vt1 not vt7 for increased compatibility.
Commit: https://github.com/graysky2/kodi-standalone-service/compare/v1.82...v1.90

graysky commented on 2017-03-04 14:17

@red - good point!

redbaron commented on 2017-03-04 10:34

Dual monitor is possible but for standalone HTPC it's not usual. And mostly this package is used on systems when KODI is started upon HTPC startup without any additional DE.

graysky commented on 2017-03-04 09:33

@redbaron - This is how it was originally setup by our team.[1] I think vt1 is the default for greeters. I can confirm that lxdm uses it anyway. Is it possible to have a box that drives both TV (HDMI1) and a monitor simultaneously (HDMI2 or DVI or DSUB, etc)?

1. https://git.archlinux.org/svntogit/community.git/commit/trunk?h=packages/xbmc&id=9763c6d32678f3a3f45c195bfae92eee209d504f

redbaron commented on 2017-03-03 21:20

I am using nvidia 378.13-3, but same problem. I think main problem is better described here https://bugs.archlinux.org/task/53090. Why not to use vt1 by default?

graysky commented on 2017-03-03 21:06

@red - Yes, on a box that needs the 340xx drivers, I too have to remove the vt7. Dunno if there is a fix in the works or not, see: https://git.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/nvidia-340xx-utils&id=d342a4bee79a215686d3c431215054b9ce0cc79f

redbaron commented on 2017-03-03 19:16

I have same problem as @ricrogz, removing vt7 helped but then shutdown function disappeared from kodi's "power options", changing vt7 to vt1 worked.

graysky commented on 2017-02-21 23:15

Does that series of nvidia cards use the 340xx drivers? Best to continue this in the thread you started[1].

1. https://bbs.archlinux.org/viewtopic.php?id=223409

invik commented on 2017-02-21 22:46

@graysky -- sorry, forgot to mention: the card is an Nvidia GT 610. Also, I am not running kodi as root: observe the "-u kodi" after the sudo.

I have been looking around the problem for several days now, and just a few minutes ago I made some progress:

The problem seems to be the "vt7" option at the end of the command line. Somehow, it looks like systemd dislikes it, and, if I lower the number (i.e. vt2 or vt3), or even remove the parameter, the errors in the Xorg log are gone, and kodi starts again (but takes a while to do so, but this seems more related to some issues with pulseaudio, which, despite all my attempts to disable it, still spawns every time I start kodi).

graysky commented on 2017-02-21 22:09

@ric - What hardware? Also, never run kodi as root. It's unsafe and potentially changes the permissions on /var/lib/kodi so that the kodi user cannot write to it and subdirs.

What I can tell you is that after an update a few days ago, my nvidia-340xx machine stopped running as the kodi user via the service. I enabled [testing] and updated and everything works again.