Package Base Details: libxml2-2.9

Git Clone URL: https://aur.archlinux.org/libxml2-2.9.git (read-only, click to copy)
Submitter: tallero
Maintainer: tallero (truocolo)
Last Packager: truocolo
Votes: 1
Popularity: 0.008209
First Submitted: 2023-07-03 11:28 (UTC)
Last Updated: 2024-02-26 17:48 (UTC)

Latest Comments

tallero commented on 2024-02-28 13:29 (UTC) (edited on 2024-02-28 14:42 (UTC) by tallero)

The package correctly provides libxml2 at version 2.9 to all programs who may need libxml2 version 2.9.

Packages which do need a version of libxml2 higher than 2.9 should report that into their dependencies using depends+=(libxml2>=2.10).

Viceversa packages depending on this should not include it directly, but setting depends+=(libxml2<2.9).

Keeping installed packages providing the same dependency at different versions should definitely not be something to be bothered with.

In case you were wondering, yes, I am aware some aur helpers could not be able to find this package since they may not be able to look for provides, but that's an issue of those helpers.

As you may know, as I have written to you in private about this a couple months ago, I am working myself on a new helper which hopefully will be able to tackle this and other issues, in particular the one which makes so the salary of our equivalent at Red Hat is money, while our is mostly complaints, for that surreal phenomenon which makes us visible when things do not work as expected and invisible when everything is fine and hard work has already been given over.

You know, over time it's an issue which has become quite stressful and in my opinion needs to be addressed.

I would agree it's an impossibly hard task to come up with something which will make everybody happy (as well as it is to come up with anything), in particular the few who do manage to get profit out of our free work, but it's not they weren't suggested to either take the lead themselves or accept the deal they offer our devs is not good enough for some devs to care about their business.

We like to say community, but reality is Marcello here is more community than a lot of high tulips.

MarsSeed commented on 2024-02-28 11:25 (UTC)

Please remove 'libxml' from provides: this is not a drop-in replacement for repo's libxml. It is not okay to allow uninstalling libxml if this package is installed - it will break many packages in a system.

florosus commented on 2023-07-20 16:12 (UTC) (edited on 2023-07-20 16:13 (UTC) by florosus)

This doesn't seem to work with python2-libxml2 and throws version 'LIBXML2_2.9.11' not found. I messing around with libxml2.syms in the python package, but that only changed the error to missing symbols.

Could you take a look?