Package Base Details: zfs-linux-lts

Git Clone URL: https://aur.archlinux.org/zfs-linux-lts.git (read-only, click to copy)
Submitter: demizer
Maintainer: minextu (archzfs-bot)
Last Packager: archzfs-bot
Votes: 77
Popularity: 1.50
First Submitted: 2016-04-24 19:05 (UTC)
Last Updated: 2024-02-20 18:47 (UTC)

Latest Comments

1 2 3 4 5 6 .. 9 Next › Last »

gromit commented on 2024-01-29 07:49 (UTC)

Why does 5da354537fd8 introduce some huge patch for kernel 6.7 while that is presumably not needed for the LTS version?

hoban commented on 2023-12-18 18:24 (UTC)

It looks like the CI build issues relate to the build infrastructure, rather than the package. I was able to build/install/run it locally without any issue:

❯ git clone https://aur.archlinux.org/zfs-linux-lts.git

❯ vim PKGBUILD
# <interactive output omitted, see diff below>

❯ git --no-pager diff
diff --git a/PKGBUILD b/PKGBUILD
index aad1ea7..71fdbb3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,9 +18,9 @@
 pkgbase="zfs-linux-lts"
 pkgname=("zfs-linux-lts" "zfs-linux-lts-headers")
 _zfsver="2.2.2"
-_kernelver="6.1.66-1"
-_kernelver_full="6.1.66-1"
-_extramodules="6.1.66-1-lts"
+_kernelver="6.1.68-1"
+_kernelver_full="6.1.68-1"
+_extramodules="6.1.68-1-lts"

 pkgver="${_zfsver}_$(echo ${_kernelver} | sed s/-/./g)"
 pkgrel=1

❯ makepkg -scir
# <package building output omitted>

❯ ls
PKGBUILD  zfs-2.2.2.tar.gz  zfs.install  zfs-linux-lts-2.2.2_6.1.68.1-1-x86_64.pkg.tar.zst  zfs-linux-lts-headers-2.2.2_6.1.68.1-1-x86_64.pkg.tar.zst

❯ pacman -Q | grep 6.1.68
linux-lts 6.1.68-1
linux-lts-headers 6.1.68-1
zfs-linux-lts 2.2.2_6.1.68.1-1
zfs-linux-lts-headers 2.2.2_6.1.68.1-1

❯ uname -r
6.1.68-1-lts
# <the above was post-reboot>

theking2 commented on 2023-09-16 08:43 (UTC)

build error ERROR: Could not push packages to remote testing repo!

LazyGamble commented on 2023-08-02 07:58 (UTC)

"No space left on device" https://ci.archzfs.com/#/builders/6/builds/2189

Who is currently maintaining the buildbot?

manchmalscott commented on 2023-08-01 02:56 (UTC)

At this point, I've decided to set up my own instance of the build server from https://github.com/archzfs/archzfs-ci/ (which has been it's own nightmare, the Dockerfiles required some heavy modification to build). I've lost trust in the maintainers of this package.

Shubby commented on 2023-08-01 02:36 (UTC)

Something isn't right with the CI build, the "current" build has been running for 5+ days and looks like it's in some weird failed state.

Erroneous commented on 2023-07-05 20:21 (UTC)

@Carlosgrr Building this package works best when you can install the dependencies and not the have the package installed itself. To do this, I recommend either building the package on another Arch installation or building inside of a chroot.

I use the aurutils AUR helper which can build packages inside a chroot environment. I'm not familiar with yay, but if it has chroot capabilities I would look into that.

Carlosgrr commented on 2023-07-05 19:11 (UTC)

And to me it seems like a cyclical dependency problem. This package needed linux-lts=6.1.37-1 to work, Yay noticing that tries to go back to linux-lts and upgrading it, but yay then checks packages that depend on linux-lts just to be safe upgrading, and then realizes, oh, the currently installed zfs-linux-lts needs 6.1.29-1, then yay breaks with the message:

error: Failed to prepare transaction (could not satisfy dependencies) :: installing linux-lts (6.1.37-1) breaks dependency "linux-lts=6.1.29-1" needed by zfs-linux-lts :: installing linux-lts (6.1.37-1) breaks dependency "linux-lts=6.1.29-1" needed by zfs-linux-lts-headers

To fix my immediate problem, all I did was uninstall the linux-lts and zfs-linux-lts, and tell yay to install zfs-linux-lts, hoping my power was not cut in the middle of the process, so that I would not need to use a recovery pen-drive, and everything was updated perfectly, but I am not sure if yay is it fault or is it this package dependencies.

@dmp1ce Indeed it is a shame Arch is not better integrated with ZFS, specially with cyclical dependency problems like this, but the good thing here in Arch is the community members are really helpful, like you just helped me understand the problem, and helped me reach a workaround. Thank you!

dmp1ce commented on 2023-07-04 20:39 (UTC)

@Carlosgrr I think the error means zfs-linux-lts is not up-to-date with the kernel. I could be wrong. I subscribe to this project in the AUR and when I get the notification that it has been updated, I rush to upgrade ASAP! Not a great solution but it is what works for me.

It is too bad Arch isn't better integrated with ZFS like some other distros like NixOS.

Carlosgrr commented on 2023-07-04 16:30 (UTC)

Just tried installing the new package released yesterday, using yay, here is the google translated error messages:

error: Failed to prepare transaction (could not satisfy dependencies) :: installing linux-lts (6.1.37-1) breaks dependency "linux-lts=6.1.29-1" needed by zfs-linux-lts :: installing linux-lts (6.1.37-1) breaks dependency "linux-lts=6.1.29-1" needed by zfs-linux-lts-headers

I am not that well versed with these package managers, but is it a problem with yay or is it this packages problem?