Package Base Details: zfs-linux-lts

Git Clone URL: https://aur.archlinux.org/zfs-linux-lts.git (read-only)
Submitter: demizer
Maintainer: minextu (archzfs-bot)
Last Packager: archzfs-bot
Votes: 44
Popularity: 0.830038
First Submitted: 2016-04-24 19:05
Last Updated: 2019-08-18 16:42

Latest Comments

« First ‹ Previous 1 2 3 4 5 Next › Last »

dangmai commented on 2017-02-11 16:36

I find that the archzfs repo usually lags behind quite a bit for the lts kernel, right now it's still pointing to the 4.4.46 kernel

Horus commented on 2017-01-29 11:36

./configure does not find spl.

Adding --with-spl=/usr/src/spl-0.6.5.8 to ./configure fixed it for me.

jdn06 commented on 2016-12-14 21:20

@demizer
Strange problem: the AUR packages have been updated, but not the archzfs repository.

GeorgP commented on 2016-10-19 08:45

Thanks for the great work.

This package is out-of-date for 3 days now. Is there a problem? Is it possible to help out somehow?

skrat commented on 2016-10-11 17:03

What's the problem with using the current kernel version (say, as provided by uname) in the PKGBUILD? I'm using custom kernel (repo-ck/linux-ck-ivybridge) and I think it's waste of time to generate a build for every custom kernel out there.

demizer commented on 2016-09-11 01:29

The packages have been updated for kernel 4.4.20-1

However, the initscripts have been refactored for this release. I have partly finished automated testing for booting archzfs at https://github.com/archzfs/archzfs/tree/master/testing/tests/archzfs-qemu-lts-test-01-root-bootfs

If anyone encounters any problems, please make an issue at https://github.com/archzfs/archzfs/issues


Also, we have had a number of contributors that made pull requests to make this happen. Please send them your thanks! See https://github.com/archzfs/archzfs/pulls?q=is%3Apr+is%3Aclosed

ackthet commented on 2016-08-23 13:48

I'm guessing this package and all the other -lts zfs pkgs need to be updated to use the newest version of the lts kernel. It wants 4.4.16, but the latest seems to be 4.4.19-1.

Shubby commented on 2016-06-13 21:39

@demizer I had done that as part of troubleshooting (deleted everything in there, not just one or the other package) but it made no difference.

ravi_n commented on 2016-06-11 04:12

I'm having the same problem (missing required signature) with the spl-linux-lts and spl-utils-linux-lts packages. When I look at the archzfs repository here: http://archzfs.com/archzfs/x86_64/

I noticed that spl-linux-lts-0.6.5.7_4.4.13_1-1-x86_64.pkg.tar.xz and spl-utils-linux-lts-0.6.5.7_4.4.13_1-1-x86_64.pkg.tar.xz do not have corresponding .sig files like the other packages do. Could that cause the problem we're seeing?

demizer commented on 2016-06-11 02:34

@shubby, try deleting the linux-lts packages in /var/cache/pacman/pkg one of the packages may have not downloaded correctly now the signature hash is not matching.