Package Base Details: zfs-linux-lts

Git Clone URL: https://aur.archlinux.org/zfs-linux-lts.git (read-only)
Submitter: demizer
Maintainer: minextu (archzfs-bot)
Last Packager: archzfs-bot
Votes: 44
Popularity: 0.743999
First Submitted: 2016-04-24 19:05
Last Updated: 2019-08-18 16:42

Latest Comments

« First ‹ Previous 1 2 3 4 5 Next › Last »

Shubby commented on 2016-05-13 12:49

Edit #3: see bottom for my fix.

Hi there,
Is there a problem with this morning's updates, or am I doing something wrong somehow? This is my first time upgrading the ZFS packages after setting up your repo, whereas before I was doing it through the AUR. So I ran a pacman -Syu this morning, it downloaded 15 packages, including the new 4.4.10 kernel and the relevant updated ZFS packages. I seem to be stuck here though:

:: Proceed with installation? [Y/n] y
(15/15) checking keys in keyring [##############################################################################################] 100%
(15/15) checking package integrity [##############################################################################################] 100%
error: spl-linux-lts: missing required signature
error: failed to commit transaction (invalid or corrupted package)
Errors occurred, no packages were upgraded.

I suspect the same issue would appear on any of the four ZFS packages, but this one is first in the list.

If I do a pacman-key -l you are listed at the bottom:
pub rsa2048/0EE7A126 2012-10-24 [SC]
uid [ full ] Jesus Alvarez <jeezusjr@gmail.com>
sub rsa2048/DAB97A2B 2012-10-24 [E]

I did a sudo pacman-key --lsign-key 0EE7A126 as well:
-> Locally signing key 5E1ABF240EE7A126...
==> Updating trust database...
gpg: next trustdb check due at 2016-10-19

I did a pacman -Sc just in case, but that didn't help.

I could set your entry in my pacman.conf not to worry about signatures but that seems like a bad workaround.

My next step would be to do what I've done in the past, which is to export my ZFS file system, uninstall the ZFS packages, upgrade my system, reinstall the ZFS packages, reimport my ZFS pool, but given the error I'm getting from pacman, I'm not sure that'll help with anything. So I haven't done that yet and I hope I don't have to (it's quick and rather painless but seems unnecessary).

I hope this isn't a glaringly obvious thing. I'm not new to Linux but rather new to Arch so it's totally possible I'm missing something.

Edit: FWIW I also tested this in a VM where your repo was not set up at all. I added it to pacman.conf, added your key, signed it locally, removed the AUR ZFS packages that were still installed, then ran pacman -Syu, rebooted due to the kernel upgrade. At this point I have no ZFS packages installed at all, so I attempted a pacman -S zfs-linux-lts but got the same error as on my main machine.

Edit #2: the non-LTS packages installed fine in my VM but I run the LTS kernel by default.

Edit #3: so I fixed it but I don't know if it's really a fix. I'm not sure if that was something I should have done from the beginning, or if something is not right with the package, but anyway, I added "SigLevel = Optional TrustedOnly" to the archzfs repo. I read the pacman man page and decided that was a sufficient level of security. But I still don't understand why I could update the zfs-linux package without setting the SigLevel.

demizer commented on 2016-04-25 06:38

Hello,

To use the archzfs repository, see https://wiki.archlinux.org/index.php/Unofficial_user_repositories#archzfs

Please Note:

These packages and repos only support x86_64 architecture.

Thank

demizer commented on 2016-04-25 06:37

Hello,

I have a number of breaking changes to report.

The archzfs-lts group is dead! It has been renamed to "archzfs-linux-lts"

https://aur.archlinux.org/packages/zfs-linux-lts/#news

also, the demz-repo-core repository has been moved to https://wiki.archlinux.org/index.php/Unofficial_user_repositories#archzfs

I am waiting for AUR volunteers to merge this the archzfs-lts packages into the archzfs-linux-lts packages.

Sorry for the inconvenience these changes may have caused. I don't anticipate having to do this ever again. These changes will allow me to support more non-standard kernels in the future!

Thanks

demizer commented on 2016-04-22 15:58

@jdn06 updated. Sorry about that.

jdn06 commented on 2016-04-22 15:35

@demizer
Hello, I think you forgot to update the repo.

demizer commented on 2015-09-19 23:31

@here - FYI there was a zvol corruption bug that affected some users using trim/discard mount options. See https://github.com/zfsonlinux/zfs/releases/tag/zfs-0.6.5.1 and https://github.com/zfsonlinux/zfs/pull/3798 and https://github.com/zfsonlinux/zfs/issues/3754

demizer commented on 2015-09-19 22:54

Sorry, I pushed 3.14.52-1 but there is a new ZFS release. I am bulding it now.

demizer commented on 2015-07-06 21:40

Please see https://github.com/archzfs/archzfs#submitting-changes on how to contribute changes to the archzfs project.

demizer commented on 2015-07-06 21:38

The switch to AUR4 presents complications in the way patches are submitted to the archzfs project. Please see https://github.com/archzfs/archzfs#submitting-changes for details.

demizer commented on 2014-12-11 00:49

I like the flag to be set if there is any problem at all. The first thing I do is check this page. Thanks!