summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2024-05-18 17:34:16 -0600
committerMark Wagie2024-05-18 17:34:16 -0600
commit6eed6acd11a936b56fa8485d36da806910e89448 (patch)
tree0cf31fc6403d9f57742ee550fafe32e1b9e4c5ca /PKGBUILD
parent659f5fed909c5f85485fe991d23890e145836b58 (diff)
downloadaur-alpm_octopi_utils.tar.gz
rebuild with Cmake
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 10 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3a20150f94d8..5d80f79f0096 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,33 +2,26 @@
# Contributor: MatMoul <matmoul at the google email domain which is .com>
pkgname=alpm_octopi_utils
pkgver=1.0.2
-pkgrel=5
+pkgrel=6
pkgdesc="Alpm utils for Octopi"
arch=('x86_64')
url="https://github.com/aarnt/alpm_octopi_utils"
license=('GPL-3.0-or-later')
depends=('pacman-contrib')
-makedepends=('git' 'vala')
+makedepends=('cmake' 'git' 'vala')
provides=('alpm-octopi-utils')
_commit=1e735c3a27803ca5b6470e946f9cac708143dfd9 # master
-source=("git+https://github.com/aarnt/alpm_octopi_utils.git#commit=$_commit"
- 'https://github.com/aarnt/alpm_octopi_utils/pull/4.patch')
-sha256sums=('SKIP'
- 'c117f3a86f6428f671723b921229fdfe3e61b057efae1e0b3b2b1a2993ef8842')
-
-prepare() {
- cd alpm_octopi_utils
-
- # Add DESTDIR to Makefile
- patch -Np1 -i ../4.patch
-}
+source=("git+https://github.com/aarnt/alpm_octopi_utils.git#commit=$_commit")
+sha256sums=('SKIP')
build() {
- cd alpm_octopi_utils
- make
+ cmake -B build -S alpm_octopi_utils \
+ -DCMAKE_BUILD_TYPE='None' \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -Wno-dev
+ cmake --build build
}
package() {
- cd alpm_octopi_utils
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" cmake --install build
}